Go Back   Corvette Forum > C1 & C2 Corvettes, 1953 - 1967 > C1 & C2 Corvettes
Sign in using an external account
Register Forgot Password?
Register Search Today's Posts Mark Forums Read FAQ Vendor Directory
Search
C1 & C2 Corvettes
General C1 Corvette & C2 Corvette Discussion, Technical Info, Performance Upgrades, Project Builds, Restorations Sponsored by
Flaming River
Industries

Welcome to Corvetteforum.com!
Welcome to Corvetteforum.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Corvetteforum.com today!


Corvette Store
 
 
C7 Parts & Accessories
C6 Parts & Accessories
C5 Parts & Accessories
C4 Parts & Accessories
C3 Parts & Accessories
C2 Parts & Accessories
C1 Parts & Accessories
Wheels & Tires
Sponsored Ads
 
 
Vendor Directory
  
Reply
 
 
 
 
Thread Tools Search this Thread
Old 02-11-2010, 02:26 PM   #1
jopat86
Junior Member
 
Member Since: Feb 2010
Default Ignition switch wiring

Hello all, new to the forum.
Need a little help.
C1 with, as far as I know, original wiring harness.
Installed a new ignition switch after a few too many yrs of just sitting, me and the car.
As luck would have it the orig switch was wired wrong to begin with.
I've tried to figure it out without frying anything but still having problems. It'll start and run but it won't shut off. Put the switch in off position and still runs.
I've searched all the threads and looked at the wiring diagram. Nothing tells me what wires from harness, etc. go on which terminals on the switch.
Right now I have:
Pink-ACC
Red-BAT
Brown-IGN
Pink-BAT
Violet-SOL
Any help with what color wires go where on the switch would be great.
Thanks
jopat86 is offline   Reply With Quote
Old 02-11-2010, 03:19 PM   #2
Frankie the Fink
CF Senior Member
Support Corvetteforum!
 
Frankie the Fink's Avatar
 
Member Since: Aug 2007
Location: Winter Garden Florida
Default

There is no labeling on my C1 schematics (e.g. IGN or ACC) for the back of the ignition switch....a picture with your wires connected would aid greatly in troubleshooting.
Frankie the Fink is offline   Reply With Quote
Old 02-11-2010, 05:08 PM   #3
Sxrxrnr
CF Senior Member
Support Corvetteforum!
 
Sxrxrnr's Avatar
 
Member Since: Nov 2009
Location: Milpitas California
Default

What year C1? I have Dr. Rebuild schematic for a 59.
Sxrxrnr is offline   Reply With Quote
Old 02-11-2010, 05:10 PM   #4
jopat86
Junior Member
 
Member Since: Feb 2010
Default

1960
jopat86 is offline   Reply With Quote
Old 02-11-2010, 05:22 PM   #5
Donald #31176
CF Senior Member
 
Member Since: Jul 2004
Default

Are you using Delco 577 ignition switch ? The stock ignition harness had a 3 wire plug that connected the solenoid ( violet) battery (red) and ignition(brown) to the switch.. The 2 pink wires are Acc & battery. If the pink wires are connected wrong the turn signal will work in the off or lock position and you just reverse them.







/
Donald #31176 is offline   Reply With Quote
Old 02-11-2010, 05:40 PM   #6
DZVette
CF Senior Member
Support Corvetteforum!
 
DZVette's Avatar
 
Member Since: Sep 2001
Location: Aggieland TX
Default

I'll send you some pics when I get home.

DZ
DZVette is offline   Reply With Quote
Old 02-11-2010, 05:52 PM   #7
jopat86
Junior Member
 
Member Since: Feb 2010
Default

Using a replacement switch. Says Danchuck on it. Bought from a catalog.
If that's correct wiring then I'm good. Directionals switch not hooked up so I don't know if pink wires are correct.
Might I have a bad switch?
When running I switch to off position, guages go off, engine keeps running.
jopat86 is offline   Reply With Quote
Old 02-11-2010, 06:35 PM   #8
TroyPyles
CF Senior Member
 
TroyPyles's Avatar
 
Member Since: Feb 2005
Location: Saint George Utah
Default

Danchuck makes parts for passenger cars - 55 to 57 I believe. Switch might not be the same as Vette?
TroyPyles is offline   Reply With Quote
Old 02-11-2010, 06:49 PM   #9
DZVette
CF Senior Member
Support Corvetteforum!
 
DZVette's Avatar
 
Member Since: Sep 2001
Location: Aggieland TX
Default

Here's how I wired my 60 with the Lectric Limited dash harness. Also included is a pic from Don Olson's wiring diagram.

Hope these help.

Dave Z
Attached Images
 
Attached Images
File Type: pdf 1960 Ign Sw Wiring.pdf (196.8 KB, 219 views)
File Type: pdf IgnSwitchWiring-1960.pdf (246.7 KB, 220 views)
DZVette is offline   Reply With Quote
Old 02-11-2010, 10:05 PM   #10
Sxrxrnr
CF Senior Member
Support Corvetteforum!
 
Sxrxrnr's Avatar
 
Member Since: Nov 2009
Location: Milpitas California
Default

Quote:
Originally Posted by jopat86 View Post
1960
Doc Rebuild says on a 1959 which I have. However I've an after market wiring system (Ron Francis) in my car so all color coding is different in my car,,,for some ungodly reason. A real pain in the ****.

Looking at the 3 center posts of the switch that are stacked like a pyramid: 2 lower posts, with a single post above them.

Top of pyramid post is red wire that goes to amp gauge passenger side stud. This wire also T's off to go to voltage Regulator "B" Battery Terminal.

Right bottom post of pyramid is purple going to driver side terminal on coil resistor.

Left bottom post of pyramid is purple going to your start solenoid "S" ignition switch terminal.

On left side of pyramid as it stands upright, this post takes a pink wire that goes to fuse block Radio 20 amp fuse position (third from the bottom).

Underneath the bottom of the pyramid is a pink wire that goes to flasher terminal at fuse block,,the top horizontal slot position of the flasher receptacle.

The remaining post on the switch which is above the pyramid, shows as unused.

Again this is all for stock harness wiring in a 59 Vette.
Sxrxrnr is offline   Reply With Quote
Old 02-25-2010, 11:36 PM   #11
jopat86
Junior Member
 
Member Since: Feb 2010
Default Got it

Got the switch to work. Starts and shuts off correctly.
Without this forum I'm dead in the water.
Thanks for the help, really appreciate it.
Now on to the wiper motor.
jopat86 is offline   Reply With Quote
Old 02-26-2010, 08:10 AM   #12
Frankie the Fink
CF Senior Member
Support Corvetteforum!
 
Frankie the Fink's Avatar
 
Member Since: Aug 2007
Location: Winter Garden Florida
Default

Quote:
Originally Posted by jopat86 View Post
Got the switch to work. Starts and shuts off correctly.
Without this forum I'm dead in the water.
Thanks for the help, really appreciate it.
Now on to the wiper motor.
You ARE a glutton for punishment! However, there is prob better info in the ST-12 manual on the wiper motor than you could find on the ignition switch.

If the motor is really a mess there is a shop that will rebuild it (not cheap but they do it right), Capitol Restorations out of Maryland (Tom Maxwell)...
Frankie the Fink is offline   Reply With Quote
Old 01-24-2013, 01:42 PM   #13
four27
Junior Member
 
Member Since: Apr 2005
Default ignition switch.

If you use the trunk key in the ignition I think you cant shut down the car. That is exactly what happened to me. My local lock guy fixed my switch for 7 bucks.

RC Eugene Oregon


I have two ignition wires under dash I cant figure out what they go to. no matter which of the prongs I hook up everything still works Any ideas!
four27 is offline   Reply With Quote
Old 01-24-2013, 02:26 PM   #14
Frankie the Fink
CF Senior Member
Support Corvetteforum!
 
Frankie the Fink's Avatar
 
Member Since: Aug 2007
Location: Winter Garden Florida
Default

Folks - its a C1; there is NO ACC position on the ignition switch and one key fits EVERYthing (unless somebody swapped locks out at some point)...

One wire close to the ignition switch that can fool you sometimes is the one that goes to the light for the cigarette lighter. The light is missing in many cars (it was in mine) so you have a suspicious looking connector just hanging in space. If one of your wires is gray with a plastic enclosed female spade connector - it could well be the cigarette lighter light power feed.

If the wire reads 12V only when the light switch is pulled out then that is DEFINITELY what it is !
Frankie the Fink is offline   Reply With Quote
Old 01-24-2013, 02:26 PM
 
Go Back   Corvette Forum > C1 & C2 Corvettes, 1953 - 1967 > C1 & C2 Corvettes
Reload this Page Ignition switch wiring
 
 
 
Reply

Tags
1960, accig, b, bad, c1, colour, corvette, diagram, francis, harness, ignition, position, problems, ron, run, switch, wires, wiring


Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
81 Starter / Ignition Wiring Questions mattowen C3 Tech/Performance 0 04-23-2013 04:06 PM
HEI Tachometer & Ballast Resistor RK-TECT C1 & C2 Corvettes 4 11-24-2012 06:15 PM
Aftermarket Keyless Entry Help Deepa C4 Tech/Performance 8 04-08-2010 10:24 AM
Ignition switch wires TOM B1 C3 General 3 12-02-2009 08:43 AM
Bose replacement wiring tips/ search tips daytonaer Audio/Electronics 4 05-24-2008 03:49 PM


All times are GMT -4. The time now is 02:14 PM.


Emails & Password Backup