Go Back   Corvette Forum > C1 & C2 Corvettes, 1953 - 1967 > C1 & C2 Corvettes
Sign in using an external account
Register Forgot Password?
Register Search Today's Posts Mark Forums Read FAQ Vendor Directory
Search
C1 & C2 Corvettes
General C1 Corvette & C2 Corvette Discussion, Technical Info, Performance Upgrades, Project Builds, Restorations Sponsored by
Flaming River
Industries

Welcome to Corvetteforum.com!
Welcome to Corvetteforum.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Corvetteforum.com today!


Corvette Store
 
 
C7 Parts & Accessories
C6 Parts & Accessories
C5 Parts & Accessories
C4 Parts & Accessories
C3 Parts & Accessories
C2 Parts & Accessories
C1 Parts & Accessories
Wheels & Tires
Sponsored Ads
 
 
Vendor Directory
  
Reply
 
 
 
 
Thread Tools Search this Thread
Old 05-08-2013, 06:45 PM   #1
66jack
CF Senior Member
 
66jack's Avatar
 
Member Since: May 2006
Location: Redding CA
Default Well....that engine didn't last long.. :(

Remember that rattle/clatter I posted awhile back, may not have baring on the issue of late.

BUT?

Went for a ride last night and noticed the oil pressure was fluctuating...

Boogied on home, 'bout 3 miles away' keeping an eye on oil pressure...

Backed into garage like always and let it idle...NO OIL PRESSURE...shut it down fast...

Looked it over on top all clear, the oil pressure line was intact...

Decided to look underneath...PUDDLE OF OIL...

Checked the oil pan gasket this AM, all good...

Its gonna come out tomorrow...

I have that feeling its not gonna be good...

And, if its not good, the engine builder will get and earful...

Will let you know what i find...
66jack is online now   Reply With Quote
Old 05-08-2013, 06:58 PM   #2
Pugly
CF Senior Member
St. Jude Donor '11
 
Pugly's Avatar
 
Member Since: Feb 2010
Location: Sugar Land Texas
Default

That sux. Maybe it's just the cam plug or something simple...
Pugly is offline   Reply With Quote
Old 05-08-2013, 07:00 PM   #3
ejboyd5
CF Senior Member
 
ejboyd5's Avatar
 
Member Since: May 2006
Location: Southold New York
Default

. . . "rattle/clatter" is not good, but I have had engines that have lost all oil pressure and have survived. Do it step by step and we'll all hope for the best.
ejboyd5 is offline   Reply With Quote
Old 05-08-2013, 07:02 PM   #4
Frankie the Fink
CF Senior Member
Support Corvetteforum!
 
Frankie the Fink's Avatar
 
Member Since: Aug 2007
Location: Winter Garden Florida
Default

Maybe just an oil filter/canister gasket - happened to me in my '61.

Dumped 4 qts of oil on the highway after showing off with a 5K RPM
pass and shut down just as the oil pressure gauge started fluctuating
back and forth like a VU meter. That was 4 years
and 20,000 miles ago and no damage.

Don't panic yet.
Frankie the Fink is offline   Reply With Quote
Old 05-08-2013, 07:14 PM   #5
66jack
CF Senior Member
 
66jack's Avatar
 
Member Since: May 2006
Location: Redding CA
Default

Sorry guys..forgot to mention the leak was coming from the bottom out of the bell housing, so Pugly might bet right...

Frankie...

I have the adapter/spin on filter...No oil from that area..

Publy...

IF, its the cam plug it would be a simple fix, but with that 'rattle/clatter' i had earlier, i would want to investigate it further..
66jack is online now   Reply With Quote
Old 05-08-2013, 07:34 PM   #6
jimh_1962
CF Senior Member
 
jimh_1962's Avatar
 
Member Since: Feb 2004
Location: Norcal CA
Default

Jack, I am coming up there on Saturday. Let me know if you need any grunt work type help...
jimh_1962 is offline   Reply With Quote
Old 05-08-2013, 07:38 PM   #7
66jack
CF Senior Member
 
66jack's Avatar
 
Member Since: May 2006
Location: Redding CA
Default

Quote:
Originally Posted by jimh_1962 View Post
Jack, I am coming up there on Saturday. Let me know if you need any grunt work type help...
Thanks jim...my brother lives close so we should have it out by noon tomorrow...

I'm taking all the little stuff off tonight and draining the water tonight...
66jack is online now   Reply With Quote
Old 05-08-2013, 08:23 PM   #8
dahogan
CF Senior Member
Ohio Events Coordinator
St. Jude Donor '14
Support Corvetteforum!
 
dahogan's Avatar
 
Member Since: May 2008
Location: 10th District Court OHIO
Default

So what color is your dipstick tube? Hope all goes well

http://forums.corvetteforum.com/c1-a...tick-tube.html
dahogan is online now   Reply With Quote
Old 05-08-2013, 08:54 PM   #9
66jack
CF Senior Member
 
66jack's Avatar
 
Member Since: May 2006
Location: Redding CA
Default

Quote:
Originally Posted by dahogan View Post
So what color is your dipstick tube? Hope all goes well

http://forums.corvetteforum.com/c1-a...tick-tube.html
Well the one that was in it was orange..but will blast it and paint it black...if I don't snap it of removing the engine...
66jack is online now   Reply With Quote
Old 05-08-2013, 09:11 PM   #10
DansYellow66
CF Senior Member
 
DansYellow66's Avatar
 
Member Since: Jan 2003
Location: Sherwood Arkansas
Default

Quote:
Originally Posted by 66jack View Post
Sorry guys..forgot to mention the leak was coming from the bottom out of the bell housing, so Pugly might bet right...

Frankie...

I have the adapter/spin on filter...No oil from that area..

Publy...

IF, its the cam plug it would be a simple fix, but with that 'rattle/clatter' i had earlier, i would want to investigate it further..
I knocked the cam plug loose on a Pontiac motor I changed the cam in once. Ran it out of oil but no lasting damage. Can't remember if I actually managed to drive it that way or was just letting in run in the driveway to break in the cam. the first bummer part is you have to at least pull the transmission to fix. The second bummer is you have to pull it out of a Corvette.
DansYellow66 is offline   Reply With Quote
Old 05-08-2013, 09:15 PM   #11
66jack
CF Senior Member
 
66jack's Avatar
 
Member Since: May 2006
Location: Redding CA
Default

Quote:
Originally Posted by DansYellow66 View Post
I knocked the cam plug loose on a Pontiac motor I changed the cam in once. Ran it out of oil but no lasting damage. Can't remember if I actually managed to drive it that way or was just letting in run in the driveway to break in the cam. the first bummer part is you have to at least pull the transmission to fix. The second bummer is you have to pull it out of a Corvette.
Hell, I'm getting to be a pro at RR'n this damn engine...

I think I will make a removable front clip....for future "F ups"...
66jack is online now   Reply With Quote
Old 05-08-2013, 11:12 PM   #12
jimh_1962
CF Senior Member
 
jimh_1962's Avatar
 
Member Since: Feb 2004
Location: Norcal CA
Default

Anytime you need help just let me know... Remember Tom does good job at arden machine shop. Hopefully, this is not the case...

Update on my car, I bought a new pan and gasket to replace the ones installed. I think the gasket is the wrong size. And the pan looked beat up so why not replace it. Not so correct restoration...

Hopefully, this will stop the front leak around the timing cover and the pan.
jimh_1962 is offline   Reply With Quote
Old 05-08-2013, 11:17 PM   #13
robert miller
CF Senior Member
 
robert miller's Avatar
 
Member Since: Jan 2007
Location: cookeville tennessee
Default

Quote:
Originally Posted by 66jack View Post
Hell, I'm getting to be a pro at RR'n this damn engine...

I think I will make a removable front clip....for future "F ups"...
I understand what you are saying here.
robert miller is offline   Reply With Quote
Old 05-08-2013, 11:17 PM
 
Go Back   Corvette Forum > C1 & C2 Corvettes, 1953 - 1967 > C1 & C2 Corvettes
Reload this Page Well....that engine didn't last long.. :(
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Low Oil Pressure ???? TopSpeedNeed C6 Tech/Performance 8 01-21-2014 04:40 PM
Oil press pegs when revving engine PapawMike C4 Tech/Performance 0 04-21-2013 04:10 PM
Oil Pressure XXX See06 C6 Z06 Discussion 0 11-21-2012 11:50 AM
losing oil baxsom C5 General 10 11-18-2012 06:26 PM
oil pressure problem... input wanted.. bags142 Autocrossing & Roadracing 5 07-09-2012 01:30 PM


All times are GMT -4. The time now is 08:34 PM.


Emails & Password Backup