Go Back   Corvette Forum > C1 & C2 Corvettes, 1953 - 1967 > C1 & C2 Corvettes
Sign in using an external account
Register Forgot Password?
Register Search Today's Posts Mark Forums Read FAQ Vendor Directory
Search
C1 & C2 Corvettes
General C1 Corvette & C2 Corvette Discussion, Technical Info, Performance Upgrades, Project Builds, Restorations Sponsored by
Flaming River
Industries

Welcome to Corvetteforum.com!
Welcome to Corvetteforum.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Corvetteforum.com today!


Corvette Store
 
 
C7 Parts & Accessories
C6 Parts & Accessories
C5 Parts & Accessories
C4 Parts & Accessories
C3 Parts & Accessories
C2 Parts & Accessories
C1 Parts & Accessories
Wheels & Tires
Sponsored Ads
 
 
Vendor Directory
  
Reply
 
 
 
 
Thread Tools Search this Thread
Old 07-30-2013, 01:41 PM   #1
blackvette58
CF Member
 
Member Since: Jul 2007
Default C1 Electrical Wiring Issues

Recently installed new wiring in my 1958. Everything works fine except the interior light and heater motor. Any suggestions for how to go about finding a remedy? Thanks.
blackvette58 is offline   Reply With Quote
Old 07-30-2013, 01:44 PM   #2
jimh_1962
CF Senior Member
 
jimh_1962's Avatar
 
Member Since: Feb 2004
Location: Norcal CA
Default

check the grounds and check the connections. You might need to clean the connections off. I would check to see you are gettiing power the end of the wires. The interior light works off of the headlight switch check to make sure it is connected. Did these items work before with the old wire harness? Fuse?
jimh_1962 is offline   Reply With Quote
Old 07-30-2013, 02:12 PM   #3
JohnZ
CF Senior Member
Support Corvetteforum!
 
Member Since: Oct 2000
Location: Washington Michigan
Default

Quote:
Originally Posted by blackvette58 View Post
Everything works fine except the interior light and heater motor. Any suggestions for how to go about finding a remedy? Thanks.
The heater motor has a really flaky design for grounding (through the outer temp cable coil wrap to the rear side of the center console faceplate). Add a secondary ground wire from a blower flange screw to a known good ground and it'll work fine.
JohnZ is offline   Reply With Quote
Old 07-30-2013, 02:12 PM
 
Go Back   Corvette Forum > C1 & C2 Corvettes, 1953 - 1967 > C1 & C2 Corvettes
Reload this Page C1 Electrical Wiring Issues
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
plugs and wires Soobz C5 Tech 8 10-26-2013 02:29 PM
One wire alternator 84wannabezo6 C4 Tech/Performance 3 07-02-2013 12:42 AM
Wiring halo rings Schmty1 C6 Corvette General Discussion 18 06-04-2013 10:00 PM
single wire alternator sun20ma C1 & C2 Corvettes 15 03-21-2013 09:19 AM
I need to identify some wires on an 80. 540 vette C3 Tech/Performance 2 09-21-2012 06:51 PM


All times are GMT -4. The time now is 12:30 AM.


Emails & Password Backup