C1 1957 speed cable question - CorvetteForum - Chevrolet Corvette Forum Discussion



C1 & C2 Corvettes
General C1 Corvette & C2 Corvette Discussion, Technical Info, Performance Upgrades, Project Builds, Restorations
Sponsored by:
Sponsored by:

C1 1957 speed cable question

Reply
 
 
 
Thread Tools Search this Thread
Old 02-16-2017, 03:18 PM   #1
68hemi
CF Senior Member
Thread Starter
 
Member Since: Nov 2003
Location: Cottonwood AZ
Posts: 149
Thanked 8 Times in 7 Posts
Default C1 1957 speed cable question

My speedo is disconnected at both the speedo head and trans. As I remember the cable comes out at the speedo head end, correct? I can't pull it out with my fingers. Don't want to put needle nose on it and break it without knowing for sure first.
68hemi is offline   Reply With Quote
Old 02-16-2017, 03:47 PM   #2
Todd H.
CF Senior Member
 
Todd H.'s Avatar
 
Member Since: Jul 2010
Location: Bemidji Minnesota
Posts: 467
Thanked 74 Times in 52 Posts
Default

yep. That cable should slide right out. Must not have been lubed for awhile.
Todd H. is offline   Reply With Quote
Go Back   CorvetteForum - Chevrolet Corvette Forum Discussion >
Reload this Page
  • C1 1957 speed cable question
  •  
     
    Reply

    Related Topics
    Thread Thread Starter Forum Replies Last Post
    79 speedo cable drwet C3 Tech/Performance 12 02-11-2016 01:50 PM
    Checking Speedomter with a drill 79vetter C3 General 1 09-16-2014 08:23 AM
    '72 speedo cable clip on back of speedo question AZDoug C3 Tech/Performance 4 02-02-2014 05:03 PM
    Speedo & Tach cable lube ? GATOR454 C3 Tech/Performance 1 11-29-2004 01:02 PM
    i need help removing my speedo cable kidice81 Factory Correct Resto 2 09-08-2001 06:26 PM


    Thread Tools Search this Thread
    Search this Thread:

    Click for Advanced Search

    Posting Rules
    You may not post new threads
    You may not post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are Off
    Pingbacks are Off
    Refbacks are Off

    Forum Jump


    All times are GMT -4. The time now is 06:07 AM.


     
    • Ask a Question
      Get answers from community experts
    What's your question?
    Send