Go Back   Corvette Forum > C3 Corvettes, 1968 - 1982 > C3 General
Sign in using an external account
Register Forgot Password?
Register Search Today's Posts Mark Forums Read FAQ Vendor Directory
Search
C3 General
General C3 Corvette Discussion not covered in Tech Sponsored by
Corvette America

Welcome to Corvetteforum.com!
Welcome to Corvetteforum.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Corvetteforum.com today!


Corvette Store
 
 
C7 Parts & Accessories
C6 Parts & Accessories
C5 Parts & Accessories
C4 Parts & Accessories
C3 Parts & Accessories
C2 Parts & Accessories
C1 Parts & Accessories
Wheels & Tires
Sponsored Ads
 
 
Vendor Directory
  
Reply
 
 
 
 
Thread Tools Search this Thread
Old 03-16-2012, 09:09 PM   #1
alconk
CF Senior Member
 
Member Since: Jun 2011
Default Wipers quit working??

My 82 wipers has been messed up since I bought the car, first the delay didn't work so I bought the bypass until the new modual is released and now I washed the car and went to turn on the wipers and they did not come on. I can hear the clicking at the motor itself but nothing. Fuse is good. Do you think the motor took a dump??
alconk is offline   Reply With Quote
Old 03-16-2012, 10:42 PM   #2
Willcox Corvette
Premium Supporting Vendor
St. Jude Donor '08-'09-'10-'11-'12-'13-'14
 
Willcox Corvette's Avatar
 
Member Since: Aug 2006
Location: Jeffersonville Indiana 812-288-7103
https://www.facebook.com/WillcoxCorvette
Send a message via MSN to Willcox Corvette
Default

Before you tear up the car looking for an issue lets test the motor on the car. Run a ground from the motor case to the engine.. see if the motor works.

If this fails then leave the ground in place and use the test below to verify the motor will run. If you do this test and the motor fails then you need a motor.

If you the motor fails the run test then post again..

Willcox

Click the image to open in full size.
Willcox Corvette is offline   Reply With Quote
Old 03-16-2012, 10:55 PM   #3
alconk
CF Senior Member
 
Member Since: Jun 2011
Default

Is there a way to bench test it?? Already have it off there car.
alconk is offline   Reply With Quote
Old 03-16-2012, 11:02 PM   #4
Willcox Corvette
Premium Supporting Vendor
St. Jude Donor '08-'09-'10-'11-'12-'13-'14
 
Willcox Corvette's Avatar
 
Member Since: Aug 2006
Location: Jeffersonville Indiana 812-288-7103
https://www.facebook.com/WillcoxCorvette
Send a message via MSN to Willcox Corvette
Default

The instructions above will work on the car or off the car!
Willcox Corvette is offline   Reply With Quote
Old 03-17-2012, 12:38 AM   #5
alconk
CF Senior Member
 
Member Since: Jun 2011
Default

Quote:
Originally Posted by Willcox Corvette View Post
The instructions above will work on the car or off the car!
Ok thanks, will do it in the morning. If it is the motor could that have been the problem with the delay all along?? I even had the delay rebuilt and when plugged in the wipers took off as soon as the key was turned on and the switch was off.
alconk is offline   Reply With Quote
Old 03-17-2012, 10:10 AM   #6
Willcox Corvette
Premium Supporting Vendor
St. Jude Donor '08-'09-'10-'11-'12-'13-'14
 
Willcox Corvette's Avatar
 
Member Since: Aug 2006
Location: Jeffersonville Indiana 812-288-7103
https://www.facebook.com/WillcoxCorvette
Send a message via MSN to Willcox Corvette
Default

I bumped the bench test video thread for you this morning. Use the one for the 69-72. Only difference is you won't have the 12 volt input wire that I attach to the motor first. All you need on your motor is power to the middle terminal, ground on the case and two jumper grounds to ground out each field.

Willcox

http://forums.corvetteforum.com/c3-g...post1579024830

Last edited by Willcox Corvette; 03-17-2012 at 10:17 AM.
Willcox Corvette is offline   Reply With Quote
Old 03-17-2012, 01:18 PM   #7
alconk
CF Senior Member
 
Member Since: Jun 2011
Default

Well I did the test and all it does it click, no movement at all. I take it that it's toast now. What do you recommend for a replacement? Autozone and others offer a reman from Cardone or I can get a reman that's a AC Delco for twice as much more.
alconk is offline   Reply With Quote
Old 03-18-2012, 10:18 AM   #8
Easy Mike
CF Senior Member
Cruise-In II Veteran
Support Corvetteforum!
 
Easy Mike's Avatar
 
Member Since: Jun 2000
Default

Quote:
Originally Posted by alconk View Post
...What do you recommend for a replacement?...
Order one from Willcox. They've already helped you out.
Easy Mike is offline   Reply With Quote
Old 03-18-2012, 02:27 PM   #9
alconk
CF Senior Member
 
Member Since: Jun 2011
Default

Quote:
Originally Posted by Easy Mike View Post
Order one from Willcox. They've already helped you out.
Yep well said Plan on some other items as well.
alconk is offline   Reply With Quote
Old 03-18-2012, 02:27 PM
 
Go Back   Corvette Forum > C3 Corvettes, 1968 - 1982 > C3 General
Reload this Page Wipers quit working??
 
 
 
Reply

Tags
c3, corvette, ield, repair, wiper, wipers, working


Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 10:22 AM.


Emails & Password Backup