How many pumps? - CorvetteForum - Chevrolet Corvette Forum Discussion


C3 General
General C3 Corvette Discussion not covered in Tech
Sponsored by:
Sponsored by:

How many pumps?

Reply
 
 
 
Thread Tools Search this Thread
Old 08-03-2013, 06:46 PM   #1
Chicagodogs
CF Member
Thread Starter
 
Chicagodogs's Avatar
 
Member Since: Mar 2013
Location: Hanover Park Illinois
Posts: 81
Thanks: 0
Thanked 0 Times in 0 Posts
Default How many pumps?

How many pump the pedal before cranking over the motor? If you do, how many pumps?
Chicagodogs is offline   Reply With Quote
Old 08-03-2013, 07:38 PM   #2
4SPDL81
CF Senior Member
St. Jude Donor '16
 
4SPDL81's Avatar
 
Member Since: Aug 2010
Posts: 335
Thanked 5 Times in 5 Posts
Default

Takes 4-5 when cold and has set for a week or more, none when warm...good luck!
4SPDL81 is offline   Reply With Quote
Old 08-03-2013, 08:19 PM   #3
79L824SPD
Junior Member
 
Member Since: Apr 2008
Location: Dodgeville Wisconsin
Posts: 42
Thanked 0 Times in 0 Posts
Default

Yea, Same here. Seems like mine starts quicker if its been sitting a week rather than a few days.
79L824SPD is offline   Reply With Quote
Old 08-03-2013, 08:20 PM   #4
DC3
CF Senior Member
 
DC3's Avatar
 
Member Since: Apr 2001
Location: Lubbock Texas
Posts: 1,017
Thanks: 0
Thanked 0 Times in 0 Posts
Default

When cold, once all the way to floor to set the choke, then turn the key and it fires right up. That's when driving it every day. If I let it sit for several days, I have to pump twice then hold the throttle down about 1/2 way.

When warm, most of the time I don't have to pump at all but sometimes it takes holding the throttle about 1/2 way.

DC
DC3 is offline   Reply With Quote
Old 08-03-2013, 08:32 PM   #5
claysmoker
CF Senior Member
St. Jude Donor '09-'11-'12-'13-'14
 
claysmoker's Avatar
 
Member Since: Dec 2004
Location: PARADISE
Posts: 8,250
Thanked 40 Times in 36 Posts
Default

One cold and none hot.
claysmoker is offline   Reply With Quote
Old 08-03-2013, 08:58 PM   #6
'75
CF Senior Member
 
'75's Avatar
 
Member Since: Dec 2007
Location: McHenry Illinois
Posts: 5,012
Thanked 166 Times in 162 Posts
Default

Quote:
Originally Posted by claysmoker View Post
One cold and none hot.
If the choke is set up properly, this works every time. If it's been sitting a week or longer it just cranks a few seconds longer. but no pumping.
'75 is offline   Reply With Quote
Old 08-03-2013, 09:26 PM   #7
68/70Vette
CF Senior Member
 
Member Since: Jul 2004
Location: Torrance California
Posts: 19,081
Thanks: 0
Thanked 8 Times in 6 Posts
Default

Never pump the gas pedal. I have an Aeromotive Street and Strip electric fuel pump. When I hit the ignition key position, the pump turns on and at the same time the starter turns over the engine. The engine might make a couple of rpm's but then it fires up.
68/70Vette is offline   Reply With Quote
Old 08-03-2013, 09:28 PM   #8
Ironcross
CF Senior Member
 
Ironcross's Avatar
 
Member Since: Nov 2002
Location: Taylor Michigan
Posts: 12,146
Thanked 21 Times in 18 Posts
Default

I just reach in through the window and turn the key and it lits right up....but its a FI Vette
Ironcross is offline   Reply With Quote
Old 08-03-2013, 11:39 PM   #9
kdf1986
CF Senior Member
 
kdf1986's Avatar
 
Member Since: Jun 2004
Location: Campbell ca
Posts: 4,454
Thanked 13 Times in 13 Posts
Default

maybe 3 pumps. But I drive it every Friday to work. So it sits for 1 week. At work, I only have to pump it 1 time.

kdf
kdf1986 is offline   Reply With Quote
Old 08-04-2013, 12:46 AM   #10
7T1vette
CF Senior Member
 
7T1vette's Avatar
 
Member Since: Jan 2006
Location: Crossville TN
Posts: 27,398
Thanked 472 Times in 426 Posts
Default

One....just to set the choke and pump some fuel in the intake. Wait 3 seconds and start it. If you need to do more than that, you don't have the choke set up right...or the accelerator pump isn't working properly...

or you have a Holley!!!!
7T1vette is offline   Reply With Quote
Old 08-04-2013, 06:36 AM   #11
scottw
CF Senior Member
 
scottw's Avatar
 
Member Since: Oct 2001
Location: Okinawa Okinawa
Posts: 1,240
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by 7T1vette View Post

or you have a Holley!!!!
Street Avenger. One pump to set the choke, turn key, fires right up. Every time.

Thanks to lars setting up the carb for me.
scottw is offline   Reply With Quote
Old 08-04-2013, 06:41 AM   #12
Haggisbash
CF Senior Member
 
Member Since: Oct 2012
Location: Dunedin NZ.
Posts: 1,102
Thanked 24 Times in 24 Posts
Default

One pump, full choke (manual choke) when cold fires move immediately to 1/3 choke, Holley carb.
Haggisbash is offline   Reply With Quote
Old 08-04-2013, 08:13 AM   #13
7T1vette
CF Senior Member
 
7T1vette's Avatar
 
Member Since: Jan 2006
Location: Crossville TN
Posts: 27,398
Thanked 472 Times in 426 Posts
Default

OK, OK.... that was an attempt at humor -- not a vendetta against Holley carbs.

That's the way all carbs should work, anyway.
7T1vette is offline   Reply With Quote
Old 08-04-2013, 10:09 PM   #14
Mod75
CF Senior Member
 
Mod75's Avatar
 
Member Since: Jan 2007
Location: Danville Illinois
Posts: 4,396
Thanks: 0
Thanked 16 Times in 16 Posts
Default

Have manual choke but don't use it, cold 2 pumps, hot nothing.
Mod75 is offline   Reply With Quote
Old 08-04-2013, 10:48 PM   #15
kwplot34
CF Senior Member
 
kwplot34's Avatar
 
Member Since: Feb 2007
Location: liberty mo
Posts: 307
Thanks: 0
Thanked 0 Times in 0 Posts
Default

pump it twice, wait about 5 seconds,turn the key and it fires right up. even after sitting for several weeks. And i dont even have a choke on my carb.
kwplot34 is offline   Reply With Quote
Old 08-05-2013, 08:43 AM   #16
Redwing01
CF Senior Member
C3 of Month Finalist 2015
 
Redwing01's Avatar
 
Member Since: Mar 2012
Location: Belle River Ontario
Posts: 1,200
Thanks: 0
Thanked 0 Times in 0 Posts
Default

2 here as well. Fires up every time.
Redwing01 is offline   Reply With Quote
Old 08-05-2013, 09:45 AM   #17
Dustup7T2
CF Senior Member
Support Corvetteforum!
 
Dustup7T2's Avatar
 
Member Since: Oct 2007
Location: Northern CO
Posts: 2,572
Thanked 8 Times in 8 Posts
Default

I mounted a chokeless Demon double pumper on mine. Same basic design as a mechanical double-pumper Holley. Fed by a factory-style mechanical fuel pump and 10 degrees of initial timing on a Comp Cams Magnum 292.

1 pump cold and lightly feather the throttle after start to clear its throat. Part throttle to none warm, gets mine back to idle.
Dustup7T2 is offline   Reply With Quote
Old 08-05-2013, 12:28 PM   #18
Chinaski
CF Senior Member
St. Jude Donor '14
 
Chinaski's Avatar
 
Member Since: Apr 2002
Location: Northridge California
Posts: 26,370
Thanked 6 Times in 6 Posts
Default

Twice when cold, none when warm.
Chinaski is offline   Reply With Quote
Old 08-05-2013, 02:36 PM   #19
jcloving
CF Senior Member
 
jcloving's Avatar
 
Member Since: Dec 2010
Location: Winston Salem NC
Posts: 917
Thanks: 0
Thanked 0 Times in 0 Posts
Default

cold: one pump before I turn the key, one while I turn it to start. It turns over for maybe 2-3 seconds and then fires up.

hot. just turn the key and it roars to life

Last edited by jcloving; 08-05-2013 at 02:40 PM.
jcloving is offline   Reply With Quote
Go Back   CorvetteForum - Chevrolet Corvette Forum Discussion >
Reload this Page
  • How many pumps?
  •  
     
    Reply

    Related Topics
    Thread Thread Starter Forum Replies Last Post
    E85 fuel pump Maligator C6 Z06 Discussion 10 03-31-2014 03:14 PM
    98 fuel pump akamam98 C5 General 5 02-01-2012 09:53 AM
    Labor Hours... Power sreering pump?? Fastbasser C5 Tech 5 08-14-2010 01:21 PM
    water pump gallons fugawi C3 Tech/Performance 4 08-11-2010 12:18 PM
    How many amps for fuel pump switch vstol C1 & C2 Corvettes 7 10-17-2006 03:57 PM


    Thread Tools Search this Thread
    Search this Thread:

    Click for Advanced Search

    Posting Rules
    You may not post new threads
    You may not post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are Off
    Pingbacks are Off
    Refbacks are Off

    Forum Jump


    All times are GMT -4. The time now is 11:42 AM.


     
    • Ask a Question
      Get answers from community experts
    What's your question?
    Send