Any TH400 experts? Trans. pump whining like crazy...and more! - CorvetteForum - Chevrolet Corvette Forum Discussion

Register FAQ Search Today's Posts Mark Forums Read Vendor Directory

C3 Tech/Performance
V8 Technical Info, Internal Engine, External Engine, Basic Tech and Maintenance for the C3 Corvette

Any TH400 experts? Trans. pump whining like crazy...and more!

Reply
 
 
 
Thread Tools Search this Thread
Old 04-19-2003, 12:46 AM   #1
ORVette
CF Senior Member
Thread Starter
 
ORVette's Avatar
 
Member Since: Apr 2001
Location: Springfield Oregon
Posts: 752
Thanks: 0
Thanked 0 Times in 0 Posts
Default Any TH400 experts? Trans. pump whining like crazy...and more!

I noticed my trans was having some trouble shifting into 3rd gear. It just sort of held 2nd, even at part throttle, then just kind of slid over into 3rd. Today, it wouldn't even slide into 3rd, just stayed in second until I let off, then felt like I pushed the clutch in, and had to rev up in second to get it to go again. Plus, it was starting out in second after coming to a stop unless I manually shifted it into low. In addition to all this, the pump is whining like crazy when I get above a couple thousand RPM. I tried adjusting the modulator up and down. I pulled the pan to check if my valve body bolts were loose, and there were a couple pretty good size metal shavings in the pan, along with a lot of metal "dust". Is it time for a new trans? :sad:
ORVette is offline   Reply With Quote
Old 04-19-2003, 02:08 AM   #2
427Hotrod
CF Senior Member
 
427Hotrod's Avatar
 
Member Since: Jan 2000
Location: Houston, Tx
Posts: 9,790
Thanks: 0
Thanked 158 Times in 127 Posts
Default Re: Any TH400 experts? Trans. pump whining like crazy...and more! (ORVette)

Sounds like pump is toast. How long has it been since you changed filter? I have new ones "suck up" and restrict flow enough to not move at all.

It's been awhile since I had one, but the best filters used to be the ones that you could NOT see the filter media as you looked into the pickup hole in the filtr body. You just see the metal of the other side of filter housing. The lower $$ generic ones often plug very easily especially if you have a shift kit with increased line pressure springs or shims in pump.

Also make sure the O rings are in good shape on the plastic pickup tube that the filter attaches to. The ones on the trans end often split and will suck air .

Hopefully you caught it before too much damage was done.

JIM
427Hotrod is offline   Reply With Quote
Old 04-19-2003, 02:17 AM   #3
ORVette
CF Senior Member
Thread Starter
 
ORVette's Avatar
 
Member Since: Apr 2001
Location: Springfield Oregon
Posts: 752
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Any TH400 experts? Trans. pump whining like crazy...and more! (427Hotrod)

I changed the filter last spring when I installed the B&M trans pak. It was kind of a cheap one, $7.99 for it and the gaskat in a kit I think. Are you saying that the pump is toast AND the filter could be a problem too? Or should I switch the filter and see if that does it (the O rings too)? I did notice that after I put in the kit last year that my 1-2 shift was way firmer, but my 2-3 was actually alot less firm than before the kit. I went in and double checked that I had reassembled everything right, but it was still pretty slushy on the 2-3. I'm getting sick of dropping this pan! One good thing is that I installed a drain plug last year. Thanks for the info, any more is also appreciated.
ORVette is offline   Reply With Quote
Old 04-19-2003, 02:34 AM   #4
ORVette
CF Senior Member
Thread Starter
 
ORVette's Avatar
 
Member Since: Apr 2001
Location: Springfield Oregon
Posts: 752
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Any TH400 experts? Trans. pump whining like crazy...and more! (ORVette)


Also, just to be sure, this part goes in with the spring up towards the trans and the disc towards the valve body? Right?
ORVette is offline   Reply With Quote
Old 04-20-2003, 12:29 AM   #5
427Hotrod
CF Senior Member
 
427Hotrod's Avatar
 
Member Since: Jan 2000
Location: Houston, Tx
Posts: 9,790
Thanks: 0
Thanked 158 Times in 127 Posts
Default Re: Any TH400 experts? Trans. pump whining like crazy...and more! (ORVette)

I'd for sure try a new filter first. If the filter is plugged it will whine. The only trick is if we caught it before much damage was done. It is common to have some "stuff" inthe pan, but those large metal pieces worry me.

How is reverse? Same clutches are involved as high gear it seems like, so it could be an indicator.

A pressure gauge reading off side of trans would tell you a lot. But I'd try filter first.

THe T-400 is not a hard trans to repair. You might have anew spring project!


JIM
427Hotrod is offline   Reply With Quote
Old 04-20-2003, 03:10 AM   #6
ORVette
CF Senior Member
Thread Starter
 
ORVette's Avatar
 
Member Since: Apr 2001
Location: Springfield Oregon
Posts: 752
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Any TH400 experts? Trans. pump whining like crazy...and more! (427Hotrod)

Thanks guys. I decided screw it and pulled it out today and took it in for a rebuild. Reverse was kind of messed up too. Had to sort of rev it up to get it to engage. This way I can start over fresh. Only took a couple hours to pull the trans and have it in the back of the truck, so I guess I'm getting good at it. I don't want anymore practice though.
ORVette is offline   Reply With Quote
Old 04-20-2003, 11:41 AM   #7
arrio76
CF Senior Member
 
arrio76's Avatar
 
Member Since: Apr 2002
Location: Newport News VA
Posts: 133
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Any TH400 experts? Trans. pump whining like crazy...and more! (ORVette)

>Thanks guys. I decided screw it and pulled it out today and took it in for a rebuild. Reverse was kind of messed up too. Had to sort of rev it up to get it to engage. This way I can start over fresh. Only took a couple hours to pull the trans and have it in the back of the truck, so I guess I'm getting good at it. I don't want anymore practice though.<

Pulling the unit is a good decision. Since you have heavy metal in the pan, it was really the only thing to do. It is evidence of some hard part failure and it would only get worse. Hopefully, there isn't too much damage.
Good luck.
arrio76 is offline   Reply With Quote
Go Back   CorvetteForum - Chevrolet Corvette Forum Discussion >
Reload this Page
  • Any TH400 experts? Trans. pump whining like crazy...and more!
  •  
     
    Reply

    Related Topics
    Thread Thread Starter Forum Replies Last Post
    C4 1989 auto-trans will not shift into 3,4,or overdrive juanway C4 General Discussion 12 04-30-2016 03:35 PM
    4l60e and torque converter puddingmmmmmmmm C4 Tech/Performance 8 04-30-2011 06:35 PM
    Auto Trans is a little sluggish and shifts back and forth?? DuffC5 C5 Tech 6 10-23-2006 01:24 AM
    muncie trans noise 66ragtop owner C1 & C2 Corvettes 24 11-27-2003 11:44 PM
    '85 700R4...Lost 3rd gear again... Blue85L98 C4 Tech/Performance 7 07-27-2002 12:56 PM


    Tags
    c4, change, filter, making, pan, pickup, pics, pump, screws, sound, th400, trans, tube, whine, whining

    Thread Tools Search this Thread
    Search this Thread:

    Click for Advanced Search

    Posting Rules
    You may not post new threads
    You may not post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are Off
    Pingbacks are Off
    Refbacks are Off

    Forum Jump


    All times are GMT -4. The time now is 03:25 PM.