Cruise Control Not Working - CorvetteForum - Chevrolet Corvette Forum Discussion

Register FAQ Search Today's Posts Mark Forums Read Vendor Directory

C4 General Discussion
General C4 Corvette Discussion not covered in Tech

Cruise Control Not Working

Reply
 
 
 
Thread Tools Search this Thread
Old 01-31-2012, 10:07 PM   #1
MikeIz 82VETTE
CF Senior Member
Thread Starter
 
MikeIz 82VETTE's Avatar
 
Member Since: Nov 2007
Location: Morgan City LA
Posts: 610
Thanks: 0
Thanked 0 Times in 0 Posts
Default Cruise Control Not Working

Hello guys, got a few questions and would appreciate any help i can get. thanks in advance!

Cruise control not working and wondering where i should start looking. is that a vacum issue or on C4's is it electronic?

thanks guys
MikeIz 82VETTE is offline   Reply With Quote
Old 01-31-2012, 10:15 PM   #2
Kmcoldcars
CF Senior Member
 
Kmcoldcars's Avatar
 
Member Since: Jan 2009
Location: Puyallup Washington
Posts: 2,752
Thanks: 0
Thanked 12 Times in 12 Posts
Default

On my 1992 it is vacuum operated. What year is your Corvette? ALWAYS include the year as the C4 Corvettes are not always the same.

I would check the vacuum at the hose going into the cruise control unit. With the car running just pull the hose off the cruise unit and stick your thumb over the end of the hose. If you have vacuum you will need to look elsewhere. If you do not have vacuum you will need to find out where the leak is.
Kmcoldcars is offline   Reply With Quote
Old 01-31-2012, 11:16 PM   #3
MikeIz 82VETTE
CF Senior Member
Thread Starter
 
MikeIz 82VETTE's Avatar
 
Member Since: Nov 2007
Location: Morgan City LA
Posts: 610
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sorry, it's a 96
MikeIz 82VETTE is offline   Reply With Quote
Old 01-31-2012, 11:22 PM   #4
jakers
CF Senior Member
St. Jude Donor '06
 
jakers's Avatar
 
Member Since: Feb 2005
Location: Midland Georgia
Posts: 3,198
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by MikeIz 82VETTE View Post
Sorry, it's a 96
Mike,

I fixed mine on my 94 by simply replacing the vacuum line. The old one had split. New one and it was fixed... .
jakers is offline   Reply With Quote
Old 01-31-2012, 11:50 PM   #5
MikeIz 82VETTE
CF Senior Member
Thread Starter
 
MikeIz 82VETTE's Avatar
 
Member Since: Nov 2007
Location: Morgan City LA
Posts: 610
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Cool! i will check for that and hopefully it's a easy fix!

thanks!
MikeIz 82VETTE is offline   Reply With Quote
Old 02-01-2012, 12:22 AM   #6
Azriel
CF Senior Member
 
Azriel's Avatar
 
Member Since: Jan 2010
Location: Austin TX
Posts: 1,998
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Mine too. What's the cruise control thingy look like?
Azriel is offline   Reply With Quote
Old 02-01-2012, 12:57 AM   #7
Kris_K
CF Senior Member
 
Kris_K's Avatar
 
Member Since: Oct 2011
Location: Fort Worth Texas
Posts: 271
Thanked 6 Times in 6 Posts
Default

Mine stopped working recently too. The CRUISE light doesn't come on anymore either, would that be from a bad switch?
Kris_K is offline   Reply With Quote
Old 02-01-2012, 05:22 AM   #8
CorvetteSonntag
Junior Member
 
CorvetteSonntag's Avatar
 
Member Since: Apr 2011
Location: Jupiter Florida
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by MikeIz 82VETTE View Post
Hello guys, got a few questions and would appreciate any help i can get. thanks in advance!

Cruise control not working and wondering where i should start looking. is that a vacum issue or on C4's is it electronic?

thanks guys



This is a picture of my 87( i have no idea if it is even remotely the same as yours). look all the way at the bottom right and you'll see a rounded looking mechanism(its right above the battery) with a cable coming out of it and leading to the side of the throttle body. that is the cruise control mechanism.

hope that helps
CorvetteSonntag is offline   Reply With Quote
Old 02-01-2012, 09:09 AM   #9
markKlein
CF Senior Member
 
Member Since: May 2007
Location: Boulder Co
Posts: 1,582
Thanks: 0
Thanked 15 Times in 15 Posts
Default

Quote:
Originally Posted by Kris_K View Post
Mine stopped working recently too. The CRUISE light doesn't come on anymore either, would that be from a bad switch?
I didn't think there was a cruise light??
markKlein is offline   Reply With Quote
Old 02-01-2012, 09:55 AM   #10
RollaMo-LT4
CF Senior Member
St. Jude Donor '10-'11-'12-'13-'14-'15-'16
 
RollaMo-LT4's Avatar
 
Member Since: Oct 2005
Location: Rolla Missouri
Posts: 10,081
Thanked 35 Times in 32 Posts
Default

Quote:
Originally Posted by Kris_K View Post
Mine stopped working recently too. The CRUISE light doesn't come on anymore either, would that be from a bad switch?
There is no cruise light on the C4

Quote:
Originally Posted by markKlein View Post
I didn't think there was a cruise light??
You are correct.
RollaMo-LT4 is offline   Reply With Quote
Old 02-01-2012, 10:10 AM   #11
Kris_K
CF Senior Member
 
Kris_K's Avatar
 
Member Since: Oct 2011
Location: Fort Worth Texas
Posts: 271
Thanked 6 Times in 6 Posts
Default

Now, I know it's been a while since I've used my cruise and I have a few different cars so I may be confused, but I thought I remembered seeing a CRUISE light in the dash of my 94 when the cruise was engaged.

UPDATE: I checked the owner's manual and no mention of a CRUISE light so I must have dreamt that one. Anyway, my cruise control definitely stopped working so I will just follow along and hopefully I solution will pop up.

Last edited by Kris_K; 02-01-2012 at 10:21 AM.
Kris_K is offline   Reply With Quote
Old 02-01-2012, 01:03 PM   #12
Goldcylon
Tech Contributor
 
Goldcylon's Avatar
 
Member Since: Aug 2006
Location: Glendale Arizona.. Resident Gold Cylon
Posts: 9,401
Thanked 47 Times in 44 Posts
Default

As stated there is no cruise on/off light. I wish there was so you know for sure its engaged at the switch level.


Reguardless another thing to look for beyond the vaccum line is the brake switch. If it is not centered on the top of the brake pedal arm cruise control will not engage. It must make contact with the brake arm. Also Cruise control can not set I believe below 20-25 Miles per hr.

Last edited by Goldcylon; 02-01-2012 at 01:06 PM.
Goldcylon is offline   Reply With Quote
Old 02-01-2012, 04:15 PM   #13
jon1all
CF Senior Member
 
jon1all's Avatar
 
Member Since: Jan 2010
Location: Sun City AZ
Posts: 588
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Goldcylon View Post
As stated there is no cruise on/off light. I wish there was so you know for sure its engaged at the switch level.


Reguardless another thing to look for beyond the vaccum line is the brake switch. If it is not centered on the top of the brake pedal arm cruise control will not engage. It must make contact with the brake arm. Also Cruise control can not set I believe below 20-25 Miles per hr.
Where is this brake switch located? The cruise on my 88 also quit working a few months ago & would like to find this brake switch to see if it's the problem.

Do I need to remove the kick panel above the brake pedal to see/find it? What does it look like? Thanks!
jon1all is offline   Reply With Quote
Old 02-01-2012, 04:39 PM   #14
Goldcylon
Tech Contributor
 
Goldcylon's Avatar
 
Member Since: Aug 2006
Location: Glendale Arizona.. Resident Gold Cylon
Posts: 9,401
Thanked 47 Times in 44 Posts
Default

Quote:
Originally Posted by jon1all View Post
Where is this brake switch located? The cruise on my 88 also quit working a few months ago & would like to find this brake switch to see if it's the problem.

Do I need to remove the kick panel above the brake pedal to see/find it? What does it look like? Thanks!
Its above your brake pedal you cant miss it. It needs to be centered on the brake pedal arm. No you do not need to remove the kick panel. Its really two switches with the electrical side normally the culprit




http://forums.corvetteforum.com/c4-t...-for-94-a.html

Last edited by Goldcylon; 02-01-2012 at 04:59 PM.
Goldcylon is offline   Reply With Quote
Go Back   CorvetteForum - Chevrolet Corvette Forum Discussion >
Reload this Page
  • Cruise Control Not Working
  •  
     
    Reply

    Related Topics
    Thread Thread Starter Forum Replies Last Post
    Cruise Control not working. button stuck. HELP! CHRIS925 C5 Tech 1 06-08-2016 11:32 AM
    2004, no cruise control in 6th gear Suehog6060 C5 Tech 9 10-03-2015 09:40 AM
    1987 Corvette Cruise Control - Help! vetterobert C4 Tech/Performance 7 11-16-2010 05:32 PM
    cruise control will not work rockinbobbyd C4 Tech/Performance 14 06-28-2006 10:06 PM
    cruise control not working help!! brandon1566 C5 Scan & Tune 4 07-08-2005 04:27 PM


    Tags
    2011, c4, camaro, control, corvette, cruise, problems, work, working

    Thread Tools Search this Thread
    Search this Thread:

    Click for Advanced Search

    Posting Rules
    You may not post new threads
    You may not post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are Off
    Pingbacks are Off
    Refbacks are Off

    Forum Jump


    All times are GMT -4. The time now is 05:55 AM.