Distributor issues... - CorvetteForum - Chevrolet Corvette Forum Discussion

Go Back   >
Log In 
Register FAQ Search Today's Posts Mark Forums Read Vendor Directory

C4 General Discussion
General C4 Corvette Discussion not covered in Tech

Distributor issues...

Reply
 
 
 
Thread Tools Search this Thread
Old 05-17-2013, 04:23 PM   #1
1984 Crossfire
Junior Member
Thread Starter
 
1984 Crossfire's Avatar
 
Member Since: Jan 2013
Location: Tyngsborough Massachusetts
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default Distributor issues...

Hey corvette forum, today i attempted to start my 84 after installing a new head gasket and wires. Problem is that the distributor doesn't seem to want to run correctly and is making a loud buzzing sound (like electricity arcing) and the car wont start. My question to you guys is if you would know what could cause this and weather or not its an easy fix or not. Any help is apreciated and i can take pictures of it if anyone needs it. Thanks in advance.
~Matt
1984 Crossfire is offline   Reply With Quote
Old 05-17-2013, 10:19 PM   #2
corvetteronw
CF Senior Member
Support Corvetteforum!
Cruise-In VII Veteran
Cruise-In VIII
St. Jude Donor '06-'07-'08-'09-'10-'11-'12-'13-'14-'15-'16
 
corvetteronw's Avatar
 
Member Since: Feb 2003
Location: Kingman AZ
Posts: 15,783

Thanked 86 Times in 67 Posts
Default

Review these steps and maybe even repeat them.
http://www.ehow.com/how_7147332_inst...-chevy-v8.html
corvetteronw is offline   Reply With Quote
Go Back   CorvetteForum - Chevrolet Corvette Forum Discussion >
Reload this Page
  • Distributor issues...
  •  
     
    Reply

    Related Topics
    Thread Thread Starter Forum Replies Last Post
    I haven't received my activation email Matt@MTI Help Forum 3 01-18-2016 01:09 AM
    Replacing a distributor on my 80 joefloyd C3 Tech/Performance 13 03-07-2014 06:14 PM
    81 distributor papapete C3 Tech/Performance 41 02-13-2014 12:00 PM
    WTB: Delco Remy D308R Distributor Cap 63vette427 C3 Parts for Sale/Wanted 0 12-23-2013 03:15 PM
    Transistor Ignition or not? mallie C1 & C2 Corvettes 2 05-17-2013 04:29 PM


    Thread Tools Search this Thread
    Search this Thread:

    Click for Advanced Search

    Posting Rules
    You may not post new threads
    You may not post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are Off
    Pingbacks are Off
    Refbacks are Off

    Forum Jump


    All times are GMT -4. The time now is 11:01 AM.