Trouble code 46 - VATS Anti Theft Circuit Fault - Corvette Forum

Go Back   >
Log In 
Register FAQ Search Today's Posts Mark Forums Read Vendor Directory

C4 Tech/Performance
L98 Corvette and LT1 Corvette Technical Info, Internal Engine, External Engine

Trouble code 46 - VATS Anti Theft Circuit Fault

Reply
 
 
 
Thread Tools Search this Thread
Old 04-21-2007, 10:26 PM   #1
C4Willie
Junior Member
Thread Starter
 
Member Since: Sep 2006
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Default Trouble code 46 - VATS Anti Theft Circuit Fault

I cleaned the ignition switch with electrical contact cleaner. Ran great for about 10 miles. It still runs but will barely accelerate. Could someone please explain how I test if the anti theft system is bad? Am I better off bypassing the system?

Thanks in advance for your help

The site I found suggested the following when I got code 46.

"With negative battery lead disconnected and using high pressure, non residue contact spray cleaner, spray into area where ignition key inserts followed by inserting and removing key several times. Check for open/short on harness from steering column VATS ignition key to ECM. Possible defective anti-theft module."
C4Willie is offline   Reply With Quote
Old 04-22-2007, 10:01 AM   #2
AGENT 86
CF Senior Member
 
AGENT 86's Avatar
 
Member Since: Jan 2003
Location: Summerland B.C. Canada
Posts: 19,664
Thanks: 0
Thanked 8 Times in 7 Posts
Default

If the car is running, I don't see VATS as being your problem, The only code you get is 46 ??
AGENT 86 is offline   Reply With Quote
Old 04-22-2007, 02:14 PM   #3
C4Willie
Junior Member
Thread Starter
 
Member Since: Sep 2006
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Default Agent 86...

Yep, the car is running. I just got back from bringing back from my parents house. Able to drive and actually able to reach +60 mph but it took a while and I really had to feather the gas. Push it past 1/4 throttle and she cuts out, let of and it stays running.

I check the codes when I got home and now the 46 is gone all I get is the 12 that you see anytime.

I suppose I may need to take it to a garage allthough I hate to give up.

I have already replaced the TPS, Cap/Rotor, Wires, Plugs and fuel filter. I also replaced the entire exhaust system from the manifolds back.

Is there a fuel management computer in these cars? Or is it one computer that runs everything? I had an 89 S-10 4cyl that had a similar problem and I had to replace the fuel magement computer. That was a little 4 cyl truck with a stick and it had like 3 or 4 computers on board!

Agent 86, and anyone who replies to this or the other post I had, Thank you. Everyone is very nice and helpful in this Forum.

Despite the rough stretch I am going through with my car I am extremely proud to be a Vette owner and I LOVE my car.
C4Willie is offline   Reply With Quote
Old 04-22-2007, 03:47 PM   #4
AGENT 86
CF Senior Member
 
AGENT 86's Avatar
 
Member Since: Jan 2003
Location: Summerland B.C. Canada
Posts: 19,664
Thanks: 0
Thanked 8 Times in 7 Posts
Default

Have you tested your fuel pressure ??
AGENT 86 is offline   Reply With Quote
Old 04-22-2007, 05:23 PM   #5
C4Willie
Junior Member
Thread Starter
 
Member Since: Sep 2006
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sorry, left that out. Yes I did test the fuel pressue Agent 86. Was good, around 40-42 even when the car starts to run bad.
C4Willie is offline   Reply With Quote
Old 04-22-2007, 08:41 PM   #6
AGENT 86
CF Senior Member
 
AGENT 86's Avatar
 
Member Since: Jan 2003
Location: Summerland B.C. Canada
Posts: 19,664
Thanks: 0
Thanked 8 Times in 7 Posts
Default

You should ask if there is anyone in your area with a laptop/software or scanner. Lot's of members here, have them.
AGENT 86 is offline   Reply With Quote
Old 04-22-2007, 11:49 PM   #7
C4Willie
Junior Member
Thread Starter
 
Member Since: Sep 2006
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thank you Agent 86. I actually just saw my Uncle a few hours ago. He has a scan tool that should work on my car. I hope to get it this week and finally solve this mystery.

Thank you again.
C4Willie is offline   Reply With Quote
Go Back   Corvette Forum >
Reload this Page
  • Trouble code 46 - VATS Anti Theft Circuit Fault
  •  
     
    Reply

    Related Topics
    Thread Thread Starter Forum Replies Last Post
    2002 z06 bad BCM? tiesi81 C5 Tech 7 02-24-2012 03:09 PM
    Anyone ever by-pass their VATS ? ladyinblack C4 Tech/Performance 3 12-10-2009 09:55 PM
    c4 anti theft system problem tck C4 Tech/Performance 9 10-13-2005 01:03 AM
    Key chime Randy93 C4 General Discussion 30 08-02-2005 07:50 PM
    VATS Question MAINEVETTE87 C4 General Discussion 4 03-07-2003 09:50 AM


    Tags
    01, 03, 46, 650, anti, board, c4, circuit, code, corvette, fault, pcm, prairie, theft, trouble, vehicle, villager

    Thread Tools Search this Thread
    Search this Thread:

    Click for Advanced Search

    Posting Rules
    You may not post new threads
    You may not post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are Off
    Pingbacks are Off
    Refbacks are Off

    Forum Jump


    All times are GMT -4. The time now is 10:17 AM.