Lazy Idle (1985) - CorvetteForum - Chevrolet Corvette Forum Discussion

Go Back   >
Log In 
Register FAQ Search Today's Posts Mark Forums Read Vendor Directory

C4 Tech/Performance
L98 Corvette and LT1 Corvette Technical Info, Internal Engine, External Engine

Lazy Idle (1985)

Reply
 
 
 
Thread Tools Search this Thread
Old 11-09-2009, 05:46 AM   #1
hln111
Junior Member
Thread Starter
 
hln111's Avatar
 
Member Since: Oct 2009
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Default Lazy Idle (1985)

Can't figure it out. I've replaced the IAC, 02 Sensor, reset the TPS to 54 and idle according to proceedure. Cleaned the throttle body. The problem I'm having is when the car is first started the idle is around 1100 rpm. It takes around 7-8 minutes to come down to 580 rpm's. After the car is warm and been driven when you come to a stop the idle doesn't come down immediately, it takes around 15 sec after your stopped.
To me the problem appears to have the traits of a vaccume leak but I can't seem to find one (and I've looked)

Ant suggestions would be appreciated.
85 Gold
hln111 is offline   Reply With Quote
Old 11-09-2009, 08:12 AM   #2
HlhnEast
CF Senior Member
 
HlhnEast's Avatar
 
Member Since: Nov 2008
Location: Jacksonville FL
Posts: 4,319
Thanked 10 Times in 10 Posts
Default

I have the same problem with my '85 and have been told that the throttle body needs to be serviced. I havent taken it off the car yet to see but I will be checking out these bushings when I clean it up.
HlhnEast is offline   Reply With Quote
Old 11-09-2009, 08:55 AM   #3
cumbercr
CF Senior Member
 
cumbercr's Avatar
 
Member Since: Mar 2008
Location: Santa Maria CA
Posts: 2,000
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have the exact same problem. I'll bet if you put your foot on the brake and tap on the accelerator, the idle will come down. I've checked the throttle cable thinking it was binding. That wasn't it. So I've purchased a scanner to see if its sensor related. The hunt goes on.
cumbercr is offline   Reply With Quote
Old 11-09-2009, 10:40 AM   #4
jmrl98
CF Senior Member
 
jmrl98's Avatar
 
Member Since: May 2002
Location: Hazel Park MI
Posts: 1,500
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I just installed a Holley 52MM TB, and my idle is way more steady. I noticed on my stock TB that there was some play before the spring opened the butterflies, with some slight clicking but no butterfly movement. There is none in the new TB, the butterflies open immediately upon tension. But I also got a chip retune, so I can't say the more steady idle is from the TB alone. But I think something within the stock TB was/is worn out, that's for sure.
jmrl98 is offline   Reply With Quote
Go Back   CorvetteForum - Chevrolet Corvette Forum Discussion >
Reload this Page
  • Lazy Idle (1985)
  •  
     
    Reply

    Related Topics
    Thread Thread Starter Forum Replies Last Post
    New Holley Idle Problem Gage C3 General 3 05-15-2011 09:34 PM
    Idle High juyanith C6 Tech/Performance 6 01-23-2011 02:38 PM
    Two separate idle problems. Midnight 85 C4 Tech/Performance 25 08-01-2007 11:53 AM
    Idle problem Roofless C5 Scan & Tune 6 09-06-2004 10:51 PM
    High Idle when rolling TRHOADS C5 Tech 12 09-11-2002 05:02 PM


    Tags
    1985, corvette, idle, rpm

    Thread Tools Search this Thread
    Search this Thread:

    Click for Advanced Search

    Posting Rules
    You may not post new threads
    You may not post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are Off
    Pingbacks are Off
    Refbacks are Off

    Forum Jump


    All times are GMT -4. The time now is 11:33 AM.