Go Back   Corvette Forum > C4 Corvettes, 1984 - 1996 > C4 Tech/Performance
Sign in using an external account
Register Forgot Password?
Register Search Today's Posts Mark Forums Read FAQ Vendor Directory
Search
C4 Tech/Performance
L98 Corvette and LT1 Corvette Technical Info, Internal Engine, External Engine

Reply
 
 
 
 
Thread Tools Search this Thread
Old 07-23-2010, 01:27 AM   #1
larry93lt1
CF Senior Member
 
larry93lt1's Avatar
 
Member Since: May 2010
Location: Gaithersburg MD A member since 2007 but then the computer crashed and then the car crash loss of memory X 2
Default Bose Radio Problems

Just got a low mileage black/black 92 6 speed coupe, 37K miles.It will eventually keep my 93 torch red coupe company. Car had not been maintained properly over the last 8 years. Have finish issues, hazing, scratches and other problems. But I have a radio issue

Radio is a Bose system AM FM W/Cassette tape. The radio will play for a while ,two minutes to ten minutes and then just shut off. Getting some static in the speakers. Antenna does not retract until switched off but there is no sound after a rather loud POP.

Any suggestioons for the radio fix ?

7/23/2010 UPDATE:

This morning I tried the radio and it doesn't work at all now.

Any ideas of costs ?

Last edited by larry93lt1; 07-23-2010 at 05:24 PM. Reason: UPDATE
larry93lt1 is offline   Reply With Quote
Old 07-23-2010, 05:42 AM   #2
pmihaltian
CF Senior Member
Support Corvetteforum!
 
pmihaltian's Avatar
 
Member Since: Dec 2001
Location: Charlotte NC
Send a message via AIM to pmihaltian
Default

Could be the radio relay.

Check out these guys, they can help you.

Factory Car Stereo Repair, Inc.
1987 Corporate Square Suite 159
Longwood, FL 32750

(407) 830-0777
Website: www.carstereohelp.com/strcorvette.htm
pmihaltian is offline   Reply With Quote
Old 07-23-2010, 08:38 AM   #3
Black92FX36spd
CF Senior Member
 
Black92FX36spd's Avatar
 
Member Since: Jul 2010
Location: Siloam Springs AR
Default

I used factory car stereo repair just a couple weeks ago. Sent my amps in and they were fixed the same week. Ship USPS priority flat rate to ship it is cheaper than UPS. I sent mine down USPS and it was like $11, they sent it back UPS and it was over $20 and took like 3 days longer. I sent mine on Tue and they called thur to say they were done and didn't get them back til the next fri. They did an awesome job and it sounds like new.
Black92FX36spd is offline   Reply With Quote
Old 07-23-2010, 10:21 AM   #4
joesgulfstream
CF Senior Member
 
joesgulfstream's Avatar
 
Member Since: Nov 2009
Default

Fixworks.com $40 a piece to re build speaker amps. did mine got them back 3 day after they finished repaire. Tell Kurt that Joe sent you.

Last edited by joesgulfstream; 07-23-2010 at 10:23 AM. Reason: forgot
joesgulfstream is offline   Reply With Quote
Old 07-23-2010, 10:51 AM   #5
Black92FX36spd
CF Senior Member
 
Black92FX36spd's Avatar
 
Member Since: Jul 2010
Location: Siloam Springs AR
Default

Quote:
Originally Posted by joesgulfstream View Post
Fixworks.com $40 a piece to re build speaker amps. did mine got them back 3 day after they finished repaire. Tell Kurt that Joe sent you.
Man! That is really cheap! I did get a lifetime warranty with mine, does fixworks have a warranty?
Black92FX36spd is offline   Reply With Quote
Old 07-23-2010, 12:34 PM   #6
onedef92
CF Senior Member
Cruise-In IV Veteran
Cruise-In VI Veteran
Cruise-In VII Veteran
Cruise-In VIII Veteran
 
onedef92's Avatar
 
Member Since: Oct 2000
Location: Louisville KY
Default

Quote:
Originally Posted by joesgulfstream View Post
Fixworks.com $40 a piece to re build speaker amps. did mine got them back 3 day after they finished repaire. Tell Kurt that Joe sent you.
Wow! I need to hit him up to see how much he charges to fix a Bose CDM/tuner module!
onedef92 is offline   Reply With Quote
Old 07-23-2010, 01:47 PM   #7
joesgulfstream
CF Senior Member
 
joesgulfstream's Avatar
 
Member Since: Nov 2009
Default

Quote:
Originally Posted by Black92FX36spd View Post
Man! That is really cheap! I did get a lifetime warranty with mine, does fixworks have a warranty?
yes, 5 year
joesgulfstream is offline   Reply With Quote
Old 07-23-2010, 01:47 PM
 
Go Back   Corvette Forum > C4 Corvettes, 1984 - 1996 > C4 Tech/Performance
Reload this Page Bose Radio Problems
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bose Radio woes vettegeoff C4 Tech/Performance 3 04-30-2014 08:21 AM
1987 corvette radio fuse issue Bugly87 C4 Tech/Performance 3 04-15-2014 05:48 AM
Bose unit turns on and off while driving 93cruiser C4 Tech/Performance 0 08-22-2013 08:11 PM
Issues with OnStar, Z130BT and PAC OS2Bose miami08VETTE Audio/Electronics 26 07-27-2012 01:59 AM
TSB for aftermarket radio problem "SYS" flashing craigbr C4 General Discussion 28 09-24-2004 11:49 PM


Tags
1984, 92, 93, bose, c4, cdm, corvette, delco, fix, module, problem, problems, radio, static, tuner, working


Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Corvette Store
 
 
C7 Parts & Accessories
C6 Parts & Accessories
C5 Parts & Accessories
C4 Parts & Accessories
C3 Parts & Accessories
C2 Parts & Accessories
C1 Parts & Accessories
Wheels & Tires
Sponsored Ads
 
 
Vendor Directory
 

All times are GMT -4. The time now is 01:38 AM.


Emails & Password Backup