Go Back   Corvette Forum > C4 Corvettes, 1984 - 1996 > C4 Tech/Performance
Sign in using an external account
Register Forgot Password?
Register Search Today's Posts Mark Forums Read FAQ Vendor Directory
Search
C4 Tech/Performance
L98 Corvette and LT1 Corvette Technical Info, Internal Engine, External Engine

Welcome to Corvetteforum.com!
Welcome to Corvetteforum.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Corvetteforum.com today!


Corvette Store
 
 
C7 Parts & Accessories
C6 Parts & Accessories
C5 Parts & Accessories
C4 Parts & Accessories
C3 Parts & Accessories
C2 Parts & Accessories
C1 Parts & Accessories
Wheels & Tires
Sponsored Ads
 
 
Vendor Directory
  
Reply
 
 
 
 
Thread Tools Search this Thread
Old 04-09-2002, 12:09 AM   #1
Hi-psi
CF Senior Member
 
Member Since: Mar 2002
Location: Acworth Georgia
Default Symptoms of a Bad Opti-Spark..........

What are they?
Hi-psi is offline   Reply With Quote
Old 04-09-2002, 11:07 AM   #2
Captain_Kaboom
CF Senior Member
 
Captain_Kaboom's Avatar
 
Member Since: Jan 2002
Location: Woodstock GA
Default Re: Symptoms of a Bad Opti-Spark.......... (Hi-psi)

Before mine went completely (Symptoms: car wouldn't stay running unless pumping gas, no error code), I heard a heavy ticking sound, which I assume came from the opti.

Captain_Kaboom is offline   Reply With Quote
Old 04-09-2002, 12:16 PM   #3
John Row
CF Senior Member
 
John Row's Avatar
 
Member Since: May 2001
Location: San Diego CA
Default Re: Symptoms of a Bad Opti-Spark.......... (Hi-psi)

Mine started missing at higher RPMs, then began working down to lower. Just before it was changed it was running very erraticaly.

John Row is offline   Reply With Quote
Old 04-09-2002, 12:29 PM   #4
Hi-psi
CF Senior Member
 
Member Since: Mar 2002
Location: Acworth Georgia
Default Re: Symptoms of a Bad Opti-Spark.......... (John Row)

Here's the deal. When I got my car,...it would float the valves above about 4400. I adjusted the valves, pulled good to redline, but above about 5500 it would have a little bit of a miss here and there. Replaced the stock plugs with NGK TR5's, and replaced the coil with a MSD. Did not replace the plug wires or the coil wire. The car now pulled noticeably stronger, but still occasionally had a VERY slight miss above about 5600-5700. Did this Sat. Car ran fine Sat, drove it 170miles Sunday and it ran fine. Drove it to work Monday fine. Monday evening the car started missing bad. Not all the time though. I could go out there now,...start the car,...go down the road. It might run fine,...then 2 minutes later anything more than light throttle and the car will miss and buck pretty bad. The a minute later be back to running fine. I'm planning to do the wires VERY soon and this will hopefully cure the problem. The wires on it are some cheap Autozone specials... But sadly,...since the car ran fine for a day or two,...I don't think it's the wires.

Thoughts?

BTW,...no trouble codes.....yet.....
Hi-psi is offline   Reply With Quote
Old 04-09-2002, 12:36 PM   #5
Hi-psi
CF Senior Member
 
Member Since: Mar 2002
Location: Acworth Georgia
Default Re: Symptoms of a Bad Opti-Spark.......... (Hi-psi)

Also,...worse case scenerio,...if it is the Opti-Spark,....I was looking in the MidAmerica catalog, they list an Opti-Spark # 611-026 for 1993-94 cars for $489.99 and then a #611-027 for 1994-96 cars for $149.99.

Which is the correct one for a 1994 LT-1 6spd?

Also,....is there anywere on the net that lists the procedure for swapping the Opti-Spark? What all is needed?

Thanks.
Hi-psi is offline   Reply With Quote
Old 04-09-2002, 12:45 PM   #6
James94LT1
CF Senior Member
 
James94LT1's Avatar
 
Member Since: Apr 2002
Location: MO
Default Re: Symptoms of a Bad Opti-Spark.......... (Hi-psi)

That sounds alot like what my car did when I had a bad coil wire.

James
James94LT1 is offline   Reply With Quote
Old 04-09-2002, 12:58 PM   #7
GlockLT4
CF Senior Member
 
GlockLT4's Avatar
 
Member Since: Apr 2001
Location: Dallas TX
Send a message via AIM to GlockLT4
Default Re: Symptoms of a Bad Opti-Spark.......... (James94LT1)

Mine sounded like pop-corn popping under the hood with very much throttle at all when my opti was bad. NOT a good sound!
GlockLT4 is offline   Reply With Quote
Old 04-09-2002, 01:19 PM   #8
emoshn
CF Senior Member
 
Member Since: May 2001
Default Re: Symptoms of a Bad Opti-Spark.......... (James94LT1)

For parts, contact http://www.paceparts.com. Jim Pace.
For procedure, check the tech forum here or get a copy of Corvette Fever magazine, Feb 01. They cover it pretty thoroughly in there. Also, get a set of Haynes manuals for your year...they are invaluable.
emoshn is offline   Reply With Quote
Old 04-09-2002, 01:38 PM   #9
vader86
CF Senior Member
 
vader86's Avatar
 
Member Since: Sep 2001
Location: Athens AL
Default Re: Symptoms of a Bad Opti-Spark.......... (emoshn)

if you do have to replace the opti, and thats kinda what it sounds like to me, try to get one from 95-96 thats vented.
vader86 is offline   Reply With Quote
Old 04-09-2002, 06:27 PM   #10
flubuyu2
CF Senior Member
 
flubuyu2's Avatar
 
Member Since: Jan 2002
Location: Garland TX
Default Re: Symptoms of a Bad Opti-Spark.......... (Glock'94)

hey glock ,this is kinda off topic but I just changed my opti etc. I wanted to ask you about the cat. problems you were having i saw the thread where you gutted it on the garage floor .what was your car doing to let you know ??mine is only able to go to about 3500-4000 rpms then dies and won't start again till she's cold!all ign. new looking for possibilities
flubuyu2 is offline   Reply With Quote
Old 04-09-2002, 07:04 PM   #11
GlockLT4
CF Senior Member
 
GlockLT4's Avatar
 
Member Since: Apr 2001
Location: Dallas TX
Send a message via AIM to GlockLT4
Default Re: Symptoms of a Bad Opti-Spark.......... (flubuyu2)

Quote:
hey glock ,this is kinda off topic but I just changed my opti etc. I wanted to ask you about the cat. problems you were having i saw the thread where you gutted it on the garage floor .what was your car doing to let you know ??mine is only able to go to about 3500-4000 rpms then dies and won't start again till she's cold!all ign. new looking for possibilities
My cats were rattling REALLY bad... sounded like my engine was coming apart. When I took the cats off, the honey comb was melting and trying to go DOWN THE PIPE! :eek: :eek: I just ordered some car sound cats yesterday to put on. I need to quiet it up a little. It's pretty loud with gutted cats and straight pipes :D
GlockLT4 is offline   Reply With Quote
Old 04-09-2002, 07:13 PM   #12
Rick93Z07
CF Senior Member
 
Member Since: Apr 2000
Default Re: Symptoms of a Bad Opti-Spark.......... (Glock'94)

Two things:

1) Go to C4 Tech Tips to get info on how to clean, properly seal and install '95-'96 air purge on a '92-'94 Optispark for $17. You may be able to wash out your cap and rotor assy and reuse it if it isn't filled with water and rust.
2) Otherwise, find Jeff Kopp at Superior Chevrolet to buy an early style replacement Optispark for dirt cheap. Don't just throw a new one on without the $17 upgrade in step 1 or you'll be doing it again every 3+ years. Reliability will remain poor with stock sealing. You won't be able to wash your motor or safely change a rad hose or water pump without losing sleep. If you continue to run the stock Opti without the mods, better have a Platinum AAA Membership with unlimited flatbed service.


[Modified by Rick93Z07, 6:16 PM 4/9/2002]
Rick93Z07 is offline   Reply With Quote
Old 04-10-2002, 03:14 AM   #13
James94LT1
CF Senior Member
 
James94LT1's Avatar
 
Member Since: Apr 2002
Location: MO
Default Re: Symptoms of a Bad Opti-Spark.......... (Rick93Z07)

I dunno if you seen my thread earlier but this happened to me tonight. Had my car detailed and the optispark crapped out tonight. Had to get towed home. Anyone have the part # or just tell em I need a replacement for a 94? Can I but the better 95 newer on my car with the proper mods?


:confused:
James94LT1 is offline   Reply With Quote
Old 04-10-2002, 05:53 AM   #14
93 ragtop
CF Senior Member
 
93 ragtop's Avatar
 
Member Since: Apr 2000
Location: Manassas VA
Default Re: Symptoms of a Bad Opti-Spark.......... (Hi-psi)

[quote]I could go out there now,...start the car,...go down the road. It might run fine,...then 2 minutes later anything more than light throttle and the car will miss and buck pretty bad. The a minute later be back to running fine. I'm planning to do the wires VERY soon and this will hopefully cure the problem. The wires on it are some cheap Autozone specials... But sadly,...since the car ran fine for a day or two,...I don't think it's the wires.

This suggestion may be way off base, but have you replaced the fuel filter? It might be starving for fuel.




[Modified by Red 86 4+3, 11:21 AM 4/10/2002]
93 ragtop is offline   Reply With Quote
Old 04-10-2002, 12:23 PM   #15
John Row
CF Senior Member
 
John Row's Avatar
 
Member Since: May 2001
Location: San Diego CA
Default Re: Symptoms of a Bad Opti-Spark.......... (Hi-psi)

You will need the opti for a 94. If you want to upgrade to the 95/6 Opti you will need a 95/6 timing chain cover (gaskets and seals) and has a different connector plug (easy to fix) as well. The 95/6 is sealed much better, but still would benefit from a liberal application of hi-temp RTV.

The cap and rotor from a 95/6 fits on a 94 base and has one of the vacuum connections. Or you can drill a 94 to add the connection.

In either case a vacuum line kit from a 95/6 is very useful.

While you are at it, you might consider an electric water pump.

If you've done the job before, it would take about 4-6 hours. If not, plan on 2 days (much of which you will stand there asking yourself "how the he11 to I get a wrench on that?" The rest of the time will be to and from the parts store to get a new tool!).


[Modified by John Row, 10:24 AM 4/10/2002]
John Row is offline   Reply With Quote
Old 04-11-2002, 09:42 PM   #16
Hi-psi
CF Senior Member
 
Member Since: Mar 2002
Location: Acworth Georgia
Default Re: Symptoms of a Bad Opti-Spark.......... (Hi-psi)

Per accumilated advice from everywhere......tomorrow I will be replacing the O2 sensor, new plug wires and coil wire, and pulling the plugs out and gapping them to .050 (when I installed I gapped the NGK's at .035 on the advice of a friend who use to have a Vette) I'll update everyone tomorrow nite.
Hi-psi is offline   Reply With Quote
Old 04-13-2002, 03:03 PM   #17
Hi-psi
CF Senior Member
 
Member Since: Mar 2002
Location: Acworth Georgia
Default Re: Symptoms of a Bad Opti-Spark.......... (Hi-psi)

Update on the ignition issues. I changed the passenger side front (pre-cat) O2 today,..which was the one that was coding. First of all,.....lemme tell you,...changing the damn O2 sensor on this thing was a ****. Had to drop the exhaust from the resonator up just to get the old sensor out. I disconnected the battery for about 30 sec to clear the codes,....hooked it back up and took her for a spin. The car is noticeably smoother (duh!), pulls extremely crisp all the way to redline,...absolutely no missing or anything in the upper RPMS anymore, and the missfiring and bucking that would come and go,...as far as I can tell has went away. I drove the car for a good 20-30min. and got it good and warm,...run it through the gears a good bit,...smooth as a Cadillac....
:cheers:

Wooohooo.... :D
Hi-psi is offline   Reply With Quote
Old 04-13-2002, 04:08 PM   #18
rerquiredtext
CF Member
 
Member Since: Apr 2002
Default Re: Symptoms of a Bad Opti-Spark.......... (Hi-psi)

The opti should be no more then $350. Shop around. I bought mine from 18carfan (superior chevrolet) 913-384-3115 Ask for Jeff. Also check out more performance http://www.moreperformanceinc.com they also sell it. I cannot remeber which one is cheaper. I am pretty sure that Jeff has it in stock. Depending on the mileage you may want to change the waterpump at the same time since you have to remove it.
rerquiredtext is offline   Reply With Quote
Old 04-13-2002, 04:23 PM   #19
XTRME 94
CF Senior Member
 
XTRME 94's Avatar
 
Member Since: Apr 2001
Location: Little Elm TX
Send a message via AIM to XTRME 94 Send a message via MSN to XTRME 94 Send a message via Yahoo to XTRME 94
Default Re: Symptoms of a Bad Opti-Spark.......... (rerquiredtext)

From my experience, when I put on the MSD Blaster coil, it was to much for the stock wires. If you have cheap wires, then you will probably want to upgrade soon. Mine did the same thing and keep knocking out the coil because there was an interal short in the coil wire. Once I put on the MSD wires, the rpm range was fine again. When I pulled the coil wire it dang near came apart in my hand. :mad
XTRME 94 is offline   Reply With Quote
Old 04-13-2002, 10:56 PM   #20
red-y
CF Senior Member
 
red-y's Avatar
 
Member Since: Aug 2001
Location: Houston TX
Default Re: Symptoms of a Bad Opti-Spark.......... (rerquiredtext)

Jeff Kopp - 800-728-8267 - There is so much posting on the Opti, I'm thinking I'll just do a PM and pull mine before it quits. :eek:
red-y is offline   Reply With Quote
Old 04-13-2002, 10:56 PM
 
Go Back   Corvette Forum > C4 Corvettes, 1984 - 1996 > C4 Tech/Performance
Reload this Page Symptoms of a Bad Opti-Spark..........
 
 
 
Reply

Tags
94, bad, coil, corvette, distributor, dying, engine, good, opilt, opti, optispark, spack, spark, symptoms, symtoms


Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Erase FortMorganAl Testing 0 05-08-2014 10:38 AM
))) Darby Malone C4s for Sale/Wanted 3 04-29-2014 07:37 PM
??? Yello95 Testing 0 02-20-2014 01:50 AM
Ouch grum C6 Corvette General Discussion 10 05-03-2013 08:43 PM


All times are GMT -4. The time now is 03:56 AM.


Emails & Password Backup