Starts but won't idle or stay running - CorvetteForum - Chevrolet Corvette Forum Discussion

Go Back   >
Log In 
Register FAQ Search Today's Posts Mark Forums Read Vendor Directory

C4 Tech/Performance
L98 Corvette and LT1 Corvette Technical Info, Internal Engine, External Engine

Starts but won't idle or stay running

Reply
 
 
 
Thread Tools Search this Thread
Old 02-27-2011, 01:20 AM   #1
MrBold1
Junior Member
Support Corvetteforum!
Thread Starter
 
MrBold1's Avatar
 
Member Since: Feb 2011
Location: Decatur Illinois
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default Starts but won't idle or stay running

I have a 1986 Vette that I just got this week that won't stay running or idle. It will start and I can keep it going using the gas pedal but it sounds and feels rough. I am going to check for codes tomorrow as the SES light is on. Could it be as simple as the TPS or IAC? I have been reading about the MAF sensor, power relay, and burnoff relay as potential culprits also. Any thoughts or advice would be greatly appreciated as I am 100% new to Corvettes! Thanks!
MrBold1 is offline   Reply With Quote
Old 02-27-2011, 06:01 AM   #2
Threshold
CF Senior Member
Support Corvetteforum!
 
Threshold's Avatar
 
Member Since: Apr 2007
Location: WLA/WEHO CA
Posts: 7,042
Thanks: 0
Thanked 0 Times in 0 Posts
Default

check your fuel pump as well
Threshold is offline   Reply With Quote
Old 02-27-2011, 08:27 AM   #3
Sandpiper59
CF Senior Member
Support Corvetteforum!
 
Sandpiper59's Avatar
 
Member Since: Nov 2010
Location: Oliphant Ontario
Posts: 460
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Get the codes before you start mentally spending money on it, a car that won't idle at all and is offering codes is probably the easiest to diagnose!
Sandpiper59 is offline   Reply With Quote
Old 02-27-2011, 10:55 AM   #4
Jesper Dahl
Junior Member
 
Member Since: Feb 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Mr Bold

I had same problem with my 88 c4....it was the MAF sensor..no codes no nothing..try disconnet it,and see if it runs again,mine did.
Jesper Dahl is offline   Reply With Quote
Old 02-27-2011, 01:27 PM   #5
MrBold1
Junior Member
Support Corvetteforum!
Thread Starter
 
MrBold1's Avatar
 
Member Since: Feb 2011
Location: Decatur Illinois
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Disconnected the MAF and she fired right up and stayed running!!! Thanks for the advice! Still gonna check codes as she's running a touch rich. Could just need a tune up or is that because the MAF is disconnected? Thanks!
MrBold1 is offline   Reply With Quote
Old 02-27-2011, 03:26 PM   #6
Jesper Dahl
Junior Member
 
Member Since: Feb 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Mr Bold

You are welcome..yeah,i knew it would work....you dont wanna know how many sleepless nights,and big bucks i have spend on this problem...becourse my MAF was only 1 week old when this problem came along,so it was the last thing that came on my mind.You need to get, and install a new Maf sensor,to make it run smoothly.
Jesper Dahl is offline   Reply With Quote
Old 02-27-2011, 05:13 PM   #7
MrBold1
Junior Member
Support Corvetteforum!
Thread Starter
 
MrBold1's Avatar
 
Member Since: Feb 2011
Location: Decatur Illinois
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Jesper
Thanks again for your help. Going to pick up a new MAF tomorrow. Also found that the fasteners on the airbox were broken so there is not a good seal for the air filter. Need to order that as well. Taking it in Tues for a tune up and some misc stuff.
MrBold1 is offline   Reply With Quote
Go Back   CorvetteForum - Chevrolet Corvette Forum Discussion >
Reload this Page
  • Starts but won't idle or stay running
  •  
     
    Reply

    Related Topics
    Thread Thread Starter Forum Replies Last Post
    85 hunting idle after rebuild-got codes jmrl98 C4 Tech/Performance 2 07-24-2015 09:47 AM
    High Idle 1970gto C4 Tech/Performance 11 12-26-2014 03:36 PM
    1990 C4 only starts Wide Open Throttle & must pump Throttle to keep running RPOL71 C4 General Discussion 7 05-12-2014 03:53 PM
    '87 Fuel Pump Relay??? FenderF4i C4 Tech/Performance 10 03-02-2013 09:10 AM
    Stalling and surging idle. Chosen Won C4 Tech/Performance 4 02-22-2005 10:50 PM


    Tags
    1982, 1986, 1987, 1988, 1996, 86, car, corvette, engine, idle, lt1, running, starts, stay, wont

    Thread Tools Search this Thread
    Search this Thread:

    Click for Advanced Search

    Posting Rules
    You may not post new threads
    You may not post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are Off
    Pingbacks are Off
    Refbacks are Off

    Forum Jump


    All times are GMT -4. The time now is 11:10 AM.