Who's running a Accel DFI Gen 7? - Corvette Forum

Go Back   >
Log In 
Register FAQ Search Today's Posts Mark Forums Read Vendor Directory

C4 Tech/Performance
L98 Corvette and LT1 Corvette Technical Info, Internal Engine, External Engine

Who's running a Accel DFI Gen 7?

Reply
 
 
 
Thread Tools Search this Thread
Old 08-07-2011, 10:35 AM   #1
rssshen vette
CF Senior Member
Thread Starter
 
rssshen vette's Avatar
 
Member Since: Oct 2004
Location: Clarksville Tennessee
Posts: 549
Thanked 0 Times in 0 Posts
Default Who's running a Accel DFI Gen 7?

Who's running a Accel DFI Gen 7? I'm about to start the tuning process on my 383 L98. This my first attempt in tuning and I was hoping to find some forum members that have some experience in doing this that may provide some advice.
rssshen vette is offline   Reply With Quote
Old 08-10-2011, 10:21 PM   #2
5abivt
CF Senior Member
 
5abivt's Avatar
 
Member Since: May 2002
Location: Toronto ontario
Posts: 4,460
Thanked 8 Times in 7 Posts
Default

H i I have the gen 7 setup in my 93. Id be hapy to help if you have any questions. Are you running a dual sync? what ecm setup are you running?
5abivt is offline   Reply With Quote
Old 08-23-2011, 09:48 PM   #3
rssshen vette
CF Senior Member
Thread Starter
 
rssshen vette's Avatar
 
Member Since: Oct 2004
Location: Clarksville Tennessee
Posts: 549
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by 5abivt View Post
H i I have the gen 7 setup in my 93. Id be hapy to help if you have any questions. Are you running a dual sync? what ecm setup are you running?
Thanks for the reply 5abvit. Yeah I'm running a dual sync Distrubtor. I.m using the Gen7 thrusher system. I don't have the wide band. I think I'll be adding that sooner than later. For now I'll try to make do without it. I do have several questions but for now how much adjustment did you have to make to the base calmap for your setup? and what area did you make your first adjustment?
rssshen vette is offline   Reply With Quote
Old 09-29-2011, 04:23 PM   #4
LaVidaLoca
CF Senior Member
 
LaVidaLoca's Avatar
 
Member Since: Jul 2002
Location: Yukon OK
Posts: 729
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by rssshen vette View Post
I.m using the Gen7 thrusher system. I don't have the wide band. ........how much adjustment did you have to make to the base calmap for your setup?
Do yourself a favor and get a wide band. I have been running a Thruster on my 85 for over a year and love it. Started with an Innovate wide band but had some issues with it. Just moved to an AEM in line module and it is simple to install. Cost about $170. MUCH less than the Accel unit.

I got a base config from Accel and didn't have to do much tuning. Started with idle and low RPM in the driveway. Then mostly out driving around and just started correcting for spots that required too much correction by the O2 sensor. Went back and started smoothing the curves out on the 3D graph.

Then I began logging data to look at O2 correction, advance, knock etc. To see what was going on under hard acceleration and working on that. After some time things started dropping into place and smoothing out.
LaVidaLoca is offline   Reply With Quote
Old 10-04-2011, 06:21 PM   #5
Chuckm3
Junior Member
 
Member Since: Jan 2007
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sorry about resurrecting a 3 month old thread...

I just set up a GEN 7 DFI system on a Dodge motor today. I actually had pretty good luck just using the 2 Bar map file "Quick Setup" option under the Configuration menu. Make sure you have all your System data entered correctly before you try this. Pay attention to little details like your firing order, compression, injector size, and transmission type, because they'll all effect the VE table.

One thing I'd really like is for a big book to fall out of the sky regarding the theory and practice behind tuning spark advance. Every builder I speak to out there says stuff like "just give the motor what it likes" (there's a big help ) or "start with 30 degrees of total timing and go from there". There is no "total timing" with a DFI system. You have over a hundred cells to work with in the timing screen, and they're load and rpm dependant. Setting up VE is a cakewalk, but spark advance is alchemy as far as I can see.

BTW, I have a ZZ383 crate motor ecm file for use with the Accel Street Ram DFI package. I can send it to you if you want something to mess around with. It might save you a lot of time and guesswork.

Last edited by Chuckm3; 10-04-2011 at 06:26 PM.
Chuckm3 is offline   Reply With Quote
Old 10-04-2011, 07:44 PM   #6
LaVidaLoca
CF Senior Member
 
LaVidaLoca's Avatar
 
Member Since: Jul 2002
Location: Yukon OK
Posts: 729
Thanks: 0
Thanked 0 Times in 0 Posts
Default

One of the things I did was to hook up the knock sensor to the Accel. Then I made numerous runs while recording RPM, Vacuum, A/F and knock. Then I advanced until there was knock and removed the knock under the conditions it occurs.

After doing a lot of adjustments I then smoothed out the curves and eliminated peaks and valleys.

Not the way to do it for competition, but works for a driver.
LaVidaLoca is offline   Reply With Quote
Old 10-13-2011, 06:24 PM   #7
rssshen vette
CF Senior Member
Thread Starter
 
rssshen vette's Avatar
 
Member Since: Oct 2004
Location: Clarksville Tennessee
Posts: 549
Thanked 0 Times in 0 Posts
Default

Thanks guy for your response. Chuckm3... I would like to take a look at that ZZ383 create motor ecm file. Currently my car isn't drivable since I installed the DFI system. I think my timing is off and the dual sync dizzy isn't phasing as per the instructions. So I'm enlisting the help of a mechanic from a local race shop.
rssshen vette is offline   Reply With Quote
Old 10-13-2011, 06:46 PM   #8
Chuckm3
Junior Member
 
Member Since: Jan 2007
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by rssshen vette View Post
Thanks guy for your response. Chuckm3... I would like to take a look at that ZZ383 create motor ecm file. Currently my car isn't drivable since I installed the DFI system. I think my timing is off and the dual sync dizzy isn't phasing as per the instructions. So I'm enlisting the help of a mechanic from a local race shop.
I'll send you the proper instructions for setting the distributor up via PM in a minute.
Chuckm3 is offline   Reply With Quote
Old 10-14-2011, 08:57 AM   #9
Chuckm3
Junior Member
 
Member Since: Jan 2007
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Did you get the info I sent? Let me know if you have any questions.
Chuckm3 is offline   Reply With Quote
Old 10-20-2011, 07:25 PM   #10
rssshen vette
CF Senior Member
Thread Starter
 
rssshen vette's Avatar
 
Member Since: Oct 2004
Location: Clarksville Tennessee
Posts: 549
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Chuckm3 View Post
Did you get the info I sent? Let me know if you have any questions.
Thanks Chuck!
rssshen vette is offline   Reply With Quote
Old 10-21-2011, 09:36 AM   #11
Chuckm3
Junior Member
 
Member Since: Jan 2007
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Default

You're welcome. I forgot to ask - what firmware revision is your Thruster system? There should be a decal on the outside of the ECM with the version number.
Chuckm3 is offline   Reply With Quote
Old 10-27-2011, 06:28 PM   #12
rssshen vette
CF Senior Member
Thread Starter
 
rssshen vette's Avatar
 
Member Since: Oct 2004
Location: Clarksville Tennessee
Posts: 549
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Chuckm3 View Post
You're welcome. I forgot to ask - what firmware revision is your Thruster system? There should be a decal on the outside of the ECM with the version number.
It's a verison 1.0 It has a manufacture date Sept 2008.
rssshen vette is offline   Reply With Quote
Old 10-27-2011, 07:43 PM   #13
Chuckm3
Junior Member
 
Member Since: Jan 2007
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok, I just wanted to know if we were talking Thruster or Thruster Pro, which is what Gen VII is called now.
Chuckm3 is offline   Reply With Quote
Old 10-28-2011, 04:03 PM   #14
rssshen vette
CF Senior Member
Thread Starter
 
rssshen vette's Avatar
 
Member Since: Oct 2004
Location: Clarksville Tennessee
Posts: 549
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Chuckm3 View Post
Ok, I just wanted to know if we were talking Thruster or Thruster Pro, which is what Gen VII is called now.
Thruster...
rssshen vette is offline   Reply With Quote
Go Back   Corvette Forum >
Reload this Page
  • Who's running a Accel DFI Gen 7?
  •  
     
    Reply

    Related Topics
    Thread Thread Starter Forum Replies Last Post
    DFI Gen 7 Backup yedister C4 Tech/Performance 3 10-27-2014 01:59 AM
    Accell gen 7 DFI 77022L wanna vette C4 Parts for Sale/Wanted 6 07-08-2014 07:18 PM
    Accel DFI Gen 6, upgrade to .....? ROME C4 Tech/Performance 1 10-14-2012 09:33 AM
    accel dfi gen 7 start problem Dalannex C4 Tech/Performance 10 09-27-2006 01:27 PM
    Ignition wiring with Accel DFI Gen 7 PolishMike C3 Tech/Performance 6 04-19-2006 02:24 AM


    Tags
    accel, c4, corvette, dfi, forum, forums, gen, good, hiw, l98, sale, system, tips, tuners, tuning, vii

    Thread Tools Search this Thread
    Search this Thread:

    Click for Advanced Search

    Posting Rules
    You may not post new threads
    You may not post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are Off
    Pingbacks are Off
    Refbacks are Off

    Forum Jump


    All times are GMT -4. The time now is 07:15 AM.