Go Back   Corvette Forum > C4 Corvettes, 1984 - 1996 > C4 Tech/Performance
Sign in using an external account
Register Forgot Password?
Register Search Today's Posts Mark Forums Read FAQ Vendor Directory
Search
C4 Tech/Performance
L98 Corvette and LT1 Corvette Technical Info, Internal Engine, External Engine

Welcome to Corvetteforum.com!
Welcome to Corvetteforum.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Corvetteforum.com today!


Corvette Store
 
 
C7 Parts & Accessories
C6 Parts & Accessories
C5 Parts & Accessories
C4 Parts & Accessories
C3 Parts & Accessories
C2 Parts & Accessories
C1 Parts & Accessories
Wheels & Tires
Sponsored Ads
 
 
Vendor Directory
  
Reply
 
 
 
 
Thread Tools Search this Thread
Old 05-01-2013, 01:37 PM   #1
choopes
CF Senior Member
 
Member Since: Mar 2002
Location: Troy Al
Default opti again

After years of frustration, and knuckle busting, I took my 93 coupe to a machanic. He has gotten to SES system to work again. Got the car running, but rough. And code 16. Says it needs a new opti. I know I have put at least 4 new optis over the 5 years or more of this ongoing problem. Typically, it runs for a while the the same thing again. What are my options for buying a GM opti these days? Semms like I remember a post where GM no longer makes them. What are my best options?
choopes is offline   Reply With Quote
Old 05-01-2013, 01:54 PM   #2
Silver96ce
CF Senior Member
 
Member Since: Mar 2012
Default

It appears you can get a new Delphi opti from Rockauto for $375.00 - that's the option I would take. Forget the offbrand Ebay optis as they are hit or miss (I would say mostly "miss").
Silver96ce is offline   Reply With Quote
Old 05-01-2013, 02:11 PM   #3
Tom400CFI
CF Senior Member
 
Tom400CFI's Avatar
 
Member Since: Aug 2004
Location: Park City Utah
Default

I agree about Ebay Opti's. I wouldn't touch one. If I were in the market to buy a new Opti unit today, I'd buy THIS ONE. It's affordable, and has a one year warranty.

Last one I bought was from Napa (for $550.00) and it's worked fine for just under a year, so far.

Last edited by Tom400CFI; 05-01-2013 at 02:14 PM.
Tom400CFI is offline   Reply With Quote
Old 05-01-2013, 04:18 PM   #4
aboatguy
CF Senior Member
 
aboatguy's Avatar
 
Member Since: Jan 2005
Location: Slidell Louisiana
Default

either summit or jegs is selling supposedly OEM optis....



I've never had trouble with a GM opti...

Mike
aboatguy is offline   Reply With Quote
Old 05-02-2013, 07:23 AM   #5
mixalive
CF Senior Member
 
mixalive's Avatar
 
Member Since: Aug 2007
Location: Austin TX
terrysamford
Default

Exactly how is your mechanic determining bad opti?
mixalive is offline   Reply With Quote
Old 05-02-2013, 08:32 AM   #6
desertmike1
CF Senior Member
 
desertmike1's Avatar
 
Member Since: Aug 2008
Location: Palmdale CA
Default

Quote:
Originally Posted by mixalive View Post
Exactly how is your mechanic determining bad opti?
Code 16 (Opticle Sensor) High resolution signal.. [Chinese Crap]

would be my guess..

Last edited by desertmike1; 05-02-2013 at 08:39 AM.
desertmike1 is offline   Reply With Quote
Old 05-02-2013, 09:06 AM   #7
SouthernSon
CF Senior Member
 
SouthernSon's Avatar
 
Member Since: Oct 2000
Location: Deal's Gap 2004 NCM Motorsports Track Crew Chief Support
Default

Forget the Dynaspark - a waste of time nowadays.(not as good as original since being bought out by another owner). Go with the MSD billet 'timing adjustable'. So far that is the one that is working well for me.

this one:

http://www.vetteweb.com/tech/vemp_07...1_distributor/

Last edited by SouthernSon; 05-02-2013 at 09:08 AM.
SouthernSon is offline   Reply With Quote
Old 05-02-2013, 10:15 AM   #8
C409
CF Senior Member
 
C409's Avatar
 
Member Since: Feb 2005
Location: Clearwater Florida
Default

..... Take your Opti apart and clean the sensors and trigger wheel ... its not easy because there's very little room ... Opti is short for optical which means photocell ... ANY haze or dirt on any of them ( there are two each - top and bottom ) and it will affect the ability of the receptors to "see" ....... take a good look at the size of the slots in the trigger wheel and their proximity to each other and multiply that by several thousand RPM and you will realize why these things are so sensitive ... I'll be happy to pay the shipping on your old ones and take 'em off your hands ... .......
C409 is offline   Reply With Quote
Old 05-03-2013, 11:28 AM   #9
choopes
CF Senior Member
 
Member Since: Mar 2002
Location: Troy Al
Default

After some harsh words with the mechanic, I have decided to have my vette towed home and attempt to fix it myself. Here’s my plan, remove and clean the opti sensor, if that doesn’t do it, I may buy another opti. What is the part number for a '93 opti?
I also want to send the ECM to an ECM specialist shop, and have it thoroughly gone through. Has anyone one this board had experience with one of these guys you could recommend?
I'll keep you posted as to the outcome of all this.
choopes is offline   Reply With Quote
Old 05-03-2013, 11:38 AM   #10
lt4obsesses
CF Senior Member
 
lt4obsesses's Avatar
 
Member Since: Dec 2006
Location: H-Town Texas
Default

Quote:
Originally Posted by choopes View Post
After some harsh words with the mechanic, I have decided to have my vette towed home and attempt to fix it myself. Here’s my plan, remove and clean the opti sensor, if that doesn’t do it, I may buy another opti. What is the part number for a '93 opti?
I also want to send the ECM to an ECM specialist shop, and have it thoroughly gone through. Has anyone one this board had experience with one of these guys you could recommend?
I'll keep you posted as to the outcome of all this.
Just a thought, and perhaps it will or will not apply to your case. But one day last fall, I went out for a drive in my '96. It was raining. The car started to stall, buck, shut off, all of that. The SES throw the hi res code. Nursed it home, and thougt to myself, I really don't want to change the opti. But I did get a new opti harness. When I pulled the old one, there was trace of coolant and moisture deep in the connector area. It had started to eat at the connector on the pig tail. I cleaned it all up with brake cleaner and a can of compressed air, put the new pigtail on, and no troubles since.
lt4obsesses is offline   Reply With Quote
Old 05-03-2013, 04:26 PM   #11
choopes
CF Senior Member
 
Member Since: Mar 2002
Location: Troy Al
Default

I put a new harness in when I changed the last opti. I'll check it again. Thanks for the suggestion.
choopes is offline   Reply With Quote
Old 05-03-2013, 06:27 PM   #12
93LT1
CF Senior Member
 
93LT1's Avatar
 
Member Since: Aug 2000
Default

Quote:
Originally Posted by choopes View Post
After years of frustration, and knuckle busting, I took my 93 coupe to a machanic. He has gotten to SES system to work again. Got the car running, but rough. And code 16. Says it needs a new opti. I know I have put at least 4 new optis over the 5 years or more of this ongoing problem. Typically, it runs for a while the the same thing again. What are my options for buying a GM opti these days? Semms like I remember a post where GM no longer makes them. What are my best options?

I retro-fitted my new Delphi (acdelco) opti with the vented system.
I would imagine this will help with your situation.
Let me know if your interested and I'll give you specifics on how to do it correctly.
93LT1 is offline   Reply With Quote
Old 05-03-2013, 08:52 PM   #13
airplane50
CF Member
 
airplane50's Avatar
 
Member Since: Jan 2006
Location: Highland Park IL
Default

Understand what you are going through. It is no fun when your ride lets you down the way you explained.

I am also on the fourth opti in my '94 with 66K miles. With the exception of an MSD opti my current and other 3 were GM parts serviced at a Chevy dealer. Living in the Chicago area, my car is stored from Nov to Apr. Each time, with the exception of the MSD, the opti would fail shortly after taking the car out of storage due to a leaking water pump. The MSD was intermittent sometimes cutting out while driving the car or not starting after a short trip, waiting 10 - 15 mins the car would start and run perfect. Took my car to Libertyville Chevrolet where Kevin, (highly recommended) sorted out my car and replaced the opti with a GM part. So far it is running better than ever.

Good luck with your ride. Keep us informed on your progress.
airplane50 is offline   Reply With Quote
Old 05-03-2013, 10:49 PM   #14
C409
CF Senior Member
 
C409's Avatar
 
Member Since: Feb 2005
Location: Clearwater Florida
Default

..... Seriously , send me your old , tired , soggy Opti's ... I will do some failure analysis and try to come up with a more economical approach to dealing with Opti failures ... shoot me a PM with what you have and what you need to ship it to me ... I'll cover it .......
C409 is offline   Reply With Quote
Old 05-03-2013, 10:50 PM   #15
choopes
CF Senior Member
 
Member Since: Mar 2002
Location: Troy Al
Default

well, it's helpful to know I'm not the only one this has happened to.
I feel I need to do something, and having it here at my house will help. The last opti was a new AC delco with a MSD cap and rotor. Done primarily for the venting option. There were no codes. Finally, the machanic somehow got the codes to work again. Code 16. He tested the ECM. It tested good. I'm thinking intermitten.
If I can fix it. Will it be reliable? Can I take it for a trip?
I'll keep ya posted..
choopes is offline   Reply With Quote
Old 05-04-2013, 12:39 AM   #16
dolbnyc
CF Member
 
Member Since: Jun 2009
Default

Ha! I am having the exact same issue. I replaced mine about 7K miles ago. I do not look forward to doing this again. It really ruins having the car. I would think that by now we should be able to fabricate a better system for way less than what the current coil on plug solutions are going for...I am thinking of changing it and then selling right away, unless after I drive it again, I get corvette fever back LOL
dolbnyc is offline   Reply With Quote
Old 05-04-2013, 12:39 AM
 
Go Back   Corvette Forum > C4 Corvettes, 1984 - 1996 > C4 Tech/Performance
Reload this Page opti again
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Opti replacement again on 94 – need opinions pcolt94 C4 Tech/Performance 21 11-28-2013 01:52 PM
Optispark Question Thomastp C4 Tech/Performance 6 07-14-2013 08:48 AM
New GM AC Delco Opti Spark (10457702) FOR SALE xlr8nflorida C4 Parts for Sale/Wanted 12 11-19-2012 01:34 PM
Opti tbirdsps C4 General Discussion 2 07-18-2012 01:37 PM
OPTISPARK !! what a joke!!! belfiglioval C4 General Discussion 63 08-24-2008 08:09 PM



Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 01:12 AM.


Emails & Password Backup