hard cold start - Corvette Forum

Go Back   Corvette Forum > C4 Corvettes, 1984 - 1996 > C4 Tech/Performance
Log In 
Register FAQ Search Today's Posts Mark Forums Read Vendor Directory
Search

C4 Tech/Performance
L98 Corvette and LT1 Corvette Technical Info, Internal Engine, External Engine

hard cold start

Reply
 
 
 
 
Thread Tools Search this Thread
Old 06-27-2013, 02:39 PM   #1
playsdixie
CF Senior Member
 
playsdixie's Avatar
 
Member Since: Jun 2013
Location: ft myers FL/Munising MI
Send a message via AIM to playsdixie
Default hard cold start

thought I had the starting probs solved with a IAC reset but it seems it takes a few seconds to go in the morning and then fine all day after...the check engine light comes on with the cold start but if I restart it immediately it goes out...unfortunately i have the hyper chip so I can't see the code it threw....reading the forums, i'm thinking I have a leaking injector...or a bad fuel pump....don't really hear anything when I turn the key on....100.ooo miles so maybe a new fuel pump would help...are there any better grade pumps to use?? don't think it' injectors since no evidence of gas smells or gas in the engine area...are there any additives for injectors that are worth the money?
playsdixie is offline   Reply With Quote
Old 06-27-2013, 06:19 PM   #2
pcolt94
CF Senior Member
 
pcolt94's Avatar
 
Member Since: Jan 2006
Location: Orlando FL
Default

Normally my first suggestion would be the FPR leaking fuel into the vacuum line.

But on that year car (86) fuel injectors come to mind since they cause hard starting, poor idle and bad running.
If it is the injectors, they are just probably just warn out due to age and usage.
pcolt94 is offline   Reply With Quote
Old 06-27-2013, 07:56 PM   #3
DanielRicany
CF Senior Member
 
Member Since: Jun 2013
Default

Cold start injector comes to my mind.
DanielRicany is offline   Reply With Quote
Old 06-27-2013, 08:00 PM   #4
playsdixie
CF Senior Member
 
playsdixie's Avatar
 
Member Since: Jun 2013
Location: ft myers FL/Munising MI
Send a message via AIM to playsdixie
Default

I have a 85....and not too long...help me out a little... a cold start injector?...Car starts immediately after initial cold start.. and perfectdly the rest of the day..what's making the service engine come on"..what in this system will throw a code?....
playsdixie is offline   Reply With Quote
Old 06-28-2013, 03:22 AM   #5
vetteoz
CF Senior Member
 
vetteoz's Avatar
 
Member Since: Jan 2004
Default

Quote:
Originally Posted by playsdixie View Post
..what's making the service engine come on"..what in this system will throw a code?....
Why can't you pull the codes?


Quote:
Originally Posted by playsdixie View Post
...Car starts immediately after initial cold start.. and perfectdly the rest of the day...
Even when the engine is dead cold again ?

Quote:
Originally Posted by playsdixie View Post
.a cold start injector?..
On drv side of the intake
Sprays extra fuel in while cranking over on cold starts ( like a choke on carby car ) .
Operated by a thermal switch at the front of the intake

Click the image to open in full size.
vetteoz is offline   Reply With Quote
Old 06-28-2013, 08:02 AM   #6
playsdixie
CF Senior Member
 
playsdixie's Avatar
 
Member Since: Jun 2013
Location: ft myers FL/Munising MI
Send a message via AIM to playsdixie
Default

thanks for the picture...is this hard to replace?...I have 100,000 miles on it. I can't pull the code due to the hyperchip I installled...I may have to take it out although it works so well with performance and keeping the engine temps down....it's a pain to get at in a 85with help from you guys, i've been able to work on problems with it without pulling codes.
although it seems the more I get into it, the more I need to be a NASA engineer...so, is there a test to the cold start injector??? if it wasn't working, would it throw a code...?
playsdixie is offline   Reply With Quote
Old 06-28-2013, 08:02 AM
 
Go Back   Corvette Forum > C4 Corvettes, 1984 - 1996 > C4 Tech/Performance
Reload this Page hard cold start
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine cranks, no start, gas fumes/smoke puffs out of intake RottenApple311 C4 Tech/Performance 20 07-24-2015 12:06 AM
Starting challenge BlairG C4 Tech/Performance 1 09-18-2014 07:33 PM
'82 CE Crossfire - Fuel Injectors JhStephens C3 Tech/Performance 11 05-07-2014 09:23 PM
1985 Corvette hard to start HughG C4 Tech/Performance 32 04-20-2014 12:03 PM
Won't Idle When Cold Bob88vette C4 Tech/Performance 6 09-05-2008 04:05 PM


Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

 
Corvette Store
 
 
C7 Parts & Accessories
C6 Parts & Accessories
C5 Parts & Accessories
C4 Parts & Accessories
C3 Parts & Accessories
C2 Parts & Accessories
C1 Parts & Accessories
Wheels & Tires
Sponsored Ads
Vendor Directory
 

All times are GMT -4. The time now is 04:23 PM.


Emails & Password Backup