Go Back   Corvette Forum > C4 Corvettes, 1984 - 1996 > C4 Tech/Performance
Sign in using an external account
Register Forgot Password?
Register Search Today's Posts Mark Forums Read FAQ Vendor Directory
Search
C4 Tech/Performance
L98 Corvette and LT1 Corvette Technical Info, Internal Engine, External Engine

Reply
 
 
 
 
Thread Tools Search this Thread
Old 11-02-2013, 11:43 AM   #1
jnorth
Junior Member
 
jnorth's Avatar
 
Member Since: Nov 2013
Location: Camrose Alberta
Default flickering dash lights and no start

I just purchased a 1990 that would not start and the digital cluster and the climate control lights are flickering. These are the only lights flickering. All other lights are operating fine.
When i turn the key to start, all lights shut down as they should, but not even a click from the starter.
So obviously i'm thinking VATS. I can jump the start and it works and i can get the engine to fire but it only fires and sputters and dies within 3 seconds. is any of this jumping out to anyone?
jnorth is offline   Reply With Quote
Old 11-02-2013, 12:25 PM   #2
bob guzzy
CF Senior Member
 
bob guzzy's Avatar
 
Member Since: Jan 2006
Location: shavertown Pa.
Default

Have you tried putting the charging the battery, by the sound of it you might not have enough power in the battery to run the car, and if the alternator can't produce enough power to run the car it will die.

If it will run while the jumper cables are hooked to another car the battery power might be your problem.

Also check to see if your ground wire on the battery is making good contact, and that the main wires on the starter are tight.
bob guzzy is offline   Reply With Quote
Old 11-02-2013, 05:26 PM   #3
AustinJohn
CF Senior Member
Support Corvetteforum!
 
AustinJohn's Avatar
 
Member Since: Dec 2006
Location: Austin Texas
Default

Quote:
Originally Posted by jnorth View Post
I just purchased a 1990 that would not start and the digital cluster and the climate control lights are flickering. These are the only lights flickering. All other lights are operating fine.
When i turn the key to start, all lights shut down as they should, but not even a click from the starter.
So obviously i'm thinking VATS. I can jump the start and it works and i can get the engine to fire but it only fires and sputters and dies within 3 seconds. is any of this jumping out to anyone?
It is also possible your neutral safety switch is the culprit. Do a search and you'll find a number of threads on that problem

Good luck! John
__________________

AustinJohn in Austin, Texas

'94 Red/Gray Coupe
Stock

'85 Black/Black Coupe
Anything but stock (Lingenfelter 383 and every Lingenfelter mod available in '88
including 3:54 rear end, big brakes, Centerforce clutch, MSD electronics, Borla exhaust.)
True "barn find" restored/upgraded by me beginning in 2010.

'90 Black/Gray ZR-1 #1723
Ported intake, Haibeck Chip, CORSA exhaust, 4.10 rear end, Hurst shifter,
drilled/slotted rotors, stainless brake lines, 32mm sway bar, 170 stat
AustinJohn is offline   Reply With Quote
Old 11-02-2013, 10:44 PM   #4
jnorth
Junior Member
 
jnorth's Avatar
 
Member Since: Nov 2013
Location: Camrose Alberta
Default

I had a charger/booster hooked up to it because ya, the battery was dead. With the charger on it still flickered and would not turn over with the key. I bought a new batt and will put it in ASAP. I know that voltage has to be correct for these cars to operate properly so I'll start there and find and clean grounds. Here's hoping.
jnorth is offline   Reply With Quote
Old 11-03-2013, 04:19 AM   #5
Cliff Harris
CF Senior Member
 
Cliff Harris's Avatar
 
Member Since: Apr 2002
Location: Anaheim CA
Default

Check your battery cables for a good connection. BOTH ends.
Cliff Harris is offline   Reply With Quote
Old 11-04-2013, 11:24 PM   #6
jnorth
Junior Member
 
jnorth's Avatar
 
Member Since: Nov 2013
Location: Camrose Alberta
Default

Ok, so i changed the battery and that fixed the flickering lights on the dash. But still wouldnt turn over with the key. so i located the starter enable really and while testing conections with a test light, I found that if i grounded the little black wire with yellow strip on it the key worked normally to turn the engine over. but still no start. So first off, I must have a bad ground there, and second must have clogged fuel filter??? the engine will run if i am fogging intake with starting fluid. but it wont run on its own. Anyone know where that starter enable relay gets its ground?
jnorth is offline   Reply With Quote
Old 11-05-2013, 02:31 AM   #7
JrRifleCoach
CF Senior Member
St. Jude '03-'04-'05-'06-'07-'08-'09-'10-'11-'12-'13-'14-'15
 
JrRifleCoach's Avatar
 
Member Since: Sep 2003
Location: "Government failure is not only an option, it is Standard Operating Procedure in the Republik of Kalifornico"

Default

All sorts of good parts get broke when the battery goes down.
Consider buying an FSM to start your troubleshooting journey...
JrRifleCoach is offline   Reply With Quote
Old 11-05-2013, 02:31 AM
 
Go Back   Corvette Forum > C4 Corvettes, 1984 - 1996 > C4 Tech/Performance
Reload this Page flickering dash lights and no start
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Infotainment screen flickering ???? cb98coupe C7 General Discussion 10 12-31-2013 04:30 PM
lights flickering?? glasguydj C5 Tech 4 12-31-2012 03:03 PM
Help.. What have they done!! (elec issue) Qiken C4 Tech/Performance 9 10-08-2012 06:03 PM
Interior lights and parking lights flickering - help c54u C6 Corvette General Discussion 3 11-12-2008 09:24 PM
Flickering dash and headlights Black89-6spd C4 Tech/Performance 11 01-13-2003 02:55 PM



Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Corvette Store
 
 
C7 Parts & Accessories
C6 Parts & Accessories
C5 Parts & Accessories
C4 Parts & Accessories
C3 Parts & Accessories
C2 Parts & Accessories
C1 Parts & Accessories
Wheels & Tires
Sponsored Ads
 
 
Vendor Directory
 

All times are GMT -4. The time now is 11:17 PM.


Emails & Password Backup