Go Back   Corvette Forum > C4 Corvettes, 1984 - 1996 > C4 Tech/Performance
Sign in using an external account
Register Forgot Password?
Register Search Today's Posts Mark Forums Read FAQ Vendor Directory
Search
C4 Tech/Performance
L98 Corvette and LT1 Corvette Technical Info, Internal Engine, External Engine Sponsored by
J&D Corvette

Welcome to Corvetteforum.com!
Welcome to Corvetteforum.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Corvetteforum.com today!


Corvette Store
 
 
C7 Parts & Accessories
C6 Parts & Accessories
C5 Parts & Accessories
C4 Parts & Accessories
C3 Parts & Accessories
C2 Parts & Accessories
C1 Parts & Accessories
Wheels & Tires
Sponsored Ads
 
 
Vendor Directory
  
Closed Thread
 
 
 
 
Thread Tools Search this Thread
Old 08-15-2003, 04:20 AM   #1
CentralCoaster
CF Senior Member
 
CentralCoaster's Avatar
 
Member Since: May 2002
Location: San Diego , CA Double Yellow DirtBags 1985..Z51..6-speed
Default What are the symptoms of a bad IAC valve/motor?

Title says it all. I changed several things out and fixed my nasty rich problem. But I still don't know what caused it.

The IAC was definitely broken, pintle jammed out, and the vette would barely run. It got 12 mpg at cruise, sounded lilke it was firing 10 degrees retarded on 6 cylinders, and spit raw fuel into the exhaust when lettting off the throttle.

I guesss i'll put my broken iac back on tomorrow to see if it acts up again. If that's the case, then i chickened out and took my new injectors back off when i shouldn't have.
CentralCoaster is offline  
Old 08-15-2003, 04:32 AM   #2
Darkness
CF Senior Member
 
Darkness's Avatar
 
Member Since: Apr 2002
Location: Boston
Default Re: What are the symptoms of a bad IAC valve/motor? (CentralCoaster)

I had the same problem a few months ago and it starts to surge when idling or when your driving normal and put it in neutral, some times the engine dies. But it only happened at low rpms, i.e 1000rpm or less.

Later
Darkness is offline  
Old 08-15-2003, 05:46 AM   #3
NanoBrain
CF Senior Member
 
NanoBrain's Avatar
 
Member Since: Jan 2002
Location: Reno NV
Default Re: What are the symptoms of a bad IAC valve/motor? (Darkness)

A bad IAC, especially on a MAF vehicle can cause all kinds of drivability issues. The most common symptoms are surging/hunting idle, or an idle that’s way out of spec (400rpm, or 1500rpm), stalling when coming to a stop, causing the ECM to have an erratic integrator value, accompanied with a moderately swinging A/F ratio. Your description of having an extremely rich A/F & “spitting raw fuel out” on de-acceleration, I would not associate that with a bad IAC! Sounds like you installed much larger Lbs/Hr injectors than stock, didn’t adj the fuel pressure, &/or install a custom chip. Perhaps you have a (NEW) bad injector(s) that leaks or are stuck open? The Accel injectors have gained a bad rep already for leaks and serious performance degradation over short periods of operation!

BTW: running that rich will ruin you engine fast, don’t’ drive it till ya fix it!
Just my 2-cents!

:crazy:NanoBrain:crazy:
NanoBrain is offline  
Old 08-15-2003, 08:51 AM   #4
AGENT 86
CF Senior Member
 
AGENT 86's Avatar
 
Member Since: Jan 2003
Location: Summerland B.C. Canada
Default Re: What are the symptoms of a bad IAC valve/motor? (CentralCoaster)

I don't see any relationship between IAC and your problems. IAC affects idle quality and stability only. It sure sounds like problems with those injectors.
Hope you get solved soon Kevin. Good Luck :cheers:
AGENT 86 is offline  
Old 08-15-2003, 04:21 PM   #5
jennykayes84vette
Junior Member
 
jennykayes84vette's Avatar
 
Member Since: Aug 2003
Location: Shawnee OK
Default Re: What are the symptoms of a bad IAC valve/motor? (Darkness)

Okay here's a question for you all. My wife and I have an 84 vette stock no mods has the same surging and dieing issue at below 1000 rpm's I know that the car is running rich, what are the solutions. I know 84's do not have a MAF in them does anyone have an idea. I found that the EGR Valve Silonoid connector is pretty bad. Still making connection but not a pretty site. It is kinda of a search and destroy mission with this car since it is new to us and we are learning the 84 crossfire "quarks". Please help looking forward to getting back to 2 vehicles again. :banghead:
jennykayes84vette is offline  
Old 05-06-2012, 09:10 PM   #6
BWD111
CF Senior Member
 
BWD111's Avatar
 
Member Since: Mar 2010
Default

What about engine reving to max rpm at start up. I pulled my out it was very dirty, so I cleaned it and put it back in and had the same result. But this could be a symtom of bad IAC.
BWD111 is offline  
Old 05-06-2012, 10:47 PM   #7
H P Bushrod
Moderator
CI 5-6-7-8-9-10-11-12 Veteran
St. Jude Donor '09-'10-'11-12-'13
NCM Sinkhole Donor
 
H P Bushrod's Avatar
 
Member Since: Jun 2002
Location: Maryville Tn
Send a message via AIM to H P Bushrod
Default

Read the rules about reviving a thread over 45 days old BWD111.

http://forums.corvetteforum.com/foru...s-or-more.html
H P Bushrod is offline  
Old 05-06-2012, 10:47 PM
 
Go Back   Corvette Forum > C4 Corvettes, 1984 - 1996 > C4 Tech/Performance
Reload this Page What are the symptoms of a bad IAC valve/motor?
 
 
 
Closed Thread

Tags
1985, bad, broken, c5, condition, corvette, drive, engine, iac, lt1, motor, rich, signs, symptoms, valve


Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Idle Air Control question RetiredSFC 97 C4 Tech/Performance 15 01-29-2010 08:07 PM
IAC questions Insane1 C4 Tech/Performance 6 04-02-2005 03:01 AM
I think I plugged the IAC valve in wrong madmike C4 Tech/Performance 10 03-11-2004 08:03 PM
Idle Valve or Motor cause of rough idle? K87ZZ4 C4 Tech/Performance 3 10-12-2002 04:56 AM
Goofy idle issue related to my throttle body/IAC/TPS/????? Jim85IROC C4 Tech/Performance 7 08-06-2002 10:59 PM


All times are GMT -4. The time now is 01:52 PM.


Emails & Password Backup