Upper Radiator hose not getting hot,. Bad Thermostat? - Corvette Forum

Go Back   >
Log In 
Register FAQ Search Today's Posts Mark Forums Read Vendor Directory

C4 Tech/Performance
L98 Corvette and LT1 Corvette Technical Info, Internal Engine, External Engine

Upper Radiator hose not getting hot,. Bad Thermostat?

Reply
 
 
 
Thread Tools Search this Thread
Old 01-09-2004, 05:36 PM   #1
montie98
CF Senior Member
Thread Starter
 
montie98's Avatar
 
Member Since: May 2003
Location: WATERFORD CT
Posts: 671
Thanks: 0
Thanked 1 Time in 1 Post
Default Upper Radiator hose not getting hot,. Bad Thermostat?

The car just keeps getting hotter with the right amount of coolent then the oferflow tank starts overflowing with lots of pressure meanwhile the upper hose is ice cold????
montie98 is offline   Reply With Quote
Old 01-09-2004, 05:49 PM   #2
Aggravated4life
CF Senior Member
Cruise-In II Veteran
 
Aggravated4life's Avatar
 
Member Since: Aug 2000
Posts: 14,132
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Upper Radiator hose not getting hot,. Bad Thermostat? (montie98)

Maybe the stat is stuck closed?Id check there first.
Aggravated4life is offline   Reply With Quote
Old 01-09-2004, 06:01 PM   #3
vinnies87
CF Senior Member
St. Jude '03-'04-'05-'06-'07
 
vinnies87's Avatar
 
Member Since: Aug 2003
Location: Magnolia Mississippi
Posts: 9,884
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Upper Radiator hose not getting hot,. Bad Thermostat? (Bill's86Coupe)

:iagree: :thumbs:
vinnies87 is offline   Reply With Quote
Old 01-09-2004, 07:37 PM   #4
jackdaroofer
CF Senior Member
Support Corvetteforum!
Cruise-In I Veteran
Cruise-In II Veteran
Cruise-In III Veteran
Cruise-In IV Veteran
Cruise-In V Veteran
Cruise-In VI Veteran
Cruise-In VII Veteran
 
jackdaroofer's Avatar
 
Member Since: Dec 1999
Location: Almost all Skyline Cruises Vettes at Waterside 1-5
Posts: 11,170
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Upper Radiator hose not getting hot,. Bad Thermostat? (vinnies87)

Quote:
:iagree: :thumbs:
:iagree: Too! For some reason I go through a thermo a year on my 88

but let me ask anothe question. How old is the top hose? Those things delaminate internally and the delaminated portion can act like a flapper valve and cut off circulation.

Is the heater putting out hot air?

:seeya

:steering:
jackdaroofer is offline   Reply With Quote
Old 01-09-2004, 08:49 PM   #5
tlc85
CF Member
 
Member Since: Sep 2003
Location: Rincon GA
Posts: 76
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Upper Radiator hose not getting hot,. Bad Thermostat? (montie98)

is your fan comming on?
tlc85 is offline   Reply With Quote
Old 01-10-2004, 02:26 PM   #6
86VetteBill
CF Senior Member
 
Member Since: Jul 2001
Posts: 253
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Upper Radiator hose not getting hot,. Bad Thermostat? (montie98)

Take your time removing those 2 thermostat housing bolts. They might be hard to unscrew. Go too fast with too large of a ratchet and you'll snap one of them off like I did.

That's not fun, especially when you're drilling and tapping a new one and the tap broke!! Taps don't drill out - even with hardest drill bits. I chiseled most of it out.
86VetteBill is offline   Reply With Quote
Old 01-10-2004, 04:14 PM   #7
JAKE
CF Senior Member
 
JAKE's Avatar
 
Member Since: Feb 2000
Location: Kempner Texas
Posts: 9,715
Thanks: 0
Thanked 4 Times in 4 Posts
Default Re: Upper Radiator hose not getting hot,. Bad Thermostat? (86VetteBill)

I vote for a stuck stat too; happened to me last spring.

If that is the case, try to find a replacement that, should it fail, will fail in the open position. They cost a bit more, about $8.00 but won't leave you stranded should it happen again.

I bought mine at O'Reilly's Auto Parts but I'll bet AutoZone sells them too.

Jake
JAKE is offline   Reply With Quote
Go Back   Corvette Forum >
Reload this Page
  • Upper Radiator hose not getting hot,. Bad Thermostat?
  •  
     
    Reply

    Related Topics
    Thread Thread Starter Forum Replies Last Post
    Mandrell bent upper radiator hose spedaleden C3 Tech/Performance 8 04-03-2016 08:47 AM
    Which upper rad hose for my '65? 65VetteVert C1 & C2 Corvettes 4 07-27-2015 02:48 PM
    Radiator hose 71corv C3 Tech/Performance 19 02-02-2015 11:11 AM
    Need a "custom" coolant hose ANTI VENOM C4 Tech/Performance 2 12-06-2014 02:16 PM
    What's the best way to remove hose clamps? slicked25 C4 Tech/Performance 12 03-05-2006 06:47 PM


    Tags
    03, 2003, bad, c5, cold, corvette, hose, hoses, hot, location, radiator, thermostat, top, tube, upper

    Thread Tools Search this Thread
    Search this Thread:

    Click for Advanced Search

    Posting Rules
    You may not post new threads
    You may not post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are Off
    Pingbacks are Off
    Refbacks are Off

    Forum Jump


    All times are GMT -4. The time now is 11:10 AM.