Symptoms of a bad EGR? - CorvetteForum - Chevrolet Corvette Forum Discussion

Register FAQ Search Today's Posts Mark Forums Read Vendor Directory

C4 Tech/Performance
L98 Corvette and LT1 Corvette Technical Info, Internal Engine, External Engine

Symptoms of a bad EGR?

Reply
 
 
 
Thread Tools Search this Thread
Old 03-17-2004, 07:56 PM   #1
Tourney3p0
CF Senior Member
Thread Starter
 
Tourney3p0's Avatar
 
Member Since: Aug 2002
Location: Warner Robins GA
Posts: 715
Thanks: 0
Thanked 0 Times in 0 Posts
Default Symptoms of a bad EGR?

I read somewhere in the archives that a bad EGR could possibly cause a sound like lifter clatter a few minutes after the car is started.

My car has a sound like that (not a tick exactly, more like a clack) that starts around the time the car goes closed loop. I was almost certain that it was timing chain slap so I've bought a Cloyes set but haven't put it on yet.

Yesterday I got a code 32 immediately after starting my car, so I started poking around the archives and came across a couple of people saying a bad EGR could cause a similar sound. My EGR valve and tube are intact but my AIR system is gone.

I'd consult my Helms manual to see what it says about an immediate code 32, but I'm in the process of moving. It's here and I'm there.. anyway, I've always heard code 32 should come up after driving a few miles, not immediately.

I'm not really looking for how to fix code 32.. the code didn't come back after I stopped the car and restarted it. I know it's EGR, I'm just wondering if maybe that random code 32 could be related to my clatter under the hood.
Tourney3p0 is offline   Reply With Quote
Old 03-17-2004, 08:57 PM   #2
65Z01
CF Senior Member
Cruise-In II Veteran
 
65Z01's Avatar
 
Member Since: Dec 2000
Location: SE NY
Posts: 71,930
Thanks: 0
Thanked 7 Times in 6 Posts
Default Re: Symptoms of a bad EGR? (Tourney3p0)

I've never heard of clatter from an EGR but when the code 32 comes up immediately after startup the ECM is detecting the EGR valve to be open when it has not been commanded to open.

While cruzing in closed loop mode the ECM will command the EGR valve to open and also throw a code 32 if it doesn't detect (via the EGR Temp Switch) that it has opened.

When you get around to servicing the EGR system there is a diagnostic method on my site.
65Z01 is online now   Reply With Quote
Old 03-18-2004, 12:21 AM   #3
VAHROOM
CF Senior Member
 
VAHROOM's Avatar
 
Member Since: Apr 2000
Location: Chandler AZ
Posts: 962
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Symptoms of a bad EGR? (Tourney3p0)

My EGR only coded after 20 minutes of driving. Not right away. I tested it with a piece of vacuum hose and tested its ability to hold vacuum. It failed. I replaced it and code 32 was gone. Just suck in on the vacuum hose connected to the nipple on the valve. Watch to see if the plunger moves. Hold the hose closed and see if it leaks down. If it moves and doesn't leak down. You are good to go.
VAHROOM is offline   Reply With Quote
Old 03-18-2004, 12:54 PM   #4
jmrl98
CF Senior Member
 
jmrl98's Avatar
 
Member Since: May 2002
Location: Hazel Park MI
Posts: 1,500
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Symptoms of a bad EGR? (VAHROOM)

That clack or ticking is the solenoid or switch for the EGR. It is happening to my 85 every time I start it up. The noise is very audible, different from the injectors, and definitly from the passenger side by the EGR. I'm going to change the solenoid (kit from midamerica) and clean the EGR, and see what the results are. The shop manual says that a malfunctioning EGR will cause idle drop upon deceleration, which I do notice but it is not like the thing is going to stall. I'm hoping the EGR cleaning and switching of he solenoid will clear up the deceleration issue and stabilize my idle a little (not that my idle jumps too much anyway). :seeya :steering:oh yeah, I'm not getting any codes, either.


[Modified by jmrl98, 10:55 AM 3/18/2004]
jmrl98 is offline   Reply With Quote
Old 03-18-2004, 11:43 PM   #5
CentralCoaster
CF Senior Member
 
CentralCoaster's Avatar
 
Member Since: May 2002
Location: San Diego , CA Double Yellow DirtBags 1985..Z51..6-speed
Posts: 24,339
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Symptoms of a bad EGR? (jmrl98)

I think I have the same problem. THe smog tech said the EGR was not responding like it should (yet it hasn't thrown any codes :confused:) I'm also hearing what I thought was injector ticking coming from near cylinders 6 and 8 (which is near the EGR solenoid on my 85).

I picked up a vacuum pump, and i'll diagnose everything tomorrow if I get a chance. New Delco EGR valve is already on its way..


[Modified by CentralCoaster, 7:44 PM 3/18/2004]
CentralCoaster is offline   Reply With Quote
Old 03-19-2004, 02:18 AM   #6
Jloshotz
CF Senior Member
 
Jloshotz's Avatar
 
Member Since: Feb 2004
Location: Long Island New York
Posts: 1,024
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Symptoms of a bad EGR? (Tourney3p0)

Check your plugs in cyls # 5 And # 6. When my EGR went bad In my 91 tuned port 5.7 z28 # 5 plug was detonated so bad it was rediculous. No Ground bar and electrode was actually hollowed out....scary

:eek: :eek: :eek:
Jloshotz is offline   Reply With Quote
Go Back   CorvetteForum - Chevrolet Corvette Forum Discussion >
Reload this Page
  • Symptoms of a bad EGR?
  •  
     
    Reply

    Related Topics
    Thread Thread Starter Forum Replies Last Post
    Trouble codes 16 32 55 HollywoodHornet C4 Tech/Performance 6 07-27-2015 10:29 AM
    Corvette EGR Control Valve Relay Solenoid lvbg1435 C4 Tech/Performance 6 01-23-2012 09:12 AM
    Mileage Drop after Injector Swap rickso84 C4 Tech/Performance 35 12-12-2008 10:40 PM
    Idle problems. EGR? 86Pacecar C4 Tech/Performance 11 04-23-2003 12:04 PM
    Code 32. Difficult to fix? Juliet C4 Tech/Performance 3 10-19-2001 09:13 PM


    Tags
    1991, 1997, 57, bad, corvette, egr, lt1, port, skipping, solenoid, symptomps, symptoms, symptons, tuned, valve, z28

    Thread Tools Search this Thread
    Search this Thread:

    Click for Advanced Search

    Posting Rules
    You may not post new threads
    You may not post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are Off
    Pingbacks are Off
    Refbacks are Off

    Forum Jump


    All times are GMT -4. The time now is 10:26 PM.