Go Back   Corvette Forum > C5 Corvettes, 1997 - 2004 > C5 General
Sign in using an external account
Register Forgot Password?
Register Search Today's Posts Mark Forums Read FAQ Vendor Directory
Search
C5 General
General C5 Corvette Discussion not covered in Tech Sponsored by
Bud's Chevy

Welcome to Corvetteforum.com!
Welcome to Corvetteforum.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Corvetteforum.com today!


Corvette Store
 
 
C7 Parts & Accessories
C6 Parts & Accessories
C5 Parts & Accessories
C4 Parts & Accessories
C3 Parts & Accessories
C2 Parts & Accessories
C1 Parts & Accessories
Wheels & Tires
Sponsored Ads
 
 
Vendor Directory
  
Reply
 
 
 
 
Thread Tools Search this Thread
Old 07-23-2014, 10:50 AM   #1
703
CF Senior Member
 
703's Avatar
 
Member Since: Feb 2013
Location: Webster NY
Default Sooner or later it was bound to happen...

Well it happened sooner rather than later... Went to start the car last night and the "pull key wait 10 sec" shows up on the dash. I'm just like Luckily it was in the garage so I didn't get stranded in a parking lot.

So now I guess it's time to order the LMC5 + unlocker & check to make sure the battery is in good health.

Only question I have is I know some people have had issues installing / getting them to work on a manual. I know there was a write up on how to do it, Anyone have the link ?
703 is offline   Reply With Quote
Old 07-23-2014, 11:10 AM   #2
Marc@Vettenuts.net
Supporting Vendor
St. Jude Donor '11
 
Marc@Vettenuts.net's Avatar
 
Member Since: May 2010
Location: OEM Parts, Sub Boxes Etc. 615-896-6100 Murfreesboro TN
/pages/VetteNutsnet/191467407563211
Default

We sell them and they are the best CLB available. We have never had any problems with a manual car. If you have any issues you can call there tech line and they will guide you right through it. Excellent customer service!

Order Here: LMC5
Marc@Vettenuts.net is offline   Reply With Quote
Old 07-24-2014, 01:27 AM   #3
laurent_zo6
CF Senior Member
Support Corvetteforum!
 
laurent_zo6's Avatar
 
Member Since: Aug 2013
Default

Quote:
Originally Posted by 703 View Post
Well it happened sooner rather than later... Went to start the car last night and the "pull key wait 10 sec" shows up on the dash. I'm just like Luckily it was in the garage so I didn't get stranded in a parking lot.

So now I guess it's time to order the LMC5 + unlocker & check to make sure the battery is in good health.

Only question I have is I know some people have had issues installing / getting them to work on a manual. I know there was a write up on how to do it, Anyone have the link ?
There is a YouTube video:

Also from Dadaroo, forum member, who has this advice:

Not uncommon for people to "put the column in a pre-lock condition" and not know it and then start with the install. In other words, they started with the column lock “energized’ even if it was not actually locked yet. If not actually locked yet, it will be as soon as you turn the steering wheel after the LMC5 install. It will then remain in the locked condition until you cause the motor to unlock. It will then remain in the unlocked condition since the motor is then unpowered with the circuits disconnected.
Here is one way to prevent that if your c olumn locks and unlocks normally:
If the CL is functioning normally you don't need the Unlocker, merely turn the igniti on, pull fuse #23, turn ignition OFF, turn the steering wheel (left and right ) and verify it i s unlocked. Next, disconnect the negative battery terminal, re-insert fuse #23 and continue with the install.
laurent_zo6 is offline   Reply With Quote
Old 07-24-2014, 06:38 AM   #4
Cybermind
CF Senior Member
Support Corvetteforum!
 
Cybermind's Avatar
 
Member Since: Apr 2009
Location: Montreal Quebec
Vettefreak66
Default

You should install some form of column lock bypass no matter what but, the "pull key and wait 10 secs" error message is often caused by your key resistance puck not reading correctly. Make sure it is clean and not damaged or excessively worn down. Try spraying your key with electronic contact cleaner and moving it in and out of the ignition several times. If the message goes away, you have found the culprit. You can also spray some contact cleaner in the ignition key hole.
Cybermind is online now   Reply With Quote
Old 07-24-2014, 08:53 AM   #5
703
CF Senior Member
 
703's Avatar
 
Member Since: Feb 2013
Location: Webster NY
Default

So for an update I'm not getting the pull key wait 10sec code anymore. But the steering wheel does lock when I pull the key out of ignition. I ordered the LMC5 & unlocker yesterday. I haven't checked the battery but that could be the culprit as well from what I have read.
703 is offline   Reply With Quote
Old 07-24-2014, 10:02 AM   #6
bjones7131
CF Senior Member
 
bjones7131's Avatar
 
Member Since: Jan 2014
Location: Walhalla South Carolina
Default

I installed the LMC5 on my o1 about a month ago. Only difficuct part was disconnecting the electrical connection on the relay I believe above the silver BCM in the footwell. The online youtube doesn't show that part, only removing and replacing the wires. The instructions are great on the LMC5 info U get with the package. It really helps to watch the youtube. After the install U will need to wait 1 or 2 seconds after turning on the key to let the BCM or computer system do its thing before cranking the car or U will still get the message. I found this to be the case on my vette and instructions says to wait a second or two and I also contacted the vendor and they told me same thing. I haven't had an issue since. Good luck
bjones7131 is offline   Reply With Quote
Old 07-24-2014, 10:02 AM
 
Go Back   Corvette Forum > C5 Corvettes, 1997 - 2004 > C5 General
Reload this Page Sooner or later it was bound to happen...
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
4d00 TacDoc C7 General Discussion 9 10-09-2013 06:48 AM
It must be time. sfc rick C5 General 37 09-10-2013 08:57 AM
Well, one step closer to being back on the road! qwiketz C4 Forced Induction/Nitrous 3 12-19-2012 01:40 AM
[HVAC] 80% efficient furnaces not sold after May 2013??? TAL Off Topic 24 11-29-2012 03:37 PM
Octane over 100? roosterocks C6 Tech/Performance 9 07-25-2012 06:17 PM


All times are GMT -4. The time now is 06:15 AM.


Emails & Password Backup