Horn won't work. - CorvetteForum - Chevrolet Corvette Forum Discussion

Register FAQ Search Today's Posts Mark Forums Read Vendor Directory

C5 Tech
Corvette Tech/Performance: LS1 Corvette Technical Info, Internal Engine, External Engine, Tech Topics, Basic Tech, Maintenance, How to Remove & Replace Sponsored by
Dart Machinery

Horn won't work.

Reply
 
 
 
Thread Tools Search this Thread
Old 06-02-2009, 01:27 AM   #1
TORCH
Airborne Moderator
St. Jude Donor '09
Support Corvetteforum!
Thread Starter
 
TORCH's Avatar
 
Member Since: Dec 1999
Location: Fairbanks Alaska
Posts: 25,842
Thanks: 0
Thanked 0 Times in 0 Posts
Default Horn won't work.

If I set off the car alarm the horn works fine but if I try to use the horn by pushing on the horns on the stearing wheel it doesn't work. I checked fuses. Any other suggestions.

Thanks in advance.
TORCH is offline   Reply With Quote
Old 06-02-2009, 08:52 AM   #2
Pwrtrip75
CF Senior Member
 
Pwrtrip75's Avatar
 
Member Since: Nov 2006
Location: Janesville Wisconsin
Posts: 380
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Interested in this also. I have the same issue on my 99.
Pwrtrip75 is offline   Reply With Quote
Old 06-02-2009, 09:28 AM   #3
ajg1915
CF Senior Member
St. Jude Donor '08
Support Corvetteforum!
 
ajg1915's Avatar
 
Member Since: May 2005
Location: West Norriton PA
Posts: 15,926
Thanks: 0
Thanked 6 Times in 5 Posts
Default

The problem could be either of these two items.

The air bag contains a membrane that over time from the heat begins to fail or work no longer. Try pushing in around the horn areas on both sides and see if the horn works, if you have no success then it might be the second problem.

The second problem requires the removal of the air bag from the steering column. There is a spring loaded (red wire) that rubs on a contact in the steering hub that may of become dirty. Try some electrical cleaner on it and reassembly.
ajg1915 is offline   Reply With Quote
Old 06-08-2009, 11:42 AM   #4
TORCH
Airborne Moderator
St. Jude Donor '09
Support Corvetteforum!
Thread Starter
 
TORCH's Avatar
 
Member Since: Dec 1999
Location: Fairbanks Alaska
Posts: 25,842
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by ajg1915 View Post
The problem could be either of these two items.

The air bag contains a membrane that over time from the heat begins to fail or work no longer. Try pushing in around the horn areas on both sides and see if the horn works, if you have no success then it might be the second problem.

The second problem requires the removal of the air bag from the steering column. There is a spring loaded (red wire) that rubs on a contact in the steering hub that may of become dirty. Try some electrical cleaner on it and reassembly.
Thanks. Can I remove the air bag? I don't want to set that dayum thing off.
TORCH is offline   Reply With Quote
Old 06-08-2009, 12:23 PM   #5
ajg1915
CF Senior Member
St. Jude Donor '08
Support Corvetteforum!
 
ajg1915's Avatar
 
Member Since: May 2005
Location: West Norriton PA
Posts: 15,926
Thanks: 0
Thanked 6 Times in 5 Posts
Default

Quote:
Originally Posted by TORCH View Post
Thanks. Can I remove the air bag? I don't want to set that dayum thing off.
You'll need to disconnect the battery and pull the fuse for the SDM in passenger footwell.

I wait about a 1/2 hour to make sure it's discharged all of the power before removing.
ajg1915 is offline   Reply With Quote
Old 06-08-2009, 01:00 PM   #6
8VETTE7
CF Senior Member
 
8VETTE7's Avatar
 
Member Since: Jul 2007
Posts: 16,959
Thanked 579 Times in 522 Posts
Default

Quote:
Originally Posted by ajg1915 View Post
You'll need to disconnect the battery and pull the fuse for the SDM in passenger footwell.

I wait about a 1/2 hour to make sure it's discharged all of the power before removing.
You definitely need to wait a while after disconnecting the battery as there is a capacitor that hold charge on the air bag system for a while. 30 minutes is more than safe.

Here's some reading for you related to the Membrane if that is the problem:

http://forums.corvetteforum.com/show....php?t=1739923
8VETTE7 is offline   Reply With Quote
Old 06-08-2009, 11:48 PM   #7
byronhunter
CF Senior Member
 
byronhunter's Avatar
 
Member Since: Oct 2007
Location: Kinston North Carolina
Posts: 2,378
Thanks: 0
Thanked 1 Time in 1 Post
Default

byronhunter is offline   Reply With Quote
Go Back   CorvetteForum - Chevrolet Corvette Forum Discussion >
Reload this Page
  • Horn won't work.
  •  
     
    Reply

    Related Topics
    Thread Thread Starter Forum Replies Last Post
    Horn jechler C4 General Discussion 1 11-20-2014 01:37 PM
    horn won't blow grassblaster C5 Tech 1 11-03-2013 11:02 PM
    1986 Corvette No Horn Lathroum C4 Tech/Performance 4 05-29-2010 10:12 AM
    New Horn Relay and still no Horn? pipe C4 Tech/Performance 27 05-23-2008 08:51 PM
    Horn problem Norman Teegardin C1 & C2 Corvettes 6 05-21-2006 05:02 PM


    Tags
    1991, 2000, 94, corvette, horn, wont, work

    Thread Tools Search this Thread
    Search this Thread:

    Click for Advanced Search

    Posting Rules
    You may not post new threads
    You may not post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are Off
    Pingbacks are Off
    Refbacks are Off

    Forum Jump


    All times are GMT -4. The time now is 03:07 AM.