Charge system fault!!!!!!!!!! - CorvetteForum - Chevrolet Corvette Forum Discussion

Go Back   >
Log In 
Register FAQ Search Today's Posts Mark Forums Read Vendor Directory

C5 Tech
Corvette Tech/Performance: LS1 Corvette Technical Info, Internal Engine, External Engine, Tech Topics, Basic Tech, Maintenance, How to Remove & Replace Sponsored by
Dart Machinery

Charge system fault!!!!!!!!!!

Reply
 
 
 
Thread Tools Search this Thread
Old 06-09-2011, 10:04 PM   #1
SCRMNC5
CF Senior Member
Thread Starter
 
SCRMNC5's Avatar
 
Member Since: Aug 2008
Location: Madison Ct.
Posts: 739
Thanks: 0
Thanked 0 Times in 0 Posts
Default Charge system fault!!!!!!!!!!

I need some help guys!!! got this display for Charge system fault the other day. bought a new battery and alternator just to make sure. put them both in and still had the same display up, with a voltage reading of 11.2-10.9. Talked to a buddy told me to make sure my connections were tight on the starter, I did, and got almost a full turn on that bolt. Put everything back together and the voltage went back up to 13.2. Took the car out today, and the voltage kept going down, and eventually I lost all the gauges on the dash then shortly after the car shut down, dead!!!!!!! Had a new battery driven out to me at the car, installed it and ..........nothing, wouldn't even turn over. Is my starter fried??? and if it is will it cause my whole system not to charge?? Please, any info will be greatly appreciated, as I am going to be doing the work myself. Thanks in advance.


Barry
SCRMNC5 is offline   Reply With Quote
Old 06-10-2011, 07:48 AM   #2
dgrant3830
Tech Contributor
Wounded Warrior Escort '11
Support Corvetteforum!
 
dgrant3830's Avatar
 
Member Since: Dec 2006
Location: Van Buren Arkansas
Posts: 10,961
Thanks: 0
Thanked 5 Times in 5 Posts
Default

There is a fuesable link between the starter and the alternator. Put a meter on the large red wire on the alternator when the engine is off and see if you measure any voltage there on it.
dgrant3830 is offline   Reply With Quote
Go Back   CorvetteForum - Chevrolet Corvette Forum Discussion >
Reload this Page
  • Charge system fault!!!!!!!!!!
  •  
     
    Reply

    Related Topics
    Thread Thread Starter Forum Replies Last Post
    Charge System Fault!! SCRMNC5 C5 General 9 06-14-2011 02:11 PM
    Stuck on vacation, DIC volts fluctuating. Jistari C5 Tech 18 04-22-2011 01:32 AM
    Stck on vacation, need vette mechanic near Long Beach Island New Jersey Jistari Northeast 19 08-07-2007 04:35 PM
    Alternator/Regulator Explained and Tested plaidside C3 Tech/Performance 2 05-21-2007 12:44 AM
    Alternator/Regulator Explained and Tested plaidside C1 & C2 Corvettes 2 05-20-2007 10:36 AM


    Tags
    2004, battery, c5, charge, corvette, fault, forum, system

    Thread Tools Search this Thread
    Search this Thread:

    Click for Advanced Search

    Posting Rules
    You may not post new threads
    You may not post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are Off
    Pingbacks are Off
    Refbacks are Off

    Forum Jump


    All times are GMT -4. The time now is 07:55 AM.