Help won't start codes P1518 and P0601 - Corvette Forum

Go Back   >
Log In 
Register FAQ Search Today's Posts Mark Forums Read Vendor Directory

C5 Tech
Corvette Tech/Performance: LS1 Corvette Technical Info, Internal Engine, External Engine, Tech Topics, Basic Tech, Maintenance, How to Remove & Replace Sponsored by
Dart Machinery

Help won't start codes P1518 and P0601

Reply
 
 
 
Thread Tools Search this Thread
Old 09-15-2013, 08:35 AM   #1
Cmeaux
Junior Member
Thread Starter
 
Member Since: Jul 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default Help won't start codes P1518 and P0601

Hi, I am looking for help, I own a 1998 corvette coupe with only 6200 miles, the car has not been used for about 2 years, but I start the car every week or so, last week the battery died so I connected a Schumacher fast charger, and started the car, after 2 minutes the car stopped and I tried to started over but in the display appeared Reduced Engine Power, Service TCS, Service ABS; I pulled the codes and they were P1518 and P0601, I tried deleting them but they appear again, the engine wont start.
I've been reading various threads and doing what some people have done to solve their problems but it hasn't worked.

Here is a list of things I've done to try to start the car:
1 checked all fuses (throtcont)
2 changed the relays between them (when I move one relay there is a noise in the throttle body so I guess it is working)
3 changed the screws on the terminal so they be tight
4 check the volts on the throttle control motor harness
5 checked the front grounds that are next to the headlamps finding no corrosion whatsoever.

I don't know what else to do, hope someone can help me.

Thanks
Cmeaux is offline   Reply With Quote
Old 09-15-2013, 10:01 AM   #2
8VETTE7
CF Senior Member
 
8VETTE7's Avatar
 
Member Since: Jul 2007
Posts: 16,353
Thanked 431 Times in 388 Posts
Default

Quote:
Originally Posted by Cmeaux View Post
Hi, I am looking for help, I own a 1998 corvette coupe with only 6200 miles, the car has not been used for about 2 years, but I start the car every week or so, last week the battery died so I connected a Schumacher fast charger, and started the car, after 2 minutes the car stopped and I tried to started over but in the display appeared Reduced Engine Power, Service TCS, Service ABS; I pulled the codes and they were P1518 and P0601, I tried deleting them but they appear again, the engine wont start.
I've been reading various threads and doing what some people have done to solve their problems but it hasn't worked.

Here is a list of things I've done to try to start the car:
1 checked all fuses (throtcont)
2 changed the relays between them (when I move one relay there is a noise in the throttle body so I guess it is working)
3 changed the screws on the terminal so they be tight
4 check the volts on the throttle control motor harness
5 checked the front grounds that are next to the headlamps finding no corrosion whatsoever.

I don't know what else to do, hope someone can help me.

Thanks



Won't Start?????

Cranks but will not run??

Doesn't crank???

P0601 - PCM Memory Not a good code to have


P1518 - PCM to TAC module Serial Data Circuit



Are you certain there are no other codes??? P0606 possibly?

This COULD be a TAC module problem. Over the years I have read a number of threads about 98's and these two codes in combination. If the TAC module is not the problem you are looking at replacing the PCM.

Last edited by 8VETTE7; 09-15-2013 at 10:03 AM.
8VETTE7 is offline   Reply With Quote
Old 09-15-2013, 10:46 AM   #3
Cmeaux
Junior Member
Thread Starter
 
Member Since: Jul 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for your answer the car will crank but won't start, I checked to see if there is spark but there isn't.
The p1518 and the p0601 are the only two codes for powertrain, it also has codes for ABS and TCS, that are deleted and come back again moments after.
Cmeaux is offline   Reply With Quote
Old 09-16-2013, 12:54 PM   #4
Cmeaux
Junior Member
Thread Starter
 
Member Since: Jul 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Any idea?
Cmeaux is offline   Reply With Quote
Old 09-16-2013, 06:12 PM   #5
sean.b
CF Senior Member
 
sean.b's Avatar
 
Member Since: Feb 2010
Location: Denver Colorado
Posts: 1,404
Thanked 1 Time in 1 Post
Default

no spark and those codes is bad PCM, is it not?
sean.b is offline   Reply With Quote
Go Back   Corvette Forum >
Reload this Page
  • Help won't start codes P1518 and P0601
  •  
     
    Reply

    Related Topics
    Thread Thread Starter Forum Replies Last Post
    P1518 - don't leave home without it :) qwck10th C5 Tech 3 04-13-2016 07:36 PM
    2001 C5 Z06 - Ignition Relay Keeps Failing - Reduced Engine Power RXPX C5 Tech 39 07-04-2015 02:10 PM
    Can't clear p1518 code tcen24b C5 Tech 20 06-16-2015 01:07 AM
    P0601, Reduced Engine Power, PCM, and ChuckCow... DocMorgan C6 Tech/Performance 5 12-20-2014 11:56 PM
    Reduced Engine Power/P1518/Fuse 17 BigT69 C5 Tech 3 11-21-2007 11:51 AM


    Thread Tools Search this Thread
    Search this Thread:

    Click for Advanced Search

    Posting Rules
    You may not post new threads
    You may not post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are Off
    Pingbacks are Off
    Refbacks are Off

    Forum Jump


    All times are GMT -4. The time now is 12:08 PM.