Go Back   Corvette Forum > C5 Corvettes, 1997 - 2004 > C5 Z06 Discussion
Sign in using an external account
Register Forgot Password?
Register Search Today's Posts Mark Forums Read FAQ Vendor Directory
Search
C5 Z06 Discussion
General Z06 Corvette Discussion, LS6 Corvette Technical Info, Performance Upgrades, Suspension Setup for Street or Track Sponsored by
PFYC

Welcome to Corvetteforum.com!
Welcome to Corvetteforum.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Corvetteforum.com today!


Corvette Store
 
 
C7 Parts & Accessories
C6 Parts & Accessories
C5 Parts & Accessories
C4 Parts & Accessories
C3 Parts & Accessories
C2 Parts & Accessories
C1 Parts & Accessories
Wheels & Tires
Sponsored Ads
 
 
Vendor Directory
  
Closed Thread
 
 
 
 
Thread Tools Search this Thread
Old 02-19-2006, 10:55 PM   #1
02z06tr
CF Member
 
02z06tr's Avatar
 
Member Since: Feb 2006
Default trunk lid doesn't "pop up"????

Hi guys, This should be an easy one for you guys. When I pop the trunk lid, either with the key fob or from inside, it pops but only opens a little bit, it is hard to get fingers under lid to lift up. I tired lubrication the piston but no change. any ideas??? Thanks, Ed
02z06tr is offline  
Old 02-19-2006, 11:03 PM   #2
JETZ
CF Senior Member
 
JETZ's Avatar
 
Member Since: Nov 2001
Default

Slam the door shut, the air preasure will pop it up more.
OR...
Click the image to open in full size.
JETZ is offline  
Old 02-19-2006, 11:05 PM   #3
Beaver06
CF Senior Member
 
Beaver06's Avatar
 
Member Since: Dec 2002
Location: Savannah, Huntsville
Send a message via Yahoo to Beaver06 Send a message via Skype™ to Beaver06
Default

Beaver06 is offline  
Old 02-19-2006, 11:58 PM   #4
TheDVS1
CF Senior Member
 
TheDVS1's Avatar
 
Member Since: May 2004
Location: San Clemente CA
Default

A little white lithium grease on the release mechanism solved that problem for me. It's been well over a year now and she still pops just fine.
TheDVS1 is offline  
Old 02-20-2006, 12:00 AM   #5
pdqz06
CF Senior Member
 
Member Since: Jul 2005
Default

Quote:
Originally Posted by JETZ
Slam the door shut, the air preasure will pop it up more.
OR...
Click the image to open in full size.

pdqz06 is offline  
Old 02-20-2006, 12:14 AM   #6
Dennis Wilson
CF Senior Member
 
Dennis Wilson's Avatar
 
Member Since: Oct 2003
Location: Murrieta Calif.
Default

I had the same problem & just sprayed i bit of WD-40 on it [ the lock mechinism] .And it works fine! pops uo about 2 inches now!
Dennis Wilson is offline  
Old 02-20-2006, 12:50 AM   #7
Z28STYLE23
CF Senior Member
 
Z28STYLE23's Avatar
 
Member Since: Oct 2004
Location: Torrance California
chris bour
Default

Quote:
Originally Posted by pdqz06
Might be stupid but lookin at the pic what are we lookin at to fix this
problem.
Z28STYLE23 is offline  
Old 02-20-2006, 01:24 AM   #8
jcraven
Junior Member
 
Member Since: Feb 2006
Location: Seattle WA
Default

Mine does this too. The guy I bought my ’01 Z06 from has an ’06 Z06…same problem. I normally use the close-the-door technique or gently wedge a key between the deck lid and body to lift it up a bit . I’ll have to try the lithium grease technique!
jcraven is offline  
Old 02-20-2006, 02:17 AM   #9
leaftye
CF Senior Member
 
Member Since: Nov 2003
Location: San Diego, CA "leaf" "tee" "e"
Send a message via ICQ to leaftye Send a message via AIM to leaftye Send a message via Yahoo to leaftye
Default

You want something that'll help it pop up a little more??
leaftye is offline  
Old 02-20-2006, 02:45 AM   #10
Z06-Goose
CF Senior Member
 
Z06-Goose's Avatar
 
Member Since: Dec 2001
Location: Boulder CO.
Default

Quote:
Originally Posted by leaftye
You want something that'll help it pop up a little more??
I think that's what he's saying. Mine does the same thing. I'd like to be able to make it pop-up more so I don't have to deal with the shutting the doors trick. It just doesn't look cool.
Z06-Goose is offline  
Old 02-20-2006, 04:40 AM   #11
mkiv808
CF Senior Member
 
mkiv808's Avatar
 
Member Since: Dec 2005
Location: Fairfield County CT
Default

How high is it supposed to pop? Mine only pops up maybe half an inch and then I wedge my fingers under it to pull it up.
mkiv808 is offline  
Old 02-20-2006, 08:21 AM   #12
RAO-3
CF Senior Member
 
RAO-3's Avatar
 
Member Since: Feb 2004
Location: Central NJ
Default

Quote:
Originally Posted by Z28STYLE23
Might be stupid but lookin at the pic what are we lookin at to fix this
problem.

Added a spring on the lifting mechanism. This worked for me, but the lube helps too!

Ray
RAO-3 is offline  
Old 02-20-2006, 09:40 AM   #13
JoeZ
CF Senior Member
 
JoeZ's Avatar
 
Member Since: Aug 2002
Location: New York Flemington
Send a message via ICQ to JoeZ
Default

I had the same problem when I first got my Z06...I just sprayed WD-40 in the latch and it worked. Now, a year later, it is starting to stick again so it is time for WD-40 once more!

Also did the WD-40 on the center console armrest hinge which made a world of difference in opening it up.
JoeZ is offline  
Old 02-20-2006, 04:26 PM   #14
IsItFast
CF Senior Member
 
IsItFast's Avatar
 
Member Since: May 2002
Location: Lenexa KS
Default

WD40 worked for me too. I may have sprayed a little on the hinges too for that little extra. But I belive the latch is the main problem. Do it about once a year.
IsItFast is offline  
Old 02-20-2006, 07:29 PM   #15
02z06tr
CF Member
 
02z06tr's Avatar
 
Member Since: Feb 2006
Default

Thanks guys, as usual one question and a ton of ideas, I can't say enough about this site! I tried the wd40 it didn'twork, the door slam I knew about, but as someone said, it isn't to cool when you are coming up to your car and have to release the latch, open the door, shut the door, open the trunk shut the trunk! i will try the lithium grease. the spring thing will be next. is that just a regular spring from Home Depot?? not a vette part i presume?? Thanks again!
02z06tr is offline  
Old 02-20-2006, 07:31 PM   #16
Miguels
CF Senior Member
 
Miguels's Avatar
 
Member Since: Mar 2004
Location: San Jose Ca
Send a message via AIM to Miguels Send a message via Yahoo to Miguels
Default

what type of spring it that?
Miguels is offline  
Old 02-20-2006, 07:34 PM   #17
Crushinator
CF Senior Member
 
Crushinator's Avatar
 
Member Since: Mar 2001
Location: Sunbury PA
Default

Quote:
Originally Posted by Dennis Wilson
I had the same problem & just sprayed i bit of WD-40 on it [ the lock mechinism] .And it works fine! pops uo about 2 inches now!
Cool, I'll have to try that. All three of my Z06's have had this problem and I never knew what to do about it.
__________________
Previous Vettes
1996 LT4
1997 Carroll Supercharged coupe
2002 Z06 (black)
2004 Z06 (yellow)
2004 Z16 ECS 825 horsepower
Crushinator is offline  
Old 02-20-2006, 07:44 PM   #18
JETZ
CF Senior Member
 
JETZ's Avatar
 
Member Since: Nov 2001
Default

Quote:
Originally Posted by 02z06tr
Thanks guys, as usual one question and a ton of ideas, I can't say enough about this site! I tried the wd40 it didn'twork, the door slam I knew about, but as someone said, it isn't to cool when you are coming up to your car and have to release the latch, open the door, shut the door, open the trunk shut the trunk! i will try the lithium grease. the spring thing will be next. is that just a regular spring from Home Depot?? not a vette part i presume?? Thanks again!
Not my mod, just reposted a members pic. Looks like what ever you can get a hold of to try, and if it does the job...it's the right one!
JETZ is offline  
Old 02-20-2006, 08:11 PM   #19
RaleighSS
CF Senior Member
 
RaleighSS's Avatar
 
Member Since: Jun 2005
Location: Youngsville NC
Default twisty things

I adjusted the black bumpers on each corner of the trunk lid and mine now opens fine... ya have to play with it a few times... but mine opens up just fine now..
RaleighSS is offline  
Old 02-20-2006, 08:55 PM   #20
Z06-Goose
CF Senior Member
 
Z06-Goose's Avatar
 
Member Since: Dec 2001
Location: Boulder CO.
Default

One quick question...
wouldn't too much WD40 wash away the lubing?
Z06-Goose is offline  
Old 02-20-2006, 08:55 PM
 
Go Back   Corvette Forum > C5 Corvettes, 1997 - 2004 > C5 Z06 Discussion
Reload this Page trunk lid doesn't "pop up"????
 
 
 
Closed Thread

Tags
2001, 2004, c5, c6, convertible, corvette, deck, hard, lid, open, openante, pop, trunk, z06, zr1


Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Trunk Lid wont pop jet843 C5 Tech 24 09-22-2014 02:30 PM
Unable to release trunk in '08 to open hood jan5 C6 Corvette General Discussion 12 01-18-2014 10:25 AM
Trunk lid spring - painted? Lou61 C1 & C2 Corvettes 2 01-17-2014 12:45 PM
TRUNK LID "STILL" WILL NOT POP UP! Bill Curlee C5 Z06 Discussion 29 11-12-2003 09:14 AM
TRUNK RELEASE PROBLEMS!!! Bill Curlee C5 Z06 Discussion 18 08-04-2002 10:08 PM


All times are GMT -4. The time now is 10:32 AM.


Emails & Password Backup