Go Back   Corvette Forum > C6 Corvette, 2005 - 2013 > C6 Corvette General Discussion
Sign in using an external account
Register Forgot Password?
Register Search Today's Posts Mark Forums Read FAQ Vendor Directory
Search
C6 Corvette General Discussion
General C6 Corvette Discussion not covered in Tech Sponsored by
PFYC

Welcome to Corvetteforum.com!
Welcome to Corvetteforum.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Corvetteforum.com today!


Corvette Store
 
 
C7 Parts & Accessories
C6 Parts & Accessories
C5 Parts & Accessories
C4 Parts & Accessories
C3 Parts & Accessories
C2 Parts & Accessories
C1 Parts & Accessories
Wheels & Tires
Sponsored Ads
 
 
Vendor Directory
  
Reply
 
 
 
 
Thread Tools Search this Thread
Old 11-23-2007, 02:50 PM   #1
dbdave
CF Senior Member
 
Member Since: Jul 2000
Default Rear Hatch Release Button Not Working

The rear hatch on my '05 coupe will not unlock using the button above the license plate. The button on the dash and the one on the fob both will open it. This started intermittently and I thought it was the fob not being close enough to the car or having a weak battery so I tried the other fob and it wouldn't allow the button to work either. Now the button will not work at all. I have no other fob related issues so I don't suspect weak batteries in either fob. The car is now in storage for the winter so I'm not going to do anything with it until spring.

In the meantime, I found that there is a TSB on this problem. It's called REAR HATCH RELEASE BUTTON OPERATION 05-08-66-002 3/21/05 BODY.

Does anyone have a way to give me a hint as to what is contained in this TSB so I may have a chance of fixing it myself? Looks like one other CF poster a while ago indicated the button sticks and he lubricated it but I don't know from reading the post if it did any good or how he did it.

Any thoughts?
dbdave is offline   Reply With Quote
Old 11-23-2007, 03:01 PM   #2
Sherman Fretwell
CF Senior Member
 
Sherman Fretwell's Avatar
 
Member Since: Nov 2007
Location: Eagle ID
Default

Try visiting here: http://www.edmunds.com/maintenance/r...artner=edmunds
Sherman Fretwell is offline   Reply With Quote
Old 11-23-2007, 03:06 PM   #3
Brett Hunter
CF Senior Member
 
Brett Hunter's Avatar
 
Member Since: Sep 2004
Location: Livingston Texas
Default

I fixed mine myself and then when it was in for an unrelated warranty issue I had them order a new switch and I replaced it. The new switch is supposed to be sealed better but I could not see a difference looking at them. The only reason I had them order one was that it is still under warranty.

The switch is very easy to remove and clean. You simply remove the inside passenger side taillight. Then reach in and unplug the switch. To completely remove it there are clips on the side that when depressed will allow the switch to be removed from the bottom. Once you have it removed simply pry the rubber boot from the bottom of the switch and remove any dirt from the boot and inside the switch. Normally this is all that is required to fix it.

I believe there is a post on here, possibly in the archives that shows pictures of this process.
__________________

Arctic White/Cashmere Z51 MZ6, Supermaxx Headers, Team ZR1 Tune,Team ZR1 Water Meth Injection
Brett Hunter is offline   Reply With Quote
Old 11-23-2007, 03:18 PM   #4
Brett Hunter
CF Senior Member
 
Brett Hunter's Avatar
 
Member Since: Sep 2004
Location: Livingston Texas
Default

I found the thread that had the pictures but they are no longer there. At least it has another write up on the removal.

http://http://forums.corvetteforum.c...00&forum_id=74

and another

http://forums.corvetteforum.com/show...ghlight=switch
Brett Hunter is offline   Reply With Quote
Old 11-23-2007, 03:47 PM   #5
anothercrisis
CF Senior Member
St. Jude Donor '06-'07-'08
 
anothercrisis's Avatar
 
Member Since: Nov 2004
Default

Quote:
Originally Posted by dbdave View Post
The rear hatch on my '05 coupe will not unlock using the button above the license plate. The button on the dash and the one on the fob both will open it. This started intermittently and I thought it was the fob not being close enough to the car or having a weak battery so I tried the other fob and it wouldn't allow the button to work either. Now the button will not work at all. I have no other fob related issues so I don't suspect weak batteries in either fob. The car is now in storage for the winter so I'm not going to do anything with it until spring.

In the meantime, I found that there is a TSB on this problem. It's called REAR HATCH RELEASE BUTTON OPERATION 05-08-66-002 3/21/05 BODY.

Does anyone have a way to give me a hint as to what is contained in this TSB so I may have a chance of fixing it myself? Looks like one other CF poster a while ago indicated the button sticks and he lubricated it but I don't know from reading the post if it did any good or how he did it.

Any thoughts?


Go in through one of the innermost tail lights. Reach in and disconnect the wiring and then the switch. As I recall it is a squeeze mechanism. I actually bought a replacement first so I could see what the mechanism looked like. I then put the new switch in. After this, I took the old one apart and cleaned it. The problem with the original is that grit gets in the the mechanism allowing the push button to stick in its innermost position. I think Pipedreams also had a thread on this repair, but I cannot find it. This is a simple fix if you are mechanical at all.


Good luck
anothercrisis
anothercrisis is offline   Reply With Quote
Old 11-23-2007, 11:08 PM   #6
dbdave
CF Senior Member
 
Member Since: Jul 2000
Default

Thanks Brett and crisis (and Pipedreams).

I'll do this right away since it's simple enough.

dbdave is offline   Reply With Quote
Old 11-24-2007, 02:22 AM   #7
*FAÇADE*
CF Senior Member
St. Jude Donor '07-'08-'09-'10-'11-'12-'13-'14
Support Corvetteforum!
 
*FAÇADE*'s Avatar
 
Member Since: Aug 2007
Default

Quote:
Originally Posted by dbdave View Post
The rear hatch on my '05 coupe will not unlock using the button above the license plate. The button on the dash and the one on the fob both will open it. This started intermittently and I thought it was the fob not being close enough to the car or having a weak battery so I tried the other fob and it wouldn't allow the button to work either. Now the button will not work at all. I have no other fob related issues so I don't suspect weak batteries in either fob. The car is now in storage for the winter so I'm not going to do anything with it until spring.

In the meantime, I found that there is a TSB on this problem. It's called REAR HATCH RELEASE BUTTON OPERATION 05-08-66-002 3/21/05 BODY.
Does anyone have a way to give me a hint as to what is contained in this TSB so I may have a chance of fixing it myself? Looks like one other CF poster a while ago indicated the button sticks and he lubricated it but I don't know from reading the post if it did any good or how he did it.

Any thoughts?

*FAÇADE* is offline   Reply With Quote
Old 11-18-2013, 12:01 AM   #8
b_mouzakis
Junior Member
 
Member Since: Sep 2013
Default

Quote:
Originally Posted by dbdave View Post
The rear hatch on my '05 coupe will not unlock using the button above the license plate. The button on the dash and the one on the fob both will open it. This started intermittently and I thought it was the fob not being close enough to the car or having a weak battery so I tried the other fob and it wouldn't allow the button to work either. Now the button will not work at all. I have no other fob related issues so I don't suspect weak batteries in either fob. The car is now in storage for the winter so I'm not going to do anything with it until spring.

In the meantime, I found that there is a TSB on this problem. It's called REAR HATCH RELEASE BUTTON OPERATION 05-08-66-002 3/21/05 BODY.

Does anyone have a way to give me a hint as to what is contained in this TSB so I may have a chance of fixing it myself? Looks like one other CF poster a while ago indicated the button sticks and he lubricated it but I don't know from reading the post if it did any good or how he did it.

Any thoughts?
I'm not sure what is on the TSB. I recently had the same problem and fixed the problem rather quickly. Looking at the back of vehicle I removed the right side (inside) tail light assembly there is a screw just above the tail lamp. Reached into the taillight hole with my arm and disconnected the electrical connector on the back of the switch. Afterwards I pushed the switch keepers (Small tabs on outside switch body towards the front of switch) to allow the switch to push through. Once out I removed the rubber dust cover over the top of the switch and using a piece of tape I pulled the push button itself out of the switch body. I found lots of real fine sand that has jammed up the works in the switch. I cleaned the switch & associated parts. Reassembled and re-installed the switch back in the car. Switch works great. Repair took less then 30 minutes from start to finish.
Good luck!
Bill
b_mouzakis is offline   Reply With Quote
Old 11-18-2013, 06:20 AM   #9
Knob Jockey
CF Senior Member
St. Jude Donor '11-'12-'13-'14
Support Corvetteforum!
 
Knob Jockey's Avatar
 
Member Since: Oct 2007
Location: Edgewood Washington
Default

Here's an excellent DIY for cleaning this switch.

Try this before spending a bunch of money for new parts/dealer work.

http://forums.corvetteforum.com/c6-c...-pictures.html
Knob Jockey is offline   Reply With Quote
Old 11-18-2013, 06:20 AM
 
Go Back   Corvette Forum > C6 Corvette, 2005 - 2013 > C6 Corvette General Discussion
Reload this Page Rear Hatch Release Button Not Working
 
 
 
Reply

Tags
button, corvette, hatch, rear, release, stopped, unlock, working


Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hatch opening when walking by Seth05 C6 Corvette General Discussion 7 08-03-2014 12:21 PM
Hatch Button kliph C6 Corvette General Discussion 6 06-26-2014 09:51 AM
key fob issue Vette 89 C5 Tech 5 11-10-2013 09:56 AM
FOB battery Issue or ??????? Sunset Orng 05 C6 Corvette General Discussion 3 10-03-2013 01:32 PM
2008 C6 Key Fob and Door Lock Problem blueacre C6 Tech/Performance 8 11-26-2012 01:26 PM


All times are GMT -4. The time now is 06:53 PM.


Emails & Password Backup