Go Back   Corvette Forum > C6 Corvette, 2005 - 2013 > C6 Corvette General Discussion
Sign in using an external account
Register Forgot Password?
Register Search Today's Posts Mark Forums Read FAQ Vendor Directory
Search
C6 Corvette General Discussion
General C6 Corvette Discussion not covered in Tech Sponsored by
PFYC

Welcome to Corvetteforum.com!
Welcome to Corvetteforum.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Corvetteforum.com today!


Corvette Store
 
 
C7 Parts & Accessories
C6 Parts & Accessories
C5 Parts & Accessories
C4 Parts & Accessories
C3 Parts & Accessories
C2 Parts & Accessories
C1 Parts & Accessories
Wheels & Tires
Sponsored Ads
 
 
Vendor Directory
  
Reply
 
 
 
 
Thread Tools Search this Thread
Old 01-05-2011, 08:40 PM   #1
nunii
CF Senior Member
 
Member Since: Aug 2009
Location: brooklyn ny
Default Power seats and telescopic stopped working please help

Like the topic said I took the car to get washed when I got it back they stopped working ! I think I tried everything checked all fuses including the ones in the sub box checked connections under seat, tried soft reset ,unhooked the battery for 2 hours !!! Please anybody with ideas respond I have an appointment tomorrow at the dealership I'd rather not go ......one more thing when I press the switches I hear a click I guess that's the relay I'm stumped ..thanks
nunii is offline   Reply With Quote
Old 01-05-2011, 08:58 PM   #2
brooklync5
CF Senior Member
 
brooklync5's Avatar
 
Member Since: Dec 2008
Location: brooklyn ny
Monster1234
Send a message via AIM to brooklync5
Default

Quote:
Originally Posted by nunii View Post
Like the topic said I took the car to get washed when I got it back they stopped working ! I think I tried everything checked all fuses including the ones in the sub box checked connections under seat, tried soft reset ,unhooked the battery for 2 hours !!! Please anybody with ideas respond I have an appointment tomorrow at the dealership I'd rather not go ......one more thing when I press the switches I hear a click I guess that's the relay I'm stumped ..thanks

really strange problem. nunii is my cousin. weve tried everything including testing every fuse in the car and unplugging the harness under the seat. someone has to have had this problem before. any takers???
brooklync5 is offline   Reply With Quote
Old 01-05-2011, 09:10 PM   #3
EVRose
CF Senior Member
 
EVRose's Avatar
 
Member Since: Oct 2010
Location: Las Vegas NV
Default

Is it both seats that don't work? Maybe check the wire harness under the passenger side. Can't hurt to try. Other than that I have no ideas. Good luck with it.
EVRose is offline   Reply With Quote
Old 01-05-2011, 09:11 PM   #4
brooklync5
CF Senior Member
 
brooklync5's Avatar
 
Member Since: Dec 2008
Location: brooklyn ny
Monster1234
Send a message via AIM to brooklync5
Default

Quote:
Originally Posted by EVRose View Post
Is it both seats that don't work? Maybe check the wire harness under the passenger side. Can't hurt to try. Other than that I have no ideas. Good luck with it.
drivers seat and telescopic stearing only.
brooklync5 is offline   Reply With Quote
Old 01-05-2011, 09:44 PM   #5
gr86ss
CF Senior Member
 
gr86ss's Avatar
 
Member Since: Apr 2007
Location: Central Valley and Bay Area CA
Default

Quote:
Originally Posted by nunii View Post
Like the topic said I took the car to get washed when I got it back they stopped working ! I think I tried everything checked all fuses including the ones in the sub box checked connections under seat, tried soft reset ,unhooked the battery for 2 hours !!! Please anybody with ideas respond I have an appointment tomorrow at the dealership I'd rather not go ......one more thing when I press the switches I hear a click I guess that's the relay I'm stumped ..thanks
Mine happened about six months ago. I found that if I dont put pressure on the drivers seat that they work. If I giggle the harness under the seat, they work. I was going to pull the seat over the holidays and look further but the HUD replacement and wide booty conversion took longer than expected . I have the seat and wheel where I want them so it hasn't been a big priority.
gr86ss is offline   Reply With Quote
Old 01-05-2011, 10:03 PM   #6
nunii
CF Senior Member
 
Member Since: Aug 2009
Location: brooklyn ny
Default

Yep tried wiggling it too no go
nunii is offline   Reply With Quote
Old 09-13-2011, 03:08 PM   #7
gr86ss
CF Senior Member
 
gr86ss's Avatar
 
Member Since: Apr 2007
Location: Central Valley and Bay Area CA
Default

I fixed my telescopic and dirver side power seat. I found that two wires under the seat sheared off. Most likely from the seat being so low and me getting in and out of the car, causing the wire to eventually break. You can only bend a wire back and forth so many times before the copper yields and brakes.

re-attached the wires to the connector and everything works as before!

Click the image to open in full size.
Click the image to open in full size.
gr86ss is offline   Reply With Quote
Old 09-21-2011, 06:15 PM   #8
I hate user names
CF Member
 
Member Since: Sep 2009
Location: Twin Cities MN
Default

I have this exact same issue! Did you uncover the problem?
I hate user names is offline   Reply With Quote
Old 09-21-2011, 06:22 PM   #9
gr86ss
CF Senior Member
 
gr86ss's Avatar
 
Member Since: Apr 2007
Location: Central Valley and Bay Area CA
Default

Yes, it you re-read my post, you will see that the center connector got separated from the wires. I re-attached the wire to the connector and plugged in the connector..
gr86ss is offline   Reply With Quote
Old 09-23-2011, 11:28 AM   #10
Chevy Cust Svc
CF Senior Member
 
Chevy Cust Svc's Avatar
 
Member Since: Mar 2010
Default

I hate user names – were you able to fix what’s going on with your Corvette? Please send me a PM if you’re still having issues.

Thanks,
Laura
GM Customer Service
Chevy Cust Svc is online now   Reply With Quote
Old 09-23-2011, 11:28 AM
 
Go Back   Corvette Forum > C6 Corvette, 2005 - 2013 > C6 Corvette General Discussion
Reload this Page Power seats and telescopic stopped working please help
 
 
 
Reply

Tags
c6, corvette, dont, power, powr, problems, sear, seat, steering, stopped, telescopic, telescoping, wheel, work, working


Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
driver side power seat stopped working '05 terrymccoyc6 C6 Tech/Performance 9 02-28-2014 10:31 PM
Power seat moves a few inches...stops kthomas C6 Corvette General Discussion 3 04-12-2013 09:33 PM
Power Seats Stopped working radd2983 C5 Tech 3 02-21-2012 05:32 PM
Power Seat 1982 Stopped Working SFL82VETTE C3 Tech/Performance 7 10-21-2008 10:00 PM
Power seats stopped working and circuit breaker HOT josephf31 C4 Tech/Performance 4 07-22-2008 11:10 PM


All times are GMT -4. The time now is 11:39 AM.


Emails & Password Backup