Go Back   Corvette Forum > C6 Corvette, 2005 - 2013 > C6 Corvette General Discussion
Sign in using an external account
Register Forgot Password?
Register Search Today's Posts Mark Forums Read FAQ Vendor Directory
Search
C6 Corvette General Discussion
General C6 Corvette Discussion not covered in Tech Sponsored by
PFYC

Reply
 
 
 
 
Thread Tools Search this Thread
Old 03-05-2011, 03:45 AM   #1
JiMmY912
CF Senior Member
 
JiMmY912's Avatar
 
Member Since: Jun 2007
Location: Downtown LA S.California
Default C6 battery life

My 3 and half year old 08 a6 with 37k miles wouldn't start last Saturday morning, so I had to jump start from my brother's 08. It was ok untill today but it wouldn't start again at the gas station so I had to jump start. Battery voltage was 13.8~14.2 during this week. Is it time for a new battery or it might be another problem? I don't think there was any cause of battery drain.

Last edited by JiMmY912; 03-05-2011 at 03:49 AM.
JiMmY912 is offline   Reply With Quote
Old 03-05-2011, 04:48 AM   #2
keyplyr
CF Senior Member
 
keyplyr's Avatar
 
Member Since: Jun 2007
Default

Good luck getting it squared away




keyplyr is offline   Reply With Quote
Old 03-05-2011, 05:14 AM   #3
Ketchum
CF Senior Member
 
Ketchum's Avatar
 
Member Since: Dec 2010
Location: Danielsville Georgia
Default

Sounds like battery. It needs a very slow 2amp charge overnight and then a simple draw test.That will tell you in a few moments if its a battery issue.
Ketchum is offline   Reply With Quote
Old 03-05-2011, 06:20 AM   #4
nch209
CF Senior Member
 
nch209's Avatar
 
Member Since: Oct 2004
Location: Chantilly VA
Default

Sounds like a new battery will fix ya up. Should be able to get a stocker for under $95, or try your hand in the numerous other makes... Good Luck
nch209 is offline   Reply With Quote
Old 03-05-2011, 09:30 AM   #5
spinalator
CF Senior Member
 
spinalator's Avatar
 
Member Since: Mar 2008
Location: Hollywood FL
Send a message via AIM to spinalator
Default

I have an 07 and I'm on my 3rd battery...
spinalator is offline   Reply With Quote
Old 03-05-2011, 09:35 AM   #6
Ketchum
CF Senior Member
 
Ketchum's Avatar
 
Member Since: Dec 2010
Location: Danielsville Georgia
Default

06 and my third. Just had a FLASH done addressing battery going dead issue. It applies to 06 and maybe some 07s. Its listed as 're flash BCM for battery rundown" Had it done Thursday.Time will tell. My battery in 30 to 40 degree weather would go totally dead in 10 days.
Ketchum is offline   Reply With Quote
Old 03-05-2011, 09:39 AM   #7
johnodrake
Moderator
Support Corvetteforum!
 
johnodrake's Avatar
 
Member Since: Dec 2002
Location: Stokesdale NC
Johnodrake @CdrDrake johnodrake
Default

Quote:
Originally Posted by spinalator View Post
I have an 07 and I'm on my 3rd battery...
I have an 06 and the original battery. Go figure.
__________________

Vita contin git. Vive com eo!

60th Anniversary 427 CE - Bone Stock.

MSM '06 415ci LS3 510rwhp, RPS, DeWitts, Pfadt Coilovers, MGW. Full 2012 GS body and interior conversion C6Z Exhaust
Leather by DSV Powdercoating by Mike

DD 05 Silverado Z71
Spring Mountain x5
Gone now but not forgotten:
'89 Coupe Z51, FX3, MN6
Sebring Silver '97 LPE SC
Mille Miglia Red '73 L82 Coupe
Daytona Yellow '70 L46 Coupe
johnodrake is offline   Reply With Quote
Old 03-05-2011, 10:00 AM   #8
NYC6
CF Senior Member
 
NYC6's Avatar
 
Member Since: Nov 2006
Location: Long Island New York
Default

OEM battery lives are all over the place. My 06 is still on the same one it was born with. Cold NY winters, never had a charger on it, weekend car that sits for weeks at a time(winter) in an unheated garage and has a 750w aftermarket audio system that taxes the battery every time I use the car. the engine lights off everytime I hit start. I wish GM will finally figure out this DBS issue.
NYC6 is online now   Reply With Quote
Old 03-05-2011, 10:01 AM   #9
Marc V.
CF Senior Member
 
Marc V.'s Avatar
 
Member Since: Aug 2007
Location: Glassboro New Jersey
Default

Sounds like a bad battery. Just driving is not enough to properly recharge a deeply discharged battery.

I have 17K miles on my 07. It sits for months at a time in the winter. Never used a battery tender and never had any problems after 4 years.
Just lucky I guess.
Marc V. is offline   Reply With Quote
Old 03-05-2011, 10:20 AM   #10
RICH 28
CF Senior Member
 
RICH 28's Avatar
 
Member Since: Oct 2005
Location: Orlando Florida
Default

I'm still on my original battery in my 05. Lucky here too.
RICH 28 is online now   Reply With Quote
Old 03-05-2011, 10:32 AM   #11
z51vett
CF Senior Member
 
z51vett's Avatar
 
Member Since: Feb 2002
Location: cumming ga
Send a message via AIM to z51vett
Default

Quote:
Originally Posted by JiMmY912 View Post
My 3 and half year old 08 a6 with 37k miles wouldn't start last Saturday morning, so I had to jump start from my brother's 08. It was ok untill today but it wouldn't start again at the gas station so I had to jump start. Battery voltage was 13.8~14.2 during this week. Is it time for a new battery or it might be another problem? I don't think there was any cause of battery drain.
Just get a new battery and be done with it its almost 4 years old my camaros and other cars don't last much longer. My Z06 set in Cal from August 08 till I bought it in March 09 Car arrived in Ga in April, had some battery problems this past year so in the fall bought new battery all is well car has gone 6 weeks and starts right up. If you drive it, and park like i do no problems 18,700 miles thats roughly 9500 a year 12 months of driving except in rain or snow and giving rain time to wash snow chemicals off highway.
z51vett
z51vett is online now   Reply With Quote
Old 03-05-2011, 11:54 AM   #12
ghostrunner
CF Senior Member
Support Corvetteforum!
 
ghostrunner's Avatar
 
Member Since: Dec 2007
Location: Joplin MO
Default

My tested bad at 2 1/2 years and was warranteed
ghostrunner is offline   Reply With Quote
Old 03-05-2011, 01:04 PM   #13
2006c6keller
CF Senior Member
 
2006c6keller's Avatar
 
Member Since: Dec 2006
Location: Dalllas/Ft Worth Area TX
Default Also check!

Also check to see that ALL accessories lights are OFF, especially map lights. I use a large tight Oring on the dash light/dimmer switch on the left side, your knee can easily hit this micro switch and turn on, then dead battery. ing.
2006c6keller is offline   Reply With Quote
Old 03-05-2011, 01:15 PM   #14
b4i4getit
CF Senior Member
 
b4i4getit's Avatar
 
Member Since: Oct 2004
Location: Toronto Ontario Canada
Default

Quote:
Originally Posted by johnodrake View Post
I have an 06 and the original battery. Go figure.
My recently traded 2005 coupe had the original battery and it was still going strong.
b4i4getit is online now   Reply With Quote
Old 03-05-2011, 01:21 PM   #15
need-for-speed
CF Senior Member
CI 1-4-5-8-9-10 Vet
St. Jude Donor '03-'05-'07-'09-'10
 
need-for-speed's Avatar
 
Member Since: Feb 2000
Location: Conroe Texas
Default

Agree with the others - it sounds like a battery. I assume you voltage readings are normal whil running so alternator = good.
need-for-speed is offline   Reply With Quote
Old 03-05-2011, 03:03 PM   #16
Max EPR
CF Senior Member
 
Member Since: Mar 2008
Default

The battery in my o8 just failed this week. The car is under three years old. I noticed that the battery is under 600 cold cranking amp raiting. Cheap battery probably due to the size restriction.

I kept it on a battery tender since new any time it sat more than a day.

The shortest life of any battery I have ever owned.
Max EPR is offline   Reply With Quote
Old 03-05-2011, 03:16 PM   #17
Mad*Max
CF Senior Member
 
Mad*Max's Avatar
 
Member Since: Apr 2007
Location: Toronto, Canada
Default

I have an 07 with the original battery - I have drained it a few times requiring a boost so I will probably put in a new one this summer. It can't stay parked for more than a week now or it won't start.
Mad*Max is online now   Reply With Quote
Old 03-05-2011, 03:30 PM   #18
CessnaDriver
CF Senior Member
 
CessnaDriver's Avatar
 
Member Since: Oct 2004
Default

I replaced my 06 with another AC Delco at around 33K, got 4.5 years out of it but I noticed the starter was sounding a little slow so figured it was time.
CessnaDriver is online now   Reply With Quote
Old 03-05-2011, 03:37 PM   #19
Mad*Max
CF Senior Member
 
Mad*Max's Avatar
 
Member Since: Apr 2007
Location: Toronto, Canada
Default

Quote:
Originally Posted by CessnaDriver View Post
I replaced my 06 with another AC Delco at around 33K, got 4.5 years out of it but I noticed the starter was sounding a little slow so figured it was time.
did replacing the battery make it turn quicker?
Mad*Max is online now   Reply With Quote
Old 03-05-2011, 05:28 PM   #20
Rebel 1
CF Senior Member
 
Rebel 1's Avatar
 
Member Since: Apr 2010
Location: the right of the people to keep and bear Arms shall not be infringed
Default

Get a multi-meter and check the volts at the battery posts after the engine has been at rest for at least an hour. Should be at least 12.55 vdc.

If your meter has a milli-amp setting, check for draw. Vettes usually pull around 17 milli-amps at rest, much more than 20 or so is excessive.

Still think like others have said a new battery may be needed.
Rebel 1 is offline   Reply With Quote
Old 03-05-2011, 05:28 PM
 
Go Back   Corvette Forum > C6 Corvette, 2005 - 2013 > C6 Corvette General Discussion
Reload this Page C6 battery life
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Well, it finally happened to me. Dead battery. wombats777 C6 Corvette General Discussion 13 05-25-2012 07:01 PM
Roadside Assistance haljensen C6 Corvette General Discussion 2 03-26-2012 11:05 AM
Help Dead Car DossC6 C6 Corvette General Discussion 22 01-28-2011 12:26 PM
Dead Battery redfrc C6 Tech/Performance 30 11-29-2006 06:38 PM
Battery issues eec8059 C5 General 4 01-27-2005 07:20 PM


Tags
2006, a6, battery, c6, charge, charged, cleaning, corvette, forum, life, posts, problem, problems, staying, vette


Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Corvette Store
 
 
C7 Parts & Accessories
C6 Parts & Accessories
C5 Parts & Accessories
C4 Parts & Accessories
C3 Parts & Accessories
C2 Parts & Accessories
C1 Parts & Accessories
Wheels & Tires
Sponsored Ads
 
 
Vendor Directory
 

All times are GMT -4. The time now is 10:18 PM.


Emails & Password Backup