Drivers side heated seat not working at all. - CorvetteForum - Chevrolet Corvette Forum Discussion

Register FAQ Search Today's Posts Mark Forums Read Vendor Directory

C6 Corvette General Discussion
General C6 Corvette Discussion not covered in Tech Sponsored by
PFYC

Drivers side heated seat not working at all.

Reply
 
 
 
Thread Tools Search this Thread
Old 05-15-2011, 10:57 AM   #1
forg0tmypen
CF Senior Member
Thread Starter
 
forg0tmypen's Avatar
 
Member Since: Mar 2010
Posts: 4,239
Thanks: 0
Thanked 0 Times in 0 Posts
Default Drivers side heated seat not working at all.

I recently had my seats reupholstered to the 3lz dark titanium pattern on my 06 Z06. I now have found that the drivers side heated seat does not function at all. Now lets get the Florida jokes out of the way here: ...................... Back on topic: I have searched, and I checked in the fuse box by the passenger foot well, I pulled all 3 fuses, the 1 relay and the separate passenger and driver fuses in the box off to the right of the main fuses, and I found that everything appeared to be in fine condition, nothing blown. The passenger heated seat is working great. When I press the button for the driver side, nothing happens, the lights do not even attempt to come on. Ive also checked under the seat, Ive unplugged and replugged in all the wiring harnesses and still nothing. I know it was working fine before the seats were redone...any thoughts?? Has anyone experience this issue? Thanks.

EDIT: Ive also tried pushing the button on the drivers side once or twice and felt the seat but it did not appear to warm up. I don't know what reupholstering a seat would break the heater component....frustrating.

EDIT 2: Upon further inspection, it appears the the drivers side and passenger side heated seat fuses are the green 20A kind and the illustration shows there should be only a 15A blue fuse there, don't know if that matters...like I said it was all working before, now its not.

Last edited by forg0tmypen; 05-15-2011 at 11:02 AM.
forg0tmypen is offline   Reply With Quote
Old 05-15-2011, 11:34 AM   #2
JJC5
CF Senior Member
 
JJC5's Avatar
 
Member Since: Apr 2006
Location: Anaheim Hills, Ca
Posts: 4,254
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had the exact same problem with mine. It turned out to be a wire rubbing on part of the seat frame, underneath. It rubbed the insulation off the wire and shorted out.
JJC5 is offline   Reply With Quote
Old 05-15-2011, 05:32 PM   #3
forg0tmypen
CF Senior Member
Thread Starter
 
forg0tmypen's Avatar
 
Member Since: Mar 2010
Posts: 4,239
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I looked under my seat, all wires look fine, I do have a wiring harness not plugged in underneath, I had the seat out of the car last week and could not find where it went....it's white and square shaped.
forg0tmypen is offline   Reply With Quote
Old 05-15-2011, 06:53 PM   #4
crusher1
CF Senior Member
 
crusher1's Avatar
 
Member Since: Jun 2005
Location: Toronto
Posts: 524
Thanks: 0
Thanked 11 Times in 11 Posts
Default

My passenger side did that after the dealership changed my sticking door on the ashtray...Before I bought the car the previous owner went to the dealeship to fix the door for me....About a month later I pushed the button and nothing. So I checked the pushbutton on the console and low and behold the connector in back was disconnected. Those clowns at the dealership must have done it ....Connect it back up and bingo she works like a charm.
crusher1 is offline   Reply With Quote
Old 05-15-2011, 07:51 PM   #5
StanNH
CF Senior Member
 
StanNH's Avatar
 
Member Since: Aug 2004
Location: Whitefield NH
Posts: 5,506
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by forg0tmypen View Post
I looked under my seat, all wires look fine, I do have a wiring harness not plugged in underneath, I had the seat out of the car last week and could not find where it went....it's white and square shaped.
My bet would be the wiring harness. My seat heater stopped working a few years ago on my 2005 and that's exactly what it was.
StanNH is offline   Reply With Quote
Old 05-15-2011, 09:24 PM   #6
forg0tmypen
CF Senior Member
Thread Starter
 
forg0tmypen's Avatar
 
Member Since: Mar 2010
Posts: 4,239
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Like I said I looked under the seat but I'll be damned if there wasn't a spot to plug it into...what's the heated seat harness look like anyways?
forg0tmypen is offline   Reply With Quote
Old 05-15-2011, 10:42 PM   #7
Garret
CF Senior Member
I believe in the Beer Fairy
 
Garret's Avatar
 
Member Since: Jul 2007
Location: Minneapolis MN
Posts: 7,138
Thanked 33 Times in 24 Posts
Default

Take it back to where you had the seats done...why the heck should you try to figure it out if they broke it.
Garret is offline   Reply With Quote
Old 05-16-2011, 08:50 AM   #8
forg0tmypen
CF Senior Member
Thread Starter
 
forg0tmypen's Avatar
 
Member Since: Mar 2010
Posts: 4,239
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Garret View Post
Take it back to where you had the seats done...why the heck should you try to figure it out if they broke it.
I'll look into this today. It's a little more complicated than you think, but I'll explore this option.
forg0tmypen is offline   Reply With Quote
Old 05-16-2011, 06:32 PM   #9
JJC5
CF Senior Member
 
JJC5's Avatar
 
Member Since: Apr 2006
Location: Anaheim Hills, Ca
Posts: 4,254
Thanks: 0
Thanked 0 Times in 0 Posts
Default

There is a flat, white Molex plug that needs to be plugged in under the seat. That's the seat heater wiring.
JJC5 is offline   Reply With Quote
Old 05-17-2011, 11:27 AM   #10
Chevy Cust Svc
CF Senior Member
 
Chevy Cust Svc's Avatar
 
Member Since: Mar 2010
Posts: 14,080
Thanks: 0
Thanked 220 Times in 197 Posts
Default

I would agree with taking it to who did the work on your vehicle. It would seem to me that they missed something when putting the seat back in.

Good luck with your repairs,

Brent
GM Customer Service
Chevy Cust Svc is online now   Reply With Quote
Go Back   CorvetteForum - Chevrolet Corvette Forum Discussion >
Reload this Page
  • Drivers side heated seat not working at all.
  •  
     
    Reply

    Related Topics
    Thread Thread Starter Forum Replies Last Post
    Drivers seat suddenly non responsive! Rogers 07 C6 Corvette General Discussion 22 10-26-2014 09:47 PM
    Bitten by the electrical Gremlin dmarkshark C5 Tech 1 09-28-2014 10:05 AM
    driver side power seat stopped working '05 terrymccoyc6 C6 Tech/Performance 9 02-28-2014 10:31 PM
    heated seat wont heat alicewhails C6 Corvette General Discussion 15 05-22-2010 03:45 PM
    Need help finding fuse for driver door power Z06ster C5 Tech 6 05-04-2007 06:51 PM


    Tags
    2005, 2007, blown, c6, corvette, drivers, fix, fuses, harness, heated, seat, seats, wiring, work, working

    Thread Tools Search this Thread
    Search this Thread:

    Click for Advanced Search

    Posting Rules
    You may not post new threads
    You may not post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are Off
    Pingbacks are Off
    Refbacks are Off

    Forum Jump


    All times are GMT -4. The time now is 01:06 PM.