Go Back   Corvette Forum > C6 Corvette, 2005 - 2013 > C6 Corvette General Discussion
Sign in using an external account
Register Forgot Password?
Register Search Today's Posts Mark Forums Read FAQ Vendor Directory
Search
C6 Corvette General Discussion
General C6 Corvette Discussion not covered in Tech Sponsored by
PFYC

Reply
 
 
 
 
Thread Tools Search this Thread
Old 08-02-2011, 10:58 AM   #1
MDPD23
CF Senior Member
 
MDPD23's Avatar
 
Member Since: Jul 2009
Location: Washington Crossing PA
Default Navigation/Radio Screen goes Blank!

Have a 2008 coupe with factory navigation. I am driving with radio on and the nav/radio sceen goes blank. Radio stays on but all the controls for radio and nav. do not work. Can't even shut the radio off!
Shut the car off, re-started and everything is fine. Drive for another 10 minutes-same thing. Continue driving and it goes back on!!
Any ideas or suggestions what this might be
MDPD23 is offline   Reply With Quote
Old 08-02-2011, 12:14 PM   #2
RicK T
CF Senior Member
 
RicK T's Avatar
 
Member Since: Sep 2005
Location: Las Vegas, Nevada
Default

Sounds like your Nav may have the issue addressed in a TSB. Check this thread, the actual TSB is posted in the thread I linked in post 5:

http://forums.corvetteforum.com/c6-c...av-screen.html
RicK T is offline   Reply With Quote
Old 08-02-2011, 12:28 PM   #3
6spdC6
CF Senior Member
 
6spdC6's Avatar
 
Member Since: Apr 2005
Location: A little town on the shores of the Great Sacandaga Lake in the "Peoples Republic" of upper NY state http://www.visitsacandaga.com/
Default

Quote:
Originally Posted by RicK T View Post
Sounds like your Nav may have the issue addressed in a TSB. Check this thread, the actual TSB is posted in the thread I linked in post 5:

http://forums.corvetteforum.com/c6-c...av-screen.html

Hey Rick not to hijack,

but my car (07 z06) did a funny last week. Radio was off and nav was just showing the local terrain and after driving about 2 miles the cursor started gong a bit crazy and actually showed me driving erratically in the middle of the big lake I was by. This was in my home area and I have driven there a lot with no problems.

Turned off car and restarted and all was ok. No I hit no bumps or anything like that. Possible corrupted disk?
6spdC6 is offline   Reply With Quote
Old 08-02-2011, 12:49 PM   #4
MDPD23
CF Senior Member
 
MDPD23's Avatar
 
Member Since: Jul 2009
Location: Washington Crossing PA
Default

Quote:
Originally Posted by RicK T View Post
Sounds like your Nav may have the issue addressed in a TSB. Check this thread, the actual TSB is posted in the thread I linked in post 5:

http://forums.corvetteforum.com/c6-c...av-screen.html
Thanks Rick! Appreciate the TSB info
MDPD23 is offline   Reply With Quote
Old 01-13-2012, 02:05 PM   #5
Vito.A
CF Senior Member
 
Vito.A's Avatar
 
Member Since: Feb 2004
Location: Tucson AZ
Send a message via AIM to Vito.A
Default

My screen has gone blank also. Thanks for the TSB info.
Now, I just hope the dealer has the audio software update disc.
Vito.A is offline   Reply With Quote
Old 01-13-2012, 03:19 PM   #6
Gearhead Jim
CF Senior Member
St. Jude Donor '13
Support Corvetteforum!
 
Member Since: Sep 2000
Location: Crystal Lake, IL
Default

We had the blank screen sometimes, only after first start in cold weather. Dealer took a couple of days to get the update disc in their shop (they'd lost the original). They did the update about 1 1/2 years ago, no problems since then.
Gearhead Jim is offline   Reply With Quote
Old 01-18-2012, 03:14 PM   #7
Chevy Cust Svc
CF Senior Member
 
Chevy Cust Svc's Avatar
 
Member Since: Mar 2010
Default

Quote:
Originally Posted by Vito.A View Post
My screen has gone blank also. Thanks for the TSB info.
Now, I just hope the dealer has the audio software update disc.
Feel free to keep me posted regarding your progress. If you have any questions or need further assistance, I can be contacted via private message. Thank you.

Tricia, Chevrolet Customer Service.
Chevy Cust Svc is offline   Reply With Quote
Old 01-18-2012, 05:01 PM   #8
dgrant3830
Tech Contributor
Wounded Warrior Escort '11
Support Corvetteforum!
 
dgrant3830's Avatar
 
Member Since: Dec 2006
Location: Van Buren Arkansas
Send a message via AIM to dgrant3830 Send a message via Yahoo to dgrant3830
Default

My '07 has done this just once long ago. No firmware update was available at the time and since its not happened again, I've not gone looking for the update that since came out.
dgrant3830 is offline   Reply With Quote
Old 01-18-2012, 05:17 PM   #9
Gearhead Jim
CF Senior Member
St. Jude Donor '13
Support Corvetteforum!
 
Member Since: Sep 2000
Location: Crystal Lake, IL
Default

Quote:
Originally Posted by 6spdC6 View Post
... but my car (07 z06) did a funny last week. Radio was off and nav was just showing the local terrain and after driving about 2 miles the cursor started gong a bit crazy and actually showed me driving erratically in the middle of the big lake I was by. This was in my home area and I have driven there a lot with no problems.
...
Don't drink and drive!


Seriously, we had a minor version of that happen on our 2006. The cursor slowly drifted away from our actual position over several minutes, then got completely erratic for another few minutes. Returned to normal by itself, and never did it again in the next ~20k miles before we sold the car. Interference with the GPS signal from something outside?
Gearhead Jim is offline   Reply With Quote
Old 01-18-2012, 05:17 PM
 
Go Back   Corvette Forum > C6 Corvette, 2005 - 2013 > C6 Corvette General Discussion
Reload this Page Navigation/Radio Screen goes Blank!
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Radio Trouble mrdi718 C6 Corvette General Discussion 2 07-27-2014 04:51 PM
2007 Radio turns off then back on KibunInc C6 Corvette General Discussion 15 01-19-2012 05:09 PM
Nav Display Blank? TexBlade C6 Corvette General Discussion 23 12-06-2011 03:51 PM
NAV MP3 Static FIX !!!!!!! Finally ! burtonbl103 C6 Corvette General Discussion 411 02-16-2010 04:11 PM
Blank Navigation Screen dave's 09 C6 Corvette General Discussion 11 10-17-2009 12:00 PM


Tags
2005, 2008, black, blank, blnk, c6, car, corvette, google, nav, navigation, radio, screen, stays, works


Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Corvette Store
 
 
C7 Parts & Accessories
C6 Parts & Accessories
C5 Parts & Accessories
C4 Parts & Accessories
C3 Parts & Accessories
C2 Parts & Accessories
C1 Parts & Accessories
Wheels & Tires
Sponsored Ads
 
 
Vendor Directory
 

All times are GMT -4. The time now is 07:34 AM.


Emails & Password Backup