Go Back   Corvette Forum > C6 Corvette, 2005 - 2013 > C6 Corvette General Discussion
Sign in using an external account
Register Forgot Password?
Register Search Today's Posts Mark Forums Read FAQ Vendor Directory
Search
C6 Corvette General Discussion
General C6 Corvette Discussion not covered in Tech Sponsored by
PFYC

Welcome to Corvetteforum.com!
Welcome to Corvetteforum.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Corvetteforum.com today!


Corvette Store
 
 
C7 Parts & Accessories
C6 Parts & Accessories
C5 Parts & Accessories
C4 Parts & Accessories
C3 Parts & Accessories
C2 Parts & Accessories
C1 Parts & Accessories
Wheels & Tires
Sponsored Ads
 
 
Vendor Directory
  
Reply
 
 
 
 
Thread Tools Search this Thread
Old 03-13-2012, 02:55 AM   #1
Big Jay E
CF Senior Member
 
Member Since: Mar 2003
Location: Willow Springs Ca.
Default Theft deterrent system

2010 GS

Tonight on the way home I saw this light on the dash just above the one that shows the headlights are on, and it looked to be a car with a padlock in front. I had actually never seen it before.

It stayed on for the entire 30 minute drive.

I checked my manual and it was for the Theft deterrent system. It said if this light stays on when the engine is running, the car needs service.

Don't really want to do that as it is 120 miles each way to my dealer.

I turned the engine off and restarted it and as soon as it started the light went off. Same three more times tonight.

Has anyone had this light come on and stay on? Did you have to take it to the dealer?
Big Jay E is offline   Reply With Quote
Old 03-13-2012, 08:54 PM   #2
Big Jay E
CF Senior Member
 
Member Since: Mar 2003
Location: Willow Springs Ca.
Default

Didn't do it all day today.
Big Jay E is offline   Reply With Quote
Old 03-13-2012, 09:20 PM   #3
Bill Dearborn
Tech Contributor
 
Bill Dearborn's Avatar
 
Member Since: Oct 1999
Location: Charlotte (formerly Endicott, NY) NC
Default

There are several things that could cause that. If you know somebody local that has a scanner (Tech 2 or equivalent) that can read GM Body codes you might be able to find out what the problem is. Since the light isn't on any code probably has reset. Wait until the next time to see what it is. You may need to keep the engine running so you don't reset the code before the scanner can read it.

Bill
Bill Dearborn is offline   Reply With Quote
Old 03-13-2012, 09:26 PM   #4
RicK T
CF Senior Member
 
RicK T's Avatar
 
Member Since: Sep 2005
Location: Las Vegas, Nevada
Default

There have been a few discussions about that issue. Some were determined to be bad battery related, others were dealer fixes.

Here's one I remembered seeing, just for info for you.

http://forums.corvetteforum.com/c6-c...n-2006-c6.html
RicK T is offline   Reply With Quote
Old 03-13-2012, 09:26 PM
 
Go Back   Corvette Forum > C6 Corvette, 2005 - 2013 > C6 Corvette General Discussion
Reload this Page Theft deterrent system
 
 
 
Reply

Tags
2005, 2012, c6, code, corvette, deterant, deterrent, reset, sercuity, system, theft


Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 07:42 PM.


Emails & Password Backup