Go Back   Corvette Forum > C6 Corvette, 2005 - 2013 > C6 Corvette General Discussion
Sign in using an external account
Register Forgot Password?
Register Search Today's Posts Mark Forums Read FAQ Vendor Directory
Search
C6 Corvette General Discussion
General C6 Corvette Discussion not covered in Tech Sponsored by
PFYC

Welcome to Corvetteforum.com!
Welcome to Corvetteforum.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Corvetteforum.com today!


Corvette Store
 
 
C7 Parts & Accessories
C6 Parts & Accessories
C5 Parts & Accessories
C4 Parts & Accessories
C3 Parts & Accessories
C2 Parts & Accessories
C1 Parts & Accessories
Wheels & Tires
Sponsored Ads
 
 
Vendor Directory
  
Reply
 
 
 
 
Thread Tools Search this Thread
Old 09-10-2012, 03:21 PM   #1
Ammo
CF Senior Member
 
Ammo's Avatar
 
Member Since: Dec 2004
Location: Sammamish WA
Default 2006 Nav Problem

I do not claim to be an expert on the C6 Navigation system but I do like it, use it extensively, and have been a proponent of it.

My extended warranty expired last wed! and this weekend I noticed a problem with my nav screen.

First the screen would go black and state something to the effect that the system no longer sees the system. Then when I remove and replace the disk it works ok. However, after doing this several times I now notice that the arrow marker indicating the direction of the car is off and sits sideways and also moves sideways in relation to the road and car travel.

Anyone experience this problem in the past?

It is an original disk, is it likely to be a failing disk? And is it likely to fail after 5 or 6 years of service? I guess I can find out if this is the problem by borrowing a newer disk?

I did a re-calibration on the system and it did not fix the problem.

Any suggestions?

Thanks

Mike
Ammo is offline   Reply With Quote
Old 09-10-2012, 03:43 PM   #2
johnodrake
Moderator
Support Corvetteforum!
 
johnodrake's Avatar
 
Member Since: Dec 2002
Location: Stokesdale NC
Johnodrake @CdrDrake johnodrake
Default

I'd try a newer disk - just to see. I have never had that experience.
__________________

Vita contin git. Vive com eo!

60th Anniversary 427 CE - Bone Stock.

MSM '06 415ci LS3 510rwhp, RPS, DeWitts, Pfadt Coilovers, MGW. Full 2012 GS body and interior conversion C6Z Exhaust
Leather by DSV Powdercoating by Mike

DD 05 Silverado Z71
Spring Mountain x5
Gone now but not forgotten:
'89 Coupe Z51, FX3, MN6
Sebring Silver '97 LPE SC
Mille Miglia Red '73 L82 Coupe
Daytona Yellow '70 L46 Coupe
johnodrake is offline   Reply With Quote
Old 09-10-2012, 05:48 PM   #3
EVRose
CF Senior Member
 
EVRose's Avatar
 
Member Since: Oct 2010
Location: Las Vegas NV
Default

Whatever you do DO NOT try a 2012 disc. It will screw up your mp3 capabilities.
EVRose is online now   Reply With Quote
Old 09-10-2012, 07:06 PM   #4
Dif
CF Senior Member
Support Corvetteforum!
 
Dif's Avatar
 
Member Since: Mar 2009
Location: Northeast MA & Mad Beach FL
Default

Quote:
Originally Posted by Ammo View Post
I do not claim to be an expert on the C6 Navigation system but I do like it, use it extensively, and have been a proponent of it.

My extended warranty expired last wed! and this weekend I noticed a problem with my nav screen.

First the screen would go black and state something to the effect that the system no longer sees the system. Then when I remove and replace the disk it works ok. However, after doing this several times I now notice that the arrow marker indicating the direction of the car is off and sits sideways and also moves sideways in relation to the road and car travel.

Anyone experience this problem in the past?

It is an original disk, is it likely to be a failing disk? And is it likely to fail after 5 or 6 years of service? I guess I can find out if this is the problem by borrowing a newer disk?

I did a re-calibration on the system and it did not fix the problem.

Any suggestions?

Thanks

Mike
If I understand you correctly the arrow is moving sideways.
Have you tried changing the settings which makes the arrow ( when working normally/correctly ) so it is pointing North all the time.
Just a thought
Dif is offline   Reply With Quote
Old 09-11-2012, 10:30 AM   #5
Ammo
CF Senior Member
 
Ammo's Avatar
 
Member Since: Dec 2004
Location: Sammamish WA
Default

I appreciate your inputs. I am aware of the two different settings: "Always Up" and "Real TIme" as I call them. This did not help. I took the disk out and looked at it closely, it appeared to be smudged and dirty. So I washed it and dryed it and we will see if this is any help.

I do not have MP3, ONSTAR or multiple disk player, my car is a 2006. Again, thanks for the input.
Ammo is offline   Reply With Quote
Old 09-11-2012, 10:59 AM   #6
fdxpilot
CF Senior Member
 
fdxpilot's Avatar
 
Member Since: Jul 2001
Location: Olive Branch MS
Mike Frey
Default

Quote:
Originally Posted by Ammo View Post
I appreciate your inputs. I am aware of the two different settings: "Always Up" and "Real TIme" as I call them. This did not help. I took the disk out and looked at it closely, it appeared to be smudged and dirty. So I washed it and dryed it and we will see if this is any help.

I do not have MP3, ONSTAR or multiple disk player, my car is a 2006. Again, thanks for the input.
Actually, if you have a 2006 with nav, you have an MP3 capable CD player, which is what the previous poster was commenting on. The early nav units implemented the MP3 capability poorly, though, and later units have been updated. Therefore, a 2012 nav disk seems to have problems with the older hardware.

My wifes car is an 06 and we are using 2011 nav discs (2 disc set) in it with no problems.
fdxpilot is offline   Reply With Quote
Old 09-11-2012, 01:18 PM   #7
Ammo
CF Senior Member
 
Ammo's Avatar
 
Member Since: Dec 2004
Location: Sammamish WA
Default

Quote:
Originally Posted by fdxpilot View Post
Actually, if you have a 2006 with nav, you have an MP3 capable CD player, which is what the previous poster was commenting on. The early nav units implemented the MP3 capability poorly, though, and later units have been updated. Therefore, a 2012 nav disk seems to have problems with the older hardware.

My wifes car is an 06 and we are using 2011 nav discs (2 disc set) in it with no problems.
Thanks for that, now I understand.
Ammo is offline   Reply With Quote
Old 09-11-2012, 01:19 PM   #8
brooklync5
CF Senior Member
 
brooklync5's Avatar
 
Member Since: Dec 2008
Location: brooklyn ny
Monster1234
Send a message via AIM to brooklync5
Default

you should pm talon90
brooklync5 is offline   Reply With Quote
Old 09-11-2012, 01:37 PM   #9
LV2TOUR
CF Senior Member
Support Corvetteforum!
 
LV2TOUR's Avatar
 
Member Since: Nov 2009
Location: New Brunswick
Default

Quote:
Originally Posted by fdxpilot View Post
My wifes car is an 06 and we are using 2011 nav discs (2 disc set) in it with no problems.
I have no issues either with the 2011 DVD's
LV2TOUR is offline   Reply With Quote
Old 09-17-2012, 01:12 AM   #10
Ammo
CF Senior Member
 
Ammo's Avatar
 
Member Since: Dec 2004
Location: Sammamish WA
Default

Followup,
I have not had a problem with it since I cleaned it! Worked great today on a 160 mile round trip drive.
Ammo is offline   Reply With Quote
Old 09-17-2012, 01:23 AM   #11
Dif
CF Senior Member
Support Corvetteforum!
 
Dif's Avatar
 
Member Since: Mar 2009
Location: Northeast MA & Mad Beach FL
Default

Quote:
Originally Posted by Ammo View Post
Followup,
I have not had a problem with it since I cleaned it! Worked great today on a 160 mile round trip drive.
Thanks for the update/info, good to know
Dif is offline   Reply With Quote
Old 09-17-2012, 01:23 AM   #12
tunaman
CF Senior Member
Support Corvetteforum!
 
tunaman's Avatar
 
Member Since: Sep 2012
Location: Bay Area Ca
Default

Ours is still working great, so sounds like you fixed it by cleaning up the disc... good job!

Roger
tunaman is offline   Reply With Quote
Old 09-17-2012, 01:23 AM
 
Go Back   Corvette Forum > C6 Corvette, 2005 - 2013 > C6 Corvette General Discussion
Reload this Page 2006 Nav Problem
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Navigation problems slimjimp C6 Corvette General Discussion 1 07-28-2014 11:57 PM
Nav Syatem 2006 rcjays C6 Corvette General Discussion 8 06-07-2014 07:49 PM
WTB updated NAV disk 2009 or newer 95jersey C6 Parts for Sale/Wanted 5 05-14-2013 01:23 PM
6 disk player bucwheat C6 Corvette General Discussion 21 03-17-2013 01:46 PM
C6 nab update .. car turned off now nav won't function M5x72 Audio/Electronics 4 07-24-2012 06:45 PM


All times are GMT -4. The time now is 10:10 AM.


Emails & Password Backup