Go Back   Corvette Forum > C6 Corvette, 2005 - 2013 > C6 Corvette ZR1
Sign in using an external account
Register Forgot Password?
Register Search Today's Posts Mark Forums Read FAQ Vendor Directory
Search
C6 Corvette ZR1
General info about GMs Corvette Supercar, LS9 Corvette Technical Info, Performance Upgrades, Suspension Setup for Street or Track Sponsored by
Bill Stasek

Welcome to Corvetteforum.com!
Welcome to Corvetteforum.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Corvetteforum.com today!


Corvette Store
 
 
C7 Parts & Accessories
C6 Parts & Accessories
C5 Parts & Accessories
C4 Parts & Accessories
C3 Parts & Accessories
C2 Parts & Accessories
C1 Parts & Accessories
Wheels & Tires
Sponsored Ads
 
 
Vendor Directory
  
Reply
 
 
 
 
Thread Tools Search this Thread
Old 07-23-2014, 11:07 AM   #1
Morphin
CF Senior Member
 
Member Since: Apr 2011
Default Dyno numbers, I expected more...

Well I took my car to the dyno and got 645whp 647wtq was really expecting more here is my mod list:

LPE 710 kit
Pulley 2.35
Lingenfelter damper 14%
LPE snout ported to 102mm
Nick Williams 102mm
LS3 ported and polished heads - Intake 387cfm Exhaust 236cfm
Meth injection
Short throw MGW
Cam Comp cams - 227/243 @.050 .614/.624 109 CL
SPEC double disc clutch
Headers 2"
No cats
AEM wideband
NT05R 345/30/19

I really was expecting at least 700whp.


Click the image to open in full size.
Morphin is offline   Reply With Quote
Old 07-23-2014, 11:19 AM   #2
Ballbearingturbo
CF Senior Member
 
Ballbearingturbo's Avatar
 
Member Since: Apr 2013
Default

With those mods you should be around 750 rwhp. What's your psi?
Ballbearingturbo is offline   Reply With Quote
Old 07-23-2014, 01:04 PM   #3
Dave Schotz
CF Senior Member
 
Dave Schotz's Avatar
 
Member Since: Oct 2000
Location: Chandler AZ
David Schotz
Default

Something is off.
Dave Schotz is offline   Reply With Quote
Old 07-23-2014, 01:19 PM   #4
Morphin
CF Senior Member
 
Member Since: Apr 2011
Default

I am at 17psi how can I upload the log of that run? When I try to attach it it says invalid file.
Morphin is offline   Reply With Quote
Old 07-23-2014, 02:25 PM   #5
Mechanical
CF Member
 
Mechanical's Avatar
 
Member Since: Feb 2014
Location: Omaha NE
Default

What kind of dyno was it?
Mechanical is offline   Reply With Quote
Old 07-23-2014, 02:54 PM   #6
Morphin
CF Senior Member
 
Member Since: Apr 2011
Default

Quote:
Originally Posted by Mechanical View Post
What kind of dyno was it?
It is a dynojet.
Morphin is offline   Reply With Quote
Old 07-23-2014, 03:22 PM   #7
ss2z06
CF Senior Member
 
Member Since: Aug 2004
Default

Is the meth working right? How much timing? What fuel are you running?
ss2z06 is offline   Reply With Quote
Old 07-23-2014, 03:26 PM   #8
timmyZ06
CF Senior Member
 
timmyZ06's Avatar
 
Member Since: Jul 2010
Location: montreal quebec
inlinesick
Send a message via Skype™ to timmyZ06
Default

something is deff wrong you should be well over 700whp. 17PSI seems low for that setup, unless cam make and headers specs justify that boost drops.
timmyZ06 is offline   Reply With Quote
Old 07-23-2014, 03:58 PM   #9
Morphin
CF Senior Member
 
Member Since: Apr 2011
Default

Quote:
Originally Posted by ss2z06 View Post
Is the meth working right? How much timing? What fuel are you running?
Meth is working fine, I am on 92oct.

Quote:
Originally Posted by timmyZ06 View Post
something is deff wrong you should be well over 700whp. 17PSI seems low for that setup, unless cam make and headers specs justify that boost drops.
Altitude is 7000ft over here thats why I on ly get 17psi.
Morphin is offline   Reply With Quote
Old 07-23-2014, 04:30 PM   #10
Morphin
CF Senior Member
 
Member Since: Apr 2011
Default

I notice that IAT2 numbers where on the sky, here is a comparison of the IAT2 on the dyno and on the street, same file same everything. How much power could I be loosing because of this?

Click the image to open in full size.
Morphin is offline   Reply With Quote
Old 07-23-2014, 05:18 PM   #11
C5kid@RKT56
Supporting Vendor
 
C5kid@RKT56's Avatar
 
Member Since: Aug 2013
Location: Cental PA
Default

it pulls MAJOR timing when the IAT2 gets that high.

I'd have to look but I think it pulls 8-9* when the IAT2 goes over 130*.
C5kid@RKT56 is offline   Reply With Quote
Old 07-23-2014, 06:01 PM   #12
Morphin
CF Senior Member
 
Member Since: Apr 2011
Default

Quote:
Originally Posted by C5kid@RKT56 View Post
it pulls MAJOR timing when the IAT2 gets that high.

I'd have to look but I think it pulls 8-9* when the IAT2 goes over 130*.
This is the knock retard table on the same run.

Click the image to open in full size.
Morphin is offline   Reply With Quote
Old 07-23-2014, 06:07 PM   #13
ZBADESTZ@Straightline
Premium Supporting Vendor
 
ZBADESTZ@Straightline's Avatar
 
Member Since: Jun 2009
Location: Naperville/Palm Beach IL/FL
Default

Your car pulled 4.5* @ 6,000 rpm...

Check your intercooler fluid.....It shouldn't be 70* above ambient...

Your coolant was at 207*

Do the fan setup like I told you...

you should be in the mid 700's
ZBADESTZ@Straightline is offline   Reply With Quote
Old 07-23-2014, 06:08 PM   #14
ZBADESTZ@Straightline
Premium Supporting Vendor
 
ZBADESTZ@Straightline's Avatar
 
Member Since: Jun 2009
Location: Naperville/Palm Beach IL/FL
Default

Quote:
Originally Posted by Morphin View Post
This is the knock retard table on the same run.

Click the image to open in full size.
That could be false knock when you initially started the run...
ZBADESTZ@Straightline is offline   Reply With Quote
Old 07-23-2014, 09:25 PM   #15
ZBADESTZ@Straightline
Premium Supporting Vendor
 
ZBADESTZ@Straightline's Avatar
 
Member Since: Jun 2009
Location: Naperville/Palm Beach IL/FL
Default

Morphin did that info I gave you on the throttle body help ya?

Also check for belt slip....Your boost is dropping 2 lbs

I would think that pulley setup would push more...I have 14% lower with 2.6 upper at 16lbs
ZBADESTZ@Straightline is offline   Reply With Quote
Old 07-23-2014, 10:30 PM   #16
ace32x
CF Senior Member
 
ace32x's Avatar
 
Member Since: May 2013
Default

your belt is slipping, still not sure why power is so low on your set up. i made 752 whp in 110 degree ambient with similar set up but ported ls9 ehads. back at home with better weather with the same pulley combo im seeing 21.8 lbs (lower to sea level in washington) car got tuned in phoenix
ace32x is offline   Reply With Quote
Old 07-23-2014, 11:10 PM   #17
Morphin
CF Senior Member
 
Member Since: Apr 2011
Default

The shop where I dynoed the car didnt had a BIG fan they only had 2 small ones thats why temperature got that high. I usually dont have issues with IAT2 numbers.
Morphin is offline   Reply With Quote
Old 07-23-2014, 11:14 PM   #18
Morphin
CF Senior Member
 
Member Since: Apr 2011
Default

This are how my IAT2 numbers usually are:


Click the image to open in full size.

I am going to need to take the car to another shop where they have a big fan for dyno runs.
Morphin is offline   Reply With Quote
Old 07-23-2014, 11:14 PM   #19
Morphin
CF Senior Member
 
Member Since: Apr 2011
Default

Quote:
Originally Posted by ace32x View Post
your belt is slipping, still not sure why power is so low on your set up. i made 752 whp in 110 degree ambient with similar set up but ported ls9 ehads. back at home with better weather with the same pulley combo im seeing 21.8 lbs (lower to sea level in washington) car got tuned in phoenix
Yeah it was slipping just fixed it today, belt was installed wrong.
Morphin is offline   Reply With Quote
Old 07-23-2014, 11:32 PM   #20
Ballbearingturbo
CF Senior Member
 
Ballbearingturbo's Avatar
 
Member Since: Apr 2013
Default

Quote:
Originally Posted by Morphin View Post
This are how my IAT2 numbers usually are: I am going to need to take the car to another shop where they have a big fan for dyno runs.
Maybe I overlooked, what heat exchanger do you have?
Ballbearingturbo is offline   Reply With Quote
Old 07-23-2014, 11:32 PM
 
Go Back   Corvette Forum > C6 Corvette, 2005 - 2013 > C6 Corvette ZR1
Reload this Page Dyno numbers, I expected more...
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ported snout and TB vs LPE w/ 102mm bad habit bird C6 Corvette ZR1 7 07-04-2014 08:09 PM
Bolton LS2's with Fast 102mm Intake Manifold & Ported TB, Dyno Numbers thread !! stanklr C6 Tech/Performance 15 12-19-2013 04:08 PM
90mm TB v. 102mm TB on FAST 102 comparo. Mike @ CMS C6 Scan & Tune 21 12-01-2012 10:04 PM
Fast 102 LSXR LPE 630 package puts down larger #'s than the LPE 660 package! bowtiguy C6 Z06 Discussion 32 05-26-2010 07:10 PM
LPE Performance Packages 383_Proof C4 Tech/Performance 5 08-21-2007 09:42 AM



Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 01:06 AM.


Emails & Password Backup