GMLAN error - Corvette Forum

Go Back   Corvette Forum > C6 Corvette, 2005 - 2013 > C6 Scan & Tune
Log In 
Register FAQ Search Today's Posts Mark Forums Read Vendor Directory
Search

C6 Scan & Tune
Onboard Diagnostics, Service Advice, Dyno Tuning, and Fuel Management for the Corvette Sponsored by
CorvetteForum Store

GMLAN error

Reply
 
 
 
Thread Tools Search this Thread
Old 06-04-2008, 12:54 AM   #1
Tag_sk
CF Member
 
Member Since: Dec 2004
Posts: 62
Location: Vacaville California
Thanks: 0
Thanked 0 Times in 0 Posts
Default GMLAN error

I have a 05 Corvette A4, it runs great, but I have a problem using a data logging tool or code reader- unable to read vehicle information. I took it to a shop that had a snap on scan tool and was able to get 3 codes; P0700 Transmission Control Module Requested MIL illumination, U2100 Controller Area Network Bus Communication, and U2105 Lost Communication with Engine Control Module. Codes where cleared and later that day I was able to log some data, but the next day I tried again and was unable to get vehicle information again. I noticed when the shop's scan tool was connected and then disconnected the driver information center on the dash alternated between Service Active Handling System & Service Traction Control System, but after a restart they did not appear again. What do I need to do to fix this?
Tag_sk is offline   Reply With Quote
Old 06-04-2008, 08:18 AM   #2
patton
CF Senior Member
St. Jude Donor '09
 
patton's Avatar
 
Member Since: Jun 2004
Posts: 2,336
Location: trenton nj
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Tag_sk View Post
I have a 05 Corvette A4, it runs great, but I have a problem using a data logging tool or code reader- unable to read vehicle information. I took it to a shop that had a snap on scan tool and was able to get 3 codes; P0700 Transmission Control Module Requested MIL illumination, U2100 Controller Area Network Bus Communication, and U2105 Lost Communication with Engine Control Module. Codes where cleared and later that day I was able to log some data, but the next day I tried again and was unable to get vehicle information again. I noticed when the shop's scan tool was connected and then disconnected the driver information center on the dash alternated between Service Active Handling System & Service Traction Control System, but after a restart they did not appear again. What do I need to do to fix this?
are your scanners/tools CAN able ? i use a snapon mgt 2500 on my 07 z and do not get those messages when hooked up. have you had a CEL ?
patton is offline   Reply With Quote
Go Back   Corvette Forum > C6 Corvette, 2005 - 2013 > C6 Scan & Tune
Reload this Page GMLAN error
 
 
Reply


Similar Threads
Thread Thread Starter Forum Replies Last Post
The electrical issues of my 1998 convertible Munckhof C5 Tech 7 06-20-2015 06:53 PM
98 C5 coupe extensive electrical issues LSGUN C5 Tech 18 06-15-2015 06:23 PM
C5 Computer Diagnostic Codes Todd157k C5 Tech 13 08-19-2014 12:14 PM
DTC -0442 Diagnostic Lesson Learned Bill Curlee C5 Tech 4 08-03-2012 01:12 PM
List of Diagnostic codes - Just wanted to share zleehw C5 Tech 33 09-22-2009 09:26 PM


Tags
06, corvette, driver, fix, gmlan, illumination, info, mil, p0700, problem, requested, u2100, u2105

Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


 

All times are GMT -4. The time now is 12:51 AM.