Go Back   Corvette Forum > C6 Corvette, 2005 - 2013 > C6 Tech/Performance
Sign in using an external account
Register Forgot Password?
Register Search Today's Posts Mark Forums Read FAQ Vendor Directory
Search
C6 Tech/Performance
LS2, LS3, LS7, LS9 Corvette Technical Info, Internal Engine, External Engine, Tech Topics, Basic Tech, Maintenance, How to Remove & Replace Sponsored by
21st Century Muscle Cars

Welcome to Corvetteforum.com!
Welcome to Corvetteforum.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Corvetteforum.com today!


Corvette Store
 
 
C7 Parts & Accessories
C6 Parts & Accessories
C5 Parts & Accessories
C4 Parts & Accessories
C3 Parts & Accessories
C2 Parts & Accessories
C1 Parts & Accessories
Wheels & Tires
Sponsored Ads
 
 
Vendor Directory
  
Reply
 
 
 
 
Thread Tools Search this Thread
Old 08-26-2008, 02:59 PM   #1
Modshack
CF Senior Member
 
Modshack's Avatar
 
Member Since: Feb 2007
Location: Greenville NC
Default AEM Wideband install...

Followed C6Antwon's lead on this one...Now to break out HP tuners and do a little tweaking on my Spinmonster tune...

Click the image to open in full size.

Click the image to open in full size.

Click the image to open in full size.

Click the image to open in full size.
__________________
Steve
'14 Blade Silver/Red
Cyber Gray stripes, 2LT, A6, NPP, Z51 suspension

Last edited by Modshack; 08-26-2008 at 03:02 PM.
Modshack is offline   Reply With Quote
Old 08-26-2008, 04:01 PM   #2
6Speeder
CF Senior Member
 
6Speeder's Avatar
 
Member Since: May 2000
Location: Albuquerque NM
Default

Looks good. Where did you run the wires through the firewall?
__________________
Porsches for breakfast
Ferraris for lunch
6Speeder is offline   Reply With Quote
Old 08-26-2008, 04:12 PM   #3
Modshack
CF Senior Member
 
Modshack's Avatar
 
Member Since: Feb 2007
Location: Greenville NC
Default

Quote:
Originally Posted by 6Speeder View Post
Looks good. Where did you run the wires through the firewall?
I actually scratched my head on this a bit, and ended up running them around the front edge of the Tunnel plate and up through the shifter opening. Dremeled a small notch in the front corner of the raised lip around the shifter hole so the rubber plate would seal again when re-installed, ran wires down the side of the console and turned left to go across the dash to the gauge.. Power ground leads were run across to under dash area and through the console to the footwell fusebox for power and ground..Not too bad actually..

You can see the O2 wires making the turn at the tunnel plate here:

Click the image to open in full size.

Click the image to open in full size.
Modshack is offline   Reply With Quote
Old 08-26-2008, 04:18 PM   #4
ZPirate
CF Senior Member
 
ZPirate's Avatar
 
Member Since: Jan 2007
Location: Greenville, NC
Default

Looks good Steve. I'm glad to see you got it all hooked up and buttoned up. Your interior certainly looks better than when I saw it on Sunday afternoon.

Now you can really see how your car is running.

BTW the dealer had to order a new computer for my truck. The PCM apparently went off the deep end.

Last edited by ZPirate; 08-26-2008 at 04:22 PM.
ZPirate is offline   Reply With Quote
Old 08-26-2008, 04:21 PM   #5
Modshack
CF Senior Member
 
Modshack's Avatar
 
Member Since: Feb 2007
Location: Greenville NC
Default

Quote:
Originally Posted by ZPirate View Post
Looks good Steve. I'm glad to see you got it all hooked up and buttoned up. Your interior certainly looks better than when I saw it on Sunday afternoon.

.
...Yeah, it was in MANY pieces!
Modshack is offline   Reply With Quote
Old 08-26-2008, 04:21 PM
 
Go Back   Corvette Forum > C6 Corvette, 2005 - 2013 > C6 Tech/Performance
Reload this Page AEM Wideband install...
 
 
 
Reply

Tags
aem, band, c5, c6, corvette, forum, gauge, harness, install, installing, location, wide, wideband, wire, z06


Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 03:41 PM.


Emails & Password Backup