Go Back   Corvette Forum > C6 Corvette, 2005 - 2013 > C6 Tech/Performance
Sign in using an external account
Register Forgot Password?
Register Search Today's Posts Mark Forums Read FAQ Vendor Directory
Search
C6 Tech/Performance
LS2, LS3, LS7, LS9 Corvette Technical Info, Internal Engine, External Engine, Tech Topics, Basic Tech, Maintenance, How to Remove & Replace Sponsored by
21st Century Muscle Cars

Welcome to Corvetteforum.com!
Welcome to Corvetteforum.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Corvetteforum.com today!


Corvette Store
 
 
C7 Parts & Accessories
C6 Parts & Accessories
C5 Parts & Accessories
C4 Parts & Accessories
C3 Parts & Accessories
C2 Parts & Accessories
C1 Parts & Accessories
Wheels & Tires
Sponsored Ads
 
 
Vendor Directory
  
Reply
 
 
 
 
Thread Tools Search this Thread
Old 03-17-2010, 03:16 AM   #1
Epic_C6
CF Senior Member
 
Epic_C6's Avatar
 
Member Since: Mar 2010
Default Buzzing sound coming from speakers when radio on or off?!?! HELP!?

I have a 2008 C6 Coupe with Navigation and recently it has randomly started to make a whining/buzzing noise that gets louder the higher the RPM of the engine? I have tried to turn the radio off, turn the volume down, and change the source without anything working. It is very loud and noticable while sitting still or driving. I have noticed that some of time if I go over a bump it stops for a little bit. Eventually after a few annoying minutes it will go away. I haven't taken it to the local chevy dealership even though it is under warranty because it is an intermittent problem that I can not recreate. Has anyone ever had this sort of problem?
Epic_C6 is offline   Reply With Quote
Old 03-17-2010, 07:56 AM   #2
65GGvert
CF Senior Member
 
65GGvert's Avatar
 
Member Since: Jul 2006
Location: Kannapolis NC
Send a message via AIM to 65GGvert
Default

Check to see if you're hearing the small fan that pulls in cabin air to monitor temperature for climate control. It's to the right of the steering wheel down low just to left of climate/radio controls. If so, it can be changed easily and not very expensive. I've seen posts here where the owner just disconnected it. Maybe try a search for how to.
65GGvert is offline   Reply With Quote
Old 03-17-2010, 09:04 AM   #3
Isaiah48
CF Senior Member
 
Isaiah48's Avatar
 
Member Since: Oct 2005
Location: Stafford Virginia
Default

A lot of times when you start picking up rpm whine like that, you have a ground problem. I would think that if it was the Fan it would have a whine that would change pitch with the fan motor speed rather rpm's, but I'm no expert...
__________________

05' Z51 M6 - 1 7/8" Kooks, No Cats, X Pipe, GHL Bullets, Vararam, Milled .030 Stage III 243 Heads, FAST 102mm & Ported 90mm Throttle body, Trak Cam 231/234 .640/.590 112 LSA, 48# Injectors, RPM Z06 Level V Trans, MGW Shifter, RPM Stage III Rear w/3:90's, ATI 25% Under drive pulley, McLeod RXT
Dyno'd @ 467 rwhp, 417 rwtq (Pre FAST & UD Pulley)
Best Run 11.03 @ 126 mph with a 1.60 60'
Isaiah48 is offline   Reply With Quote
Old 03-17-2010, 09:16 AM   #4
Epic_C6
CF Senior Member
 
Epic_C6's Avatar
 
Member Since: Mar 2010
Default

The whining is definetly coming from the rear speakers. When I start to hear it I try to pull over as soon as I find a safe place so that I can closer identify it but it always stops after a few minutes at the most. It is very loud and it definetly is affected by RPM even when I down shift it gets louder. This is really confusing me. If I could replicate the problem I think it would be much easier to diagnos but so far I have been unable to replicate it.
Epic_C6 is offline   Reply With Quote
Old 03-17-2010, 10:42 AM   #5
lovemyyellowc6
Junior Member
Support Corvetteforum!
 
Member Since: Jan 2010
Location: Greenville SC
Default

I have a 2008 without nav but I have had a similar experience on day while it was raining. There seemed to be a buzzing noise coming from the speakers. It continued after I turned off the car until I opened my door. I have not noticed it again but I can relate to your problem.
lovemyyellowc6 is offline   Reply With Quote
Old 03-17-2010, 05:50 PM   #6
65GGvert
CF Senior Member
 
65GGvert's Avatar
 
Member Since: Jul 2006
Location: Kannapolis NC
Send a message via AIM to 65GGvert
Default

Quote:
Originally Posted by phil_sime View Post
The whining is definetly coming from the rear speakers. When I start to hear it I try to pull over as soon as I find a safe place so that I can closer identify it but it always stops after a few minutes at the most. It is very loud and it definetly is affected by RPM even when I down shift it gets louder. This is really confusing me. If I could replicate the problem I think it would be much easier to diagnos but so far I have been unable to replicate it.
Sorry, you didn't say rear speakers in your original question. I don't have anything for that.
65GGvert is offline   Reply With Quote
Old 03-18-2010, 04:47 PM   #7
Epic_C6
CF Senior Member
 
Epic_C6's Avatar
 
Member Since: Mar 2010
Default

Update - I just spoke with one of my local REPUTABLE Chevy dealers and the service manager said he is almost positive he knows what my problem is and I will be taking it in next week to get it looked at. Once they take a look at it and if they fix it I will let all of you know incase you encounter the same problem or are already are. Check back.
Epic_C6 is offline   Reply With Quote
Old 05-16-2010, 12:06 PM   #8
magnum08
Junior Member
 
magnum08's Avatar
 
Member Since: Jul 2008
Default

My 2008 coupe is doing the exact same "buzzing" thing, but i believe it is coming through all the speakers. Any update on what the cause was for your vette?

Just read another thread by you. No IPOD in mine. I think it's the ground or ignition wires in my vette. Thanks anyway.

Last edited by magnum08; 05-16-2010 at 12:22 PM. Reason: add on
magnum08 is offline   Reply With Quote
Old 05-16-2012, 10:22 PM   #9
scoaman
CF Senior Member
 
Member Since: Oct 2000
Location: Sharon,MA USA
Send a message via AIM to scoaman
Default 2008 vert same issue

Replaced both speakers in passenger door and whine still comes and goes as you hit bumps. Has gotten to the point that I don't drive car much. Any ideas.
scoaman is offline   Reply With Quote
Old 05-16-2012, 11:14 PM   #10
moms 06
Junior Member
Support Corvetteforum!
 
moms 06's Avatar
 
Member Since: Apr 2012
Default

I have the same issue with the speakers in my 06 but of course it won't do it when the dealership is driving it... have you had any luck finding out what the issue is? Seems to only do it with the XM - it whines and the bass sound goes in and out... I thought ground issue on the whine and loose connection on the other but Dealer thinks different... help

Last edited by moms 06; 05-16-2012 at 11:17 PM. Reason: add text
moms 06 is offline   Reply With Quote
Old 05-17-2012, 07:27 AM   #11
Boomer111
CF Senior Member
 
Boomer111's Avatar
 
Member Since: Oct 2005
Location: Bay Area Ca.
Default

You guys sure it is not the front windsheield cowl panel, it buzzes at higher speeds but I do not think it increases with rpm.

Changing with rpm through speakers is an electrical problem, grounding maybe.

Let us know the outcome.
Boomer111 is offline   Reply With Quote
Old 05-17-2012, 07:39 AM   #12
scoaman
CF Senior Member
 
Member Since: Oct 2000
Location: Sharon,MA USA
Send a message via AIM to scoaman
Default not possible

Stops when you turn radio off. Think it's time to trade for a porsche. No one seems to have an answer.
scoaman is offline   Reply With Quote
Old 05-17-2012, 10:30 PM   #13
Boomer111
CF Senior Member
 
Boomer111's Avatar
 
Member Since: Oct 2005
Location: Bay Area Ca.
Default

Keep the radio off and put in a CD.

My radio is rarely on.

Frustrating problem indeed.
Boomer111 is offline   Reply With Quote
Old 05-18-2012, 07:26 AM   #14
scoaman
CF Senior Member
 
Member Since: Oct 2000
Location: Sharon,MA USA
Send a message via AIM to scoaman
Default Doesn't matter

Does it with CD, iPod, AM or FM.
scoaman is offline   Reply With Quote
Old 05-18-2012, 07:26 AM
 
Go Back   Corvette Forum > C6 Corvette, 2005 - 2013 > C6 Tech/Performance
Reload this Page Buzzing sound coming from speakers when radio on or off?!?! HELP!?
 
 
 
Reply

Tags
annoying, buzzing, car, coming, corvette, goldwing, hear, humming, loud, noise, radio, sound, speaker, speakers, tech


Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -4. The time now is 02:26 PM.


Emails & Password Backup