Go Back   Corvette Forum > C7 Corvette > C7 Tech/Performance
Sign in using an external account
Register Forgot Password?
Register Search Today's Posts Mark Forums Read FAQ Vendor Directory
Search
C7 Tech/Performance
Corvette Technical Info, Internal Engine, External Engine, Tech Topics, Basic Tech, Maintenance, How to Remove & Replace Sponsored by
Hennessey Performance

Welcome to Corvetteforum.com!
Welcome to Corvetteforum.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Corvetteforum.com today!


Corvette Store
 
 
C7 Parts & Accessories
C6 Parts & Accessories
C5 Parts & Accessories
C4 Parts & Accessories
C3 Parts & Accessories
C2 Parts & Accessories
C1 Parts & Accessories
Wheels & Tires
Sponsored Ads
 
 
Vendor Directory
  
Reply
 
 
 
 
Thread Tools Search this Thread
Old 12-05-2013, 03:31 PM   #1
Rmd1114
Junior Member
 
Member Since: Dec 2013
Default Problems with my 2014 Corvette Stingray Z51

I picked up my car from Kerbeck 1 month ago. The next day, I tried to start it and it was dead. Had it jump started. Took it into Gearhart and they said everything was fine. Haven't had a problem with the battery since. I also told them of an issue with the mirrors (reverse tilt function.). They couldn't reproduce it. Since then the following issues have occurred with the car, and they were reproducible. Of course, The service dept couldn't reproduce them, except to say that I need 2 new seat switches. I have typically dealt with Porsche and BMW with my autos always with satisfaction. I'm aggravated that these issues cannot be reproduced until I pull the
Car off of the lot. Here are the current problems:



1) When car is started, it does not always start in the default “Touring” mode.

2) When the drive mode selector is turned to the right (from “touring” towards “track&rdquo, the modes sometimes turn the other way (towards “weather&rdquo

3) When “side mirror reverse function”was enabled, the mirrors would sometimes go into the down position, or the would go into an “UP” position, where nrither the road of the car was visible. It is dangerous, because the mirrors then have to be adjusted when the car is in [forward gear

4) When the roof is removed, the gagues get “”dim”, to the point that they are very difficult to see. The same issue occured yesterday (11/24) with the roof on, at night. It has happened in day light as well. When I purchased the car (from Kerbeck) the saleman said that this was going to be fixed, and that I wouldn’t have to worry about it, that it would be downloaded to the computer of the car. It has not been fixed.
5) If I unlock the car with the transmitter, the driver door can be opened, but the passenger door cannot be opened. The driver door must be opened first.

6) I am not certain if the car locks when I move the key away. Please check to see that the locking feature (passive lock I believe) is working properly.

7) The media device setting needs to be rebooted (I have to switch from device to radio, then back to device) and then the cell phone (Itunes) are once again heard.

8) The seat preset setting buttons do not work. If button “1” or “2” is pressed, the seats move a very little bit, Other times, they seem to require two or three pushes.

9) Please check the temperature accuracy on the heating system. If the temp is set at 72 degrees, it feels like 80 +

10) I have disabled the “horn chirp” feature (which chirps when the car is started and I leave the seat) and it still chirps most of the time, but not always.

11) driving last night, the gauges would not change when I switched through all of the modes. The "sport" gauge was the only one seen. I then used the buttons on the steering wheel and selected "link to driving mode" and they worked normally. I had that setting active since
I owned the car, and for some reason, I had to reset it again.

12) out of nowhere, the lap timer came on. I tried to stop it and reset it and couldn't. Also, the traction control deactivation light was on as well

Any insight would be greatly appreciated

Thx
Rmd1114 is offline   Reply With Quote
Old 12-05-2013, 03:39 PM   #2
Rmd1114
Junior Member
 
Member Since: Dec 2013
Default

[QUOTE=Rmd1114;1585601802]I picked up my car from Kerbeck 1 month ago. The next day, I tried to start it and it was dead. Had it jump started. Took it into Gearhart and they said everything was fine. Haven't had a problem with the battery since. I also told them of an issue with the mirrors (reverse tilt function.). They couldn't reproduce it. Since then the following issues have occurred with the car, and they were reproducible. Of course, The service dept couldn't reproduce them, except to say that I need 2 new seat switches. I have typically dealt with Porsche and BMW with my autos always with satisfaction. I'm aggravated that these issues cannot be reproduced until I pull the
Car off of the lot. Here are the current problems:



1) When car is started, it does not always start in the default “Touring” mode.

2) When the drive mode selector is turned to the right (from “touring” towards “track&rdquo, the modes sometimes turn the other way (towards “weather&rdquo

3) When “side mirror reverse function”was enabled, the mirrors would sometimes go into the down position, or the would go into an “UP” position, where nrither the road of the car was visible. It is dangerous, because the mirrors then have to be adjusted when the car is in [forward gear

4) When the roof is removed, the gagues get “”dim”, to the point that they are very difficult to see. The same issue occured yesterday (11/24) with the roof on, at night. It has happened in day light as well. When I purchased the car (from Kerbeck) the saleman said that this was going to be fixed, and that I wouldn’t have to worry about it, that it would be downloaded to the computer of the car. It has not been fixed.
5) If I unlock the car with the transmitter, the driver door can be opened, but the passenger door cannot be opened. The driver door must be opened first.

6) I am not certain if the car locks when I move the key away. Please check to see that the locking feature (passive lock I believe) is working properly.

7) The media device setting needs to be rebooted (I have to switch from device to radio, then back to device) and then the cell phone (Itunes) are once again heard.

8) The seat preset setting buttons do not work. If button “1” or “2” is pressed, the seats move a very little bit, Other times, they seem to require two or three pushes.

9) Please check the temperature accuracy on the heating system. If the temp is set at 72 degrees, it feels like 80 +

10) I have disabled the “horn chirp” feature (which chirps when the car is started and I leave the seat) and it still chirps most of the time, but not always.

11) driving last night, the gauges would not change when I switched through all of the modes. The "sport" gauge was the only one seen. I then used the buttons on the steering wheel and selected "link to driving mode" and they worked normally. I had that setting active since
I owned the car, and for some reason, I had to reset it again.

12) out of nowhere, the lap timer came on. I tried to stop it and reset it and couldn't. Also, the traction control deactivation light was on as well

Any insight would be greatly appreciated

**************Sorry here are corrections from above:


1) When car is started, it does not always start in the default Touring mode.

2) When the drive mode selector is turned to the right (from Touring; towards track), the modes sometimes turn the other way (towards weather / eco)

3) When side mirror reverse function was enabled, the mirrors would sometimes go into the down position, or the would go into an "up" position, where neither the road of the car was visible. It is dangerous, because the mirrors then have to be adjusted when the car is in [forward gear

4) When the roof is removed, the gagues get to the point that they are very difficult to see. The same issue occured yesterday (11/24) with the roof on, at night. It has happened in day light as well. When I purchased the car (from Kerbeck) the saleman said that this was going to be fixed, and that I wouldn't have to worry about it, that it would be downloaded to the computer of the car. It has not been fixed.
5) If I unlock the car with the transmitter, the driver door can be opened, but the passenger door cannot be opened. The driver door must be opened first.
Rmd1114 is offline   Reply With Quote
Old 12-05-2013, 03:52 PM   #3
theseal
CF Senior Member
 
Member Since: Feb 2005
Default

every car has problem children... that's why i contend that a sportscar that is meant to live for 50 years like the vette should have an absolute minimum of electronics, very few modules, and all modules should be in an easily accessible panel instead of crammed up in the dash for a 10 hour replacement job.

why would a freaking corvette want mirror reverse, mode selectors other than - real man all off - and let your mom drive it all on.

why would anyone accept a car that reverted to some unwanted complicated setting every time you start it, rather than the setting you select?

why would you want screens and electronics that will soon be obsolete if they aren't already? if you want a lap timer, or a map, use your iphone or buy a real product.

why would anyone ever want a sports car whose doors lock or unlock without you doing it?

i am sorry you are having these problems, but the fact is none of these devices should be in a corvette. period. ever. and they are why in 50 years you'll see 100 year old vettes, but you won't find a 50 year old one.
theseal is offline   Reply With Quote
Old 12-05-2013, 03:53 PM   #4
Rmd1114
Junior Member
 
Member Since: Dec 2013
Default

[QUOTE=Rmd1114;1585601857]
Quote:
Originally Posted by Rmd1114 View Post
I picked up my car from Kerbeck 1 month ago. The next day, I tried to start it and it was dead. Had it jump started. Took it into Gearhart and they said everything was fine. Haven't had a problem with the battery since. I also told them of an issue with the mirrors (reverse tilt function.). They couldn't reproduce it. Since then the following issues have occurred with the car, and they were reproducible. Of course, The service dept couldn't reproduce them, except to say that I need 2 new seat switches. I have typically dealt with Porsche and BMW with my autos always with satisfaction. I'm aggravated that these issues cannot be reproduced until I pull the
Car off of the lot. Here are the current problems:



1) When car is started, it does not always start in the default “Touring” mode.

2) When the drive mode selector is turned to the right (from “touring” towards “track&rdquo, the modes sometimes turn the other way (towards “weather&rdquo

3) When “side mirror reverse function”was enabled, the mirrors would sometimes go into the down position, or the would go into an “UP” position, where nrither the road of the car was visible. It is dangerous, because the mirrors then have to be adjusted when the car is in [forward gear

4) When the roof is removed, the gagues get “”dim”, to the point that they are very difficult to see. The same issue occured yesterday (11/24) with the roof on, at night. It has happened in day light as well. When I purchased the car (from Kerbeck) the saleman said that this was going to be fixed, and that I wouldn’t have to worry about it, that it would be downloaded to the computer of the car. It has not been fixed.
5) If I unlock the car with the transmitter, the driver door can be opened, but the passenger door cannot be opened. The driver door must be opened first.

6) I am not certain if the car locks when I move the key away. Please check to see that the locking feature (passive lock I believe) is working properly.

7) The media device setting needs to be rebooted (I have to switch from device to radio, then back to device) and then the cell phone (Itunes) are once again heard.

8) The seat preset setting buttons do not work. If button “1” or “2” is pressed, the seats move a very little bit, Other times, they seem to require two or three pushes.

9) Please check the temperature accuracy on the heating system. If the temp is set at 72 degrees, it feels like 80 +

10) I have disabled the “horn chirp” feature (which chirps when the car is started and I leave the seat) and it still chirps most of the time, but not always.

11) driving last night, the gauges would not change when I switched through all of the modes. The "sport" gauge was the only one seen. I then used the buttons on the steering wheel and selected "link to driving mode" and they worked normally. I had that setting active since
I owned the car, and for some reason, I had to reset it again.

12) out of nowhere, the lap timer came on. I tried to stop it and reset it and couldn't. Also, the traction control deactivation light was on as well

Any insight would be greatly appreciated

**************Sorry here are corrections from above:


1) When car is started, it does not always start in the default Touring mode.

2) When the drive mode selector is turned to the right (from Touring; towards track), the modes sometimes turn the other way (towards weather / eco)

3) When side mirror reverse function was enabled, the mirrors would sometimes go into the down position, or the would go into an "up" position, where neither the road of the car was visible. It is dangerous, because the mirrors then have to be adjusted when the car is in [forward gear

4) When the roof is removed, the gagues get to the point that they are very difficult to see. The same issue occured yesterday (11/24) with the roof on, at night. It has happened in day light as well. When I purchased the car (from Kerbeck) the saleman said that this was going to be fixed, and that I wouldn't have to worry about it, that it would be downloaded to the computer of the car. It has not been fixed.
5) If I unlock the car with the transmitter, the driver door can be opened, but the passenger door cannot be opened. The driver door must be opened first.
8) The seat preset setting buttons do not work. If button1 or 2 is pressed, the seats move a very little bit, Other times, they seem to require two or three pushes.
Rmd1114 is offline   Reply With Quote
Old 12-05-2013, 04:02 PM   #5
erikszr1
CF Senior Member
 
erikszr1's Avatar
 
Member Since: Jun 2004
Send a message via AIM to erikszr1
Default

Quote:
Originally Posted by ramey View Post
every car has problem children... that's why i contend that a sportscar that is meant to live for 50 years like the vette should have an absolute minimum of electronics, very few modules, and all modules should be in an easily accessible panel instead of crammed up in the dash for a 10 hour replacement job.

why would a freaking corvette want mirror reverse, mode selectors other than - real man all off - and let your mom drive it all on.

why would anyone accept a car that reverted to some unwanted complicated setting every time you start it, rather than the setting you select?

why would you want screens and electronics that will soon be obsolete if they aren't already? if you want a lap timer, or a map, use your iphone or buy a real product.

why would anyone ever want a sports car whose doors lock or unlock without you doing it?

i am sorry you are having these problems, but the fact is none of these devices should be in a corvette. period. ever. and they are why in 50 years you'll see 100 year old vettes, but you won't find a 50 year old one.
all that crap should be saved for bmws and benz. who needs it!!! My C6Z has plenty of crap, most of which i can do without. all that junk should be optional. i like the c7, but all these issues is nonsense. hopefully the problems are contained to the electronics, time and miles will help show its true colors..............
erikszr1 is offline   Reply With Quote
Old 12-05-2013, 04:13 PM   #6
djseto
CF Senior Member
 
Member Since: Dec 2013
Default

Are these electronics issues common amongst new C7s? I've always owned german/japanese brands and while the germans are not without their issues, they usually get solved. The C7 would be my first American car and a while back I was also looking at the new Jeep Grand Cherokee but forums have shown it's been plagued with electronic issues and this thread isn't giving me the warm and fuzzies about a potential purchase. I guess..is this the norm or the exception?
djseto is offline   Reply With Quote
Old 12-05-2013, 04:16 PM   #7
Theta
Tech Contributor
St. Jude Donor '14
Support Corvetteforum!
 
Theta's Avatar
 
Member Since: Jan 2006
Location: Saint Louis MO
Default

Quote:
Originally Posted by Rmd1114 View Post
I picked up my car from Kerbeck 1 month ago. The next day, I tried to start it and it was dead. Had it jump started. Took it into Gearhart and they said everything was fine. Haven't had a problem with the battery since. I also told them of an issue with the mirrors (reverse tilt function.). They couldn't reproduce it. Since then the following issues have occurred with the car, and they were reproducible. Of course, The service dept couldn't reproduce them, except to say that I need 2 new seat switches. I have typically dealt with Porsche and BMW with my autos always with satisfaction. I'm aggravated that these issues cannot be reproduced until I pull the
Car off of the lot. Here are the current problems:



1) When car is started, it does not always start in the default “Touring” mode.

I've not run into this. If I turn the car off in Sport, it will start again in Sport. If I turn it off in Track, it will start in Touring. I hate that, personally... I want it to start in Track, but I digress. If you have it in Sport when turned off, it will start in Sport.

2) When the drive mode selector is turned to the right (from “touring” towards “track&rdquo, the modes sometimes turn the other way (towards “weather&rdquo

I have this as well, very frustrating, but I find that twisting all the way to the left or right solves it. Still annoying.

3) When “side mirror reverse function”was enabled, the mirrors would sometimes go into the down position, or the would go into an “UP” position, where nrither the road of the car was visible. It is dangerous, because the mirrors then have to be adjusted when the car is in [forward gear

Have not experienced this.

4) When the roof is removed, the gagues get “”dim”, to the point that they are very difficult to see. The same issue occured yesterday (11/24) with the roof on, at night. It has happened in day light as well. When I purchased the car (from Kerbeck) the saleman said that this was going to be fixed, and that I wouldn’t have to worry about it, that it would be downloaded to the computer of the car. It has not been fixed.

This is a big one, and it's dangerous. It's supposedly going to be fixed in an update. Here's hoping, because it's the worst bug so far.

5) If I unlock the car with the transmitter, the driver door can be opened, but the passenger door cannot be opened. The driver door must be opened first.

Hit "unlock" twice on the fob.

6) I am not certain if the car locks when I move the key away. Please check to see that the locking feature (passive lock I believe) is working properly.

Mine does not lock when the fob is away from it - perhaps this is a setting I need to dig for.

7) The media device setting needs to be rebooted (I have to switch from device to radio, then back to device) and then the cell phone (Itunes) are once again heard.

Happens here, as well, with Android A2DP. This is the case with both 4.3 and 4.4. I had chalked it up to an Android issue, but it looks like a Bluetooth issue if you're having the same issue.

8) The seat preset setting buttons do not work. If button “1” or “2” is pressed, the seats move a very little bit, Other times, they seem to require two or three pushes.

I have to hold mine down the whole time for them to work. Wasn't aware you could even make them 1-touch...

9) Please check the temperature accuracy on the heating system. If the temp is set at 72 degrees, it feels like 80 +

Big engine = lots of heat. This has always happened on LSx engines that I've owned.

10) I have disabled the “horn chirp” feature (which chirps when the car is started and I leave the seat) and it still chirps most of the time, but not always.

Same here, very aggravating at night.

11) driving last night, the gauges would not change when I switched through all of the modes. The "sport" gauge was the only one seen. I then used the buttons on the steering wheel and selected "link to driving mode" and they worked normally. I had that setting active since
I owned the car, and for some reason, I had to reset it again.

Link to driving mode helps reset this as you stated.

12) out of nowhere, the lap timer came on. I tried to stop it and reset it and couldn't. Also, the traction control deactivation light was on as well

That's a new one - never experienced or heard of that.

Any insight would be greatly appreciated

Thx
See replies above in your quoted post.

Theta is offline   Reply With Quote
Old 12-05-2013, 04:17 PM   #8
Rmd1114
Junior Member
 
Member Since: Dec 2013
Default

Quote:
Originally Posted by djseto View Post
Are these electronics issues common amongst new C7s? I've always owned german/japanese brands and while the germans are not without their issues, they usually get solved. The C7 would be my first American car and a while back I was also looking at the new Jeep Grand Cherokee but forums have shown it's been plagued with electronic issues and this thread isn't giving me the warm and fuzzies about a potential purchase. I guess..is this the norm or the exception?
I absolutely LOVE this car! It's perfect in every way, except for these problems.
Rmd1114 is offline   Reply With Quote
Old 12-05-2013, 04:18 PM   #9
Theta
Tech Contributor
St. Jude Donor '14
Support Corvetteforum!
 
Theta's Avatar
 
Member Since: Jan 2006
Location: Saint Louis MO
Default

Quote:
Originally Posted by djseto View Post
Are these electronics issues common amongst new C7s? I've always owned german/japanese brands and while the germans are not without their issues, they usually get solved. The C7 would be my first American car and a while back I was also looking at the new Jeep Grand Cherokee but forums have shown it's been plagued with electronic issues and this thread isn't giving me the warm and fuzzies about a potential purchase. I guess..is this the norm or the exception?
Not that it's representative of new models, but I owned an SRT8 Jeep Grand Cherokee for a grand total of 9 months before getting rid of it due to strange electronic issues with the traction system, integrated HDD, etc.

That was a 2010, so it may be much better now, or I could have had a lemon.

Sorry for that sidetrack, but see my replies in my last post above this one.
Theta is offline   Reply With Quote
Old 12-05-2013, 04:19 PM   #10
Theta
Tech Contributor
St. Jude Donor '14
Support Corvetteforum!
 
Theta's Avatar
 
Member Since: Jan 2006
Location: Saint Louis MO
Default

Quote:
Originally Posted by Rmd1114 View Post
I absolutely LOVE this car! It's perfect in every way, except for these problems.
100% agree - I'm in love and will put up with any of these issues for the pleasure of driving it. Seriously.
Theta is offline   Reply With Quote
Old 12-05-2013, 04:22 PM   #11
Rmd1114
Junior Member
 
Member Since: Dec 2013
Default

Hi Theta, Thx for your info.... I have the same exact car.... color and wheels. With regards to the key Fob, whether I hit it twice or ten times, it doesn't open the passenger door. I have to get in the car from the driver side, reach across, and press the "door open" handle on the passenger door to open.
Rmd1114 is offline   Reply With Quote
Old 12-05-2013, 04:48 PM   #12
Theta
Tech Contributor
St. Jude Donor '14
Support Corvetteforum!
 
Theta's Avatar
 
Member Since: Jan 2006
Location: Saint Louis MO
Default

Awesome - I love this combo, excellent choice!

Now that does suck with the fob. Check to see if you can open the door with the car locked by having the key on you and pressing the passenger door handle button.

Wonder what type of gremlin that is...
Theta is offline   Reply With Quote
Old 12-05-2013, 04:54 PM   #13
Rmd1114
Junior Member
 
Member Since: Dec 2013
Default

I've tried every combo. I can't wait to reproduce this error tomorrow when I pick up the car.
Rmd1114 is offline   Reply With Quote
Old 12-06-2013, 06:13 AM   #14
vetehead
CF Senior Member
 
vetehead's Avatar
 
Member Since: Jul 2007
Location: Massapequa NY
Vetehead@optonline.net Vetehead
Default

Quote:
Originally Posted by Rmd1114 View Post
I picked up my car from Kerbeck 1 month ago. The next day, I tried to start it and it was dead. Had it jump started. Took it into Gearhart and they said everything was fine. Haven't had a problem with the battery since. I also told them of an issue with the mirrors (reverse tilt function.). They couldn't reproduce it. Since then the following issues have occurred with the car, and they were reproducible. Of course, The service dept couldn't reproduce them, except to say that I need 2 new seat switches. I have typically dealt with Porsche and BMW with my autos always with satisfaction. I'm aggravated that these issues cannot be reproduced until I pull the
Car off of the lot. Here are the current problems:

1) When car is started, it does not always start in the default “Touring” mode.

2) When the drive mode selector is turned to the right (from “touring” towards “track&rdquo, the modes sometimes turn the other way (towards “weather&rdquo

3) When “side mirror reverse function”was enabled, the mirrors would sometimes go into the down position, or the would go into an “UP” position, where nrither the road of the car was visible. It is dangerous, because the mirrors then have to be adjusted when the car is in [forward gear

4) When the roof is removed, the gagues get “”dim”, to the point that they are very difficult to see. The same issue occured yesterday (11/24) with the roof on, at night. It has happened in day light as well. When I purchased the car (from Kerbeck) the saleman said that this was going to be fixed, and that I wouldn’t have to worry about it, that it would be downloaded to the computer of the car. It has not been fixed.
5) If I unlock the car with the transmitter, the driver door can be opened, but the passenger door cannot be opened. The driver door must be opened first.

6) I am not certain if the car locks when I move the key away. Please check to see that the locking feature (passive lock I believe) is working properly.

7) The media device setting needs to be rebooted (I have to switch from device to radio, then back to device) and then the cell phone (Itunes) are once again heard.

8) The seat preset setting buttons do not work. If button “1” or “2” is pressed, the seats move a very little bit, Other times, they seem to require two or three pushes.

9) Please check the temperature accuracy on the heating system. If the temp is set at 72 degrees, it feels like 80 +

10) I have disabled the “horn chirp” feature (which chirps when the car is started and I leave the seat) and it still chirps most of the time, but not always.

11) driving last night, the gauges would not change when I switched through all of the modes. The "sport" gauge was the only one seen. I then used the buttons on the steering wheel and selected "link to driving mode" and they worked normally. I had that setting active since
I owned the car, and for some reason, I had to reset it again.

12) out of nowhere, the lap timer came on. I tried to stop it and reset it and couldn't. Also, the traction control deactivation light was on as well

Any insight would be greatly appreciated

Thx
All I can tell you I have had all the same issues including the dead battery in shop now....Think back to the day before dead battery....was it the day onstar did the monthly maintenance download????Thats what I am thinking right now??? Thats what happened right before I turned car off and went to start next am stone dead!!

Let me hit your issues...dim dash fixable already....bullentin released to dealers yesterday.

My dash is always linked to sport(so dont really know about that on)


Drivers mode not always where set when restart(yes it happens)

Drivers select rotated backward somethimes(yes it happens occasional)

Lap counter appears on restart sometimes(yes it has happened once)

Horn beep 3x when getting out closing door while running taking key fob with u..gm design (safety) so they say..has nothing to do with setting key left in car thats when u leave fob in car turn of ign.and try to leave...that you can turn off.

Hvac..??i will agree quirky...but mine seems to be the opposite have to turn temp hotter then I would expect.

Media device..when streaming pandoro if i get out of car without ign cycle it loses connection with erro messages in pandora app and will not reconnect with out either relaunching from 1 source to the other or power cycle ign..

Seats if you have a m7 like i do..works same way(this my work around turn off easy entry....then start car first while seat is in exit position after running press preset once and seat will go to desired preset...when exit after turning ign off.just open door(easy exit turned on in settings) seat wheel mirrors will go to exit position....if ign is still on u have to open door first and press seat exit button to go to exit position....and if manual...parking brake MUST be on or you will have to press and hold buttons all the time!!

Some of these issues in my feelings are due to buggy software,some could be a week battery....

I gave the dealer the tis link yesterday that was posted here,and told them I dont care if a bulletin was issued or not....any software that is later then when my car left the factory(for my vin #) i want it updated....we will see...


LONG...lol but hope this helps you!
vetehead is offline   Reply With Quote
Old 12-06-2013, 07:53 AM   #15
Rmd1114
Junior Member
 
Member Since: Dec 2013
Default

Thanks Vettehead!! Can't believe that you have the same issues. Can I ask if you have any selections about the passenger door not being able to be opened, or the mirrors orienting up and away after reversing? Thx, Bob
Rmd1114 is offline   Reply With Quote
Old 12-06-2013, 03:31 PM   #16
vetehead
CF Senior Member
 
vetehead's Avatar
 
Member Since: Jul 2007
Location: Massapequa NY
Vetehead@optonline.net Vetehead
Default

Quote:
Originally Posted by Rmd1114 View Post
Thanks Vettehead!! Can't believe that you have the same issues. Can I ask if you have any selections about the passenger door not being able to be opened, or the mirrors orienting up and away after reversing? Thx, Bob
Bob definitely ,no problem with mirrors...but not sure about passenger door I will check when I get my car back and report back here....along with all software updates dealer performed.
vetehead is offline   Reply With Quote
Old 12-06-2013, 05:21 PM   #17
Rmd1114
Junior Member
 
Member Since: Dec 2013
Default

Ron, They did a software update for you?
Rmd1114 is offline   Reply With Quote
Old 12-06-2013, 05:22 PM   #18
Rmd1114
Junior Member
 
Member Since: Dec 2013
Default

Name:  image-69973466.jpg
Views: 4741
Size:  284.4 KB

Here is my beast
Rmd1114 is offline   Reply With Quote
Old 12-06-2013, 07:07 PM   #19
vetehead
CF Senior Member
 
vetehead's Avatar
 
Member Since: Jul 2007
Location: Massapequa NY
Vetehead@optonline.net Vetehead
Default

Quote:
Originally Posted by Rmd1114 View Post
Thanks Vettehead!! Can't believe that you have the same issues. Can I ask if you have any selections about the passenger door not being able to be opened, or the mirrors orienting up and away after reversing? Thx, Bob
Quote:
Originally Posted by Rmd1114 View Post
Ron, They did a software update for you?

Lol....yes but couldn't tell ya how that went as the car is in shop over the weekend so they can continue to go thru it for the "the unknown dead battery issue"..... They told me they all ready did the dim dash issue/ bulletin and they were going thru all other modules via the tis site I gave them, to make sure was all modules were as up to date as possible at this time.....I'm hopping most the the little bugs will be out of the car.More importantly I hope they find the root cause of the dead battery!

Last edited by vetehead; 12-06-2013 at 07:15 PM.
vetehead is offline   Reply With Quote
Old 12-06-2013, 07:10 PM   #20
vetehead
CF Senior Member
 
vetehead's Avatar
 
Member Since: Jul 2007
Location: Massapequa NY
Vetehead@optonline.net Vetehead
Default



Twins
vetehead is offline   Reply With Quote
Old 12-06-2013, 07:10 PM
 
Go Back   Corvette Forum > C7 Corvette > C7 Tech/Performance
Reload this Page Problems with my 2014 Corvette Stingray Z51
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Obama said Hillary's story is "horsesheet" virtue4u Politics, Religion & Controversy 19 08-12-2014 07:22 PM
More corruption by the MMGW scientists virtue4u Politics, Religion & Controversy 35 05-20-2014 09:42 AM
Chuck cow tune and Booster review akcraig85 C6 Tech/Performance 1 03-18-2014 03:55 AM
Chuck COW tune and Booster review akcraig85 C6 Scan & Tune 10 03-14-2014 04:45 PM
Fess up ...ot perv who is this,man caught rubbing his genitals against a the window Johnny Utah Off Topic 20 12-26-2013 07:03 PM


All times are GMT -4. The time now is 02:31 AM.


Emails & Password Backup