C2 Elecrical issue on my 67 - Page 2 - CorvetteForum - Chevrolet Corvette Forum Discussion

Notices
C1 & C2 Corvettes General C1 Corvette & C2 Corvette Discussion, Technical Info, Performance Upgrades, Project Builds, Restorations

[C2] Elecrical issue on my 67

Reply

 
 
 
Old 07-13-2018, 05:45 PM
  #21  
Frankie the Fink
CF Senior Member
Support Corvetteforum!
 
Frankie the Fink's Avatar
 
Member Since: Aug 2007
Location: Orlando Metro Area Florida
Posts: 42,065
Thanked 2,383 Times in 1,951 Posts
Default

I'm gonna say this and hope I'm wrong - if its one fuse holder the stopgap above might work; it its corrosion then you MIGHT be able to clean things up....if the fuse holder fingers are weak AND there is corrosion you might be in for a wiring job. I played getting this 67 Chevelle fuse box working consistently for about 4 months before I threw in the towel and replaced it. Doesn't look that bad ? Right ? Wrong. nothing but problems...you can see the corrosion on each fuse holder.

I'm just sayin'



Last edited by Frankie the Fink; 07-13-2018 at 05:46 PM.
Frankie the Fink is offline  
Reply With Quote
 
 
 


Thread Tools
Search this Thread
Sponsored Ads
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: