Can you hurt the speedo if--- - CorvetteForum - Chevrolet Corvette Forum Discussion


C3 General
General C3 Corvette Discussion not covered in Tech
Sponsored by:
Sponsored by:

Can you hurt the speedo if---

Reply
 
 
 
Thread Tools Search this Thread
Old 04-03-2005, 03:27 AM   #1
Desertdawg
CF Senior Member
St. Jude Donor '09
Thread Starter
 
Desertdawg's Avatar
 
Member Since: Jun 2001
Location: The Only Corvette in Gila Bend, Az.
Posts: 16,485
Thanks: 0
Thanked 0 Times in 0 Posts
Default Can you hurt the speedo if---

Can you hurt the speedo if you run it pegged for about 35 miles at a time?
Say, I run around 105mph and my speedo is pegged at 85mph, will this hurt anything internally???


Note:
All LEO's this is not an admittance to guilt. I no Nuthink....
Desertdawg is offline   Reply With Quote
Old 04-03-2005, 03:31 AM   #2
74FLCONV
CF Senior Member
 
74FLCONV's Avatar
 
Member Since: Oct 2002
Location: Manalapan FL
Posts: 3,258
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes...it's kinda like what Mom said about crossing your eyes...

74FLCONV is offline   Reply With Quote
Old 04-03-2005, 03:32 AM   #3
81 Vette
CF Senior Member
St. Jude Donor '05
First C3 General Poster!
 
81 Vette's Avatar
 
Member Since: Sep 2004
Location: Vernon British Columbia
Posts: 917
Thanks: 0
Thanked 0 Times in 0 Posts
Default

its worth it
81 Vette is offline   Reply With Quote
Old 04-03-2005, 03:40 AM   #4
Desertdawg
CF Senior Member
St. Jude Donor '09
Thread Starter
 
Desertdawg's Avatar
 
Member Since: Jun 2001
Location: The Only Corvette in Gila Bend, Az.
Posts: 16,485
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yeah, thats true.

I could repair it a couple of times just for this kind of fun!!!
Desertdawg is offline   Reply With Quote
Old 04-03-2005, 03:41 AM   #5
Desertdawg
CF Senior Member
St. Jude Donor '09
Thread Starter
 
Desertdawg's Avatar
 
Member Since: Jun 2001
Location: The Only Corvette in Gila Bend, Az.
Posts: 16,485
Thanks: 0
Thanked 0 Times in 0 Posts
Default

OOPS !!!

Double post
Desertdawg is offline   Reply With Quote
Old 04-03-2005, 04:07 AM   #6
Twin_Turbo
CF Senior Member
 
Member Since: Dec 1999
Posts: 16,941
Thanks: 0
Thanked 1 Time in 1 Post
Default

no, I ran mine pegged a lot of times...it's not a problem. The needle isn't solidly connected to the speedo cable anyway.
Twin_Turbo is offline   Reply With Quote
Old 04-03-2005, 04:08 AM   #7
platato
CF Senior Member
St. Jude Donor '05
 
platato's Avatar
 
Member Since: Aug 2003
Location: The Armpit of Illinois Platato says..... "Sometimes your the windshield & sometimes your the bug".
Posts: 518
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Desertdawg
Can you hurt the speedo if you run it pegged for about 35 miles at a time?
Say, I run around 105mph and my speedo is pegged at 85mph, will this hurt anything internally
LOL!

Uhhh yep!

I've had two cars with non functioning speedometers thanks to my obsession with top end. Both had cables that exploded with a sound that sounded like someone pumped a 12 gauge round into my dash.

When the cable explodes it uncoils and gets VERY BIG. That along with the misc pieces, can mess stuff up pretty good. If your going to run the desert like I did make sure you lube her real good or disconnect her. Also, she gets a little light in the nose at top end so be prepared. I really enjoyed running the desert in Nevada. I found the L81's top end is much improved when coming down one of those mountains with a straight road that you can see into infinity.

I learned a long ago that the tach is as good (actually better) than a speedo. The only reason for repairing the Vette is for NCRS. Heck, with an 85mph speedo I never see how fast I'm going anyway unless I'm in town.

STW!
Platato
platato is offline   Reply With Quote
Old 04-03-2005, 04:14 AM   #8
Desertdawg
CF Senior Member
St. Jude Donor '09
Thread Starter
 
Desertdawg's Avatar
 
Member Since: Jun 2001
Location: The Only Corvette in Gila Bend, Az.
Posts: 16,485
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'll lube up the cable again just in case, but one of these day's I'll upgrade it to a 145mph speedo...

BTW, I have been up above 130 out here, and didn't notice any lightness in the front, it felt pretty solidly planted...How high did your's sit in the front???
Desertdawg is offline   Reply With Quote
Old 04-03-2005, 05:02 AM   #9
platato
CF Senior Member
St. Jude Donor '05
 
platato's Avatar
 
Member Since: Aug 2003
Location: The Armpit of Illinois Platato says..... "Sometimes your the windshield & sometimes your the bug".
Posts: 518
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Desertdawg
I'll lube up the cable again just in case, but one of these day's I'll upgrade it to a 145mph speedo...

BTW, I have been up above 130 out here, and didn't notice any lightness in the front, it felt pretty solidly planted...How high did your's sit in the front???
Mine is bone stock on 255/60R15's. It definitely felt light to me but I diddn't have much of a contact patch at those speeds either. Shark81 has VERY touchy steering at *cough* "normal speeds". It got a lot less touchy at those speeds and seemed to buffet a bit. Fortunately not a turn for 100 miles so we just rode it out together

I'm not sure what the top end was but the mountains were tall, the road was straight and the speedo & tach were pegged. I ran every mountain and straight-a-way through Nevada like that. I left California via Yosemite so I diddn't even pick up a real highway (70) until Utah. I never saw another car and was in my glory because I always wondered what it would be like to run WOT for a l o n g time. I had a few good runs in Utah but had to watch for cops from there to Illinois. Colorado was great through the desert side and amazing through the Rockies (the Rockies were obviously designed for the Vette)

Cannonball anyone?

STW!

Platato

Last edited by platato; 04-03-2005 at 05:05 AM.
platato is offline   Reply With Quote
Old 04-03-2005, 10:19 AM   #10
Aflac
CF Senior Member
Cruise-In 5, 6 & 10 Veteran
St. Jude Donor '09
 
Aflac's Avatar
 
Member Since: Oct 2002
Location: Smalltownville Michigan
Posts: 12,064
Thanked 0 Times in 0 Posts
Default

mine has a 160 speedo in it...
Aflac is offline   Reply With Quote
Old 04-03-2005, 12:31 PM   #11
stingr69
CF Senior Member
 
stingr69's Avatar
 
Member Since: Mar 2004
Location: Little Rock AR
Posts: 3,485
Thanks: 0
Thanked 8 Times in 8 Posts
Default

My speedo only goes to "85"

I know I am going pretty fast when it gets to "H"....as in "MPH"

-JK

-Mark.
stingr69 is online now   Reply With Quote
Go Back   CorvetteForum - Chevrolet Corvette Forum Discussion >
Reload this Page
  • Can you hurt the speedo if---
  •  
     
    Reply

    Related Topics
    Thread Thread Starter Forum Replies Last Post
    TKO Performance: Banner screw up TLS_Addict C6 Corvette General Discussion 7 10-29-2012 07:04 PM
    Speedo default bobamylaura C5 Tech 9 10-29-2012 12:40 AM
    Pegged the speedo yesterday AZDoug C1 & C2 Corvettes 13 09-29-2008 05:39 PM
    Can you figure the final drive ratio with this info........ Mag Red Monster C5 Tech 4 05-11-2003 04:06 PM
    Speedo ? Todd15 C4 Tech/Performance 4 07-08-2002 08:45 PM


    Thread Tools Search this Thread
    Search this Thread:

    Click for Advanced Search

    Posting Rules
    You may not post new threads
    You may not post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are Off
    Pingbacks are Off
    Refbacks are Off

    Forum Jump

    Sponsored Ads
    Vendor Directory

    All times are GMT -4. The time now is 05:19 AM.


     
    • Ask a Question
      Get answers from community experts
    Question Title:
    Description:
    Your question will be posted in: