C3 Tech/Performance V8 Technical Info, Internal Engine, External Engine, Basic Tech and Maintenance for the C3 Corvette

'81 Horn not working

 
Old 08-03-2001, 12:36 AM
  #1  
rmadlem
CF Senior Member
Thread Starter
 
rmadlem's Avatar
 
Member Since: Jun 2001
Location: Beautiful Grand Rapids MI
Posts: 1,166
Likes: 0
Liked 0 Times in 0 Posts
Default '81 Horn not working

The horn in my '81 will not work. I noticed the spring, sleeve, and metal shaft were missing so I replaced these. The horn still won't work. Can anyone give me a description of how these are installed? The directions that came with the kit are terrible, I installed them in the way I thought made sense. What would the next thing to look for be? The horns themselves??
Thanks :smash:
rmadlem is offline  
Old 08-03-2001, 12:47 AM
  #2  
Dalannex
CF Senior Member
 
Dalannex's Avatar
 
Member Since: Mar 2000
Location: Northeast South Dakota
Posts: 4,018
Liked 1 Time in 1 Post
Default Re: '81 Horn not working (rmadlem)

I don't remember exactly how the parts you describe go in, but I do remember that when that small rod is sticking out if you ground it the horn should go off. You could try taking the upper contact assembly out and grounding the contact rod to see if the horn goes off then. If it does it is the upper assembly. Only one of your horns should work with the horn. The other one is for the alarm, I think. Mine had the upper assembly always grounding out, so I had to use some small paper spacers and new rivets to get it to work right again. If you find out there is a problem with your upper assembly let me know and I'll tell you what I did to mine to get it to work. :D
Dalannex is offline  
Old 08-03-2001, 10:16 AM
  #3  
Neo Fender
CF Senior Member
 
Member Since: Mar 2001
Location: St. Louis, Missouri
Posts: 1,409
Likes: 0
Liked 1 Time in 1 Post
Default Re: '81 Horn not working (rmadlem)

Spring goes in first. Insert pin into the sleeve, the large, flat end of the pin goes in first. Carefully press the pin angainst the spring and turn the sleeve so that it locks into place. A straightened paperclip works well for this.

Assuming that everything is in place, if your horn is not blowing, check to see if your horn relay is clicking or not. The horn relay is a light blue plastic cube under the dashboard. It is atached to a wiring harness.
Neo Fender is offline  
Old 08-03-2001, 10:56 AM
  #4  
rmadlem
CF Senior Member
Thread Starter
 
rmadlem's Avatar
 
Member Since: Jun 2001
Location: Beautiful Grand Rapids MI
Posts: 1,166
Likes: 0
Liked 0 Times in 0 Posts
Default Re: '81 Horn not working (rmadlem)

Thanks NeoFender,
I'll give that a try. I don't think that's how I installed it.
Take care
rmadlem is offline  
Old 08-03-2001, 11:08 AM
  #5  
Neo Fender
CF Senior Member
 
Member Since: Mar 2001
Location: St. Louis, Missouri
Posts: 1,409
Likes: 0
Liked 1 Time in 1 Post
Default Re: '81 Horn not working (rmadlem)

Also, with the spring out, you should be able to see the lower horn contact down in that hole. Using a small screwdriver, short this contact out against any other metal part and the horn should blow. If not, you'll know that your problem lies somewhere between that contact and the horns.
Neo Fender is offline  

Thread Tools
Search this Thread
Quick Reply: '81 Horn not working


Sponsored Ads
Vendor Directory

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: