Suddenly my HVAC blower is on high - even with the key off. - CorvetteForum - Chevrolet Corvette Forum Discussion


C4 General Discussion General C4 Corvette Discussion not covered in Tech

Suddenly my HVAC blower is on high - even with the key off.

Reply
 
 
 
Thread Tools Search this Thread
Old 05-07-2018, 11:19 PM   #1  
Cap'n Rich
CF Senior Member
Thread Starter
 
Cap'n Rich's Avatar
 
Member Since: Apr 2001
Location: Gig Harbor WA
Posts: 432
Thanked 0 Times in 0 Posts
Default Suddenly my HVAC blower is on high - even with the key off.

1989 convertible 5.7 L w/AC. Driven very little. The second time this yeqr today, just to the post office and home.
When I got home, then put it in the garage and shut it down, the heater/AC blower motor remained on high speed. I don't know where it may have been set.

I had to pull the battery ground cable to shut it down. Doing a little research, it seems this is not uncommon, but most fixes involve throwing parts at it until it goes away.

Figured I'd start by seeing where this 12V is coming from, then tracing it back towards the battery until I find the fault. Offhand, a stuck relay seems likely.

My Chilton's doesn't have a schematic I could find on the '89 HVAC. Anyone with hot leads? (pun sort of intended). :/

Last edited by Cap'n Rich; 05-07-2018 at 11:23 PM. Reason: Sloppy grammar.
Cap'n Rich is offline   Reply With Quote
Old 05-07-2018, 11:27 PM   #2  
five-oh
CF Senior Member
 
five-oh's Avatar
 
Member Since: Mar 2007
Location: Morrilton Arkansas
Posts: 307
Thanked 7 Times in 4 Posts
Default

I'd lay money on it being a blower control module, assuming it is a C68 equipped car with the digital settings. There's a thread on here somewhere with a link to a Jeep part that is a third of the cost of the Corvette part- I actually posted it after buying one for my 96. Common issue. I've had it happen on 2 of the 4 C4's I've owned.
five-oh is offline   Reply With Quote
The Following User Says Thank You to five-oh For This Useful Post:
Cap'n Rich (05-08-2018)
Old 05-07-2018, 11:44 PM   #3  
Cap'n Rich
CF Senior Member
Thread Starter
 
Cap'n Rich's Avatar
 
Member Since: Apr 2001
Location: Gig Harbor WA
Posts: 432
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by five-oh View Post
I'd lay money on it being a blower control module, assuming it is a C68 equipped car with the digital settings. There's a thread on here somewhere with a link to a Jeep part that is a third of the cost of the Corvette part- I actually posted it after buying one for my 96. Common issue. I've had it happen on 2 of the 4 C4's I've owned.
I read and bookmarked that thread, but that's what I meant about throwing parts at it. Not much sense in throwing a $30 module at it when it might be a $3 relay, right?

Appreciate the answer, though. Thanks.

Edit: The controls are digital. The previous time I drove it, I ran the HVAC through all it's function to check it's operation after sitting all winter. It seemed to work ok, but that's probably the first time in many years I have set the fan at 10.

Last edited by Cap'n Rich; 05-07-2018 at 11:57 PM. Reason: Answering question by five oh
Cap'n Rich is offline   Reply With Quote
Old 05-08-2018, 08:10 AM   #4  
Kevova
CF Senior Member
 
Kevova's Avatar
 
Member Since: Sep 2013
Location: near the thumb in the mitten
Posts: 2,245
Thanked 233 Times in 222 Posts
Default

Unfortunately the blower power module is the relay when you have C68. Manual HVAC C60 uses a relay.
Kevova is online now   Reply With Quote
The Following User Says Thank You to Kevova For This Useful Post:
Cap'n Rich (05-08-2018)
Old 05-08-2018, 10:46 AM   #5  
billschroeder5842
ZenVette Master level VII
Support Corvetteforum!
 
billschroeder5842's Avatar
 
Member Since: Mar 2016
Location: Southlake, TX
Posts: 2,732
Thanked 316 Times in 287 Posts
Default

Hey, Cap'n , swap out the blower control module. Simple and easy. This is super common. I bought a spare as it is only a matter of time.

BTW... scrap your chiltons for a legit FSM. It has a great trouble shooting guide.
billschroeder5842 is offline   Reply With Quote
The Following User Says Thank You to billschroeder5842 For This Useful Post:
Cap'n Rich (05-08-2018)
Old 05-08-2018, 12:38 PM   #6  
Cap'n Rich
CF Senior Member
Thread Starter
 
Cap'n Rich's Avatar
 
Member Since: Apr 2001
Location: Gig Harbor WA
Posts: 432
Thanked 0 Times in 0 Posts
Default

Okay, Kevova &Bill, I have one on order. In the description on eBay, all it said was that it was a resistor. I couldn't see that it was anything more, hence my confusion.

In the few minutes I had to check under the hood yesterday, I was looking for a relay such as the coolant fan relay - with no luck. Later when I had to go out to the garage/shop to retrieve a jug of rum I had stashed under the top cover lid, I had to hook up the battery for a moment to get the lid open, and the fan started right up runnin' agin. The engine was cool by then, so that verified the fault lay within the blower.

Now to get my son to come down to replace the module. I'm 76 and don't do my own wrenching any more. I'll have a rum and coke while he swaps it out. Also, I'll need to look up the location and procedure for him.

EDIT: I watched the YouTube video on the replacement and it seems easy-peasy. For some reason, I can't get any YouTube audio on my computer today. Other audio works fine. Fortunately, our local cable company now offers a free YouTube app on our TV. Watched it in HD 4K 70" living color!





Last edited by Cap'n Rich; 05-08-2018 at 03:24 PM.
Cap'n Rich is offline   Reply With Quote
Old 05-08-2018, 12:42 PM   #7  
Tom400CFI
CF Senior Member
 
Tom400CFI's Avatar
 
Member Since: Aug 2004
Location: Park City Utah
Posts: 12,582
Thanked 462 Times in 410 Posts
Default

If this is the blower control module,




I have one of those for sale, HERE, FYI.
Tom400CFI is offline   Reply With Quote
Old 05-08-2018, 03:24 PM   #8  
Cap'n Rich
CF Senior Member
Thread Starter
 
Cap'n Rich's Avatar
 
Member Since: Apr 2001
Location: Gig Harbor WA
Posts: 432
Thanked 0 Times in 0 Posts
Default

Tom .......... I've already ordered a new one for $28.

Rich

Last edited by Cap'n Rich; 05-08-2018 at 03:26 PM.
Cap'n Rich is offline   Reply With Quote
Old 05-08-2018, 03:50 PM   #9  
Tom400CFI
CF Senior Member
 
Tom400CFI's Avatar
 
Member Since: Aug 2004
Location: Park City Utah
Posts: 12,582
Thanked 462 Times in 410 Posts
Default

Really? Where? I looked on NAPA and they list it at $240.00 (?)

NAPA Blower motor resistor
Tom400CFI is offline   Reply With Quote
Old 05-08-2018, 07:53 PM   #10  
Cap'n Rich
CF Senior Member
Thread Starter
 
Cap'n Rich's Avatar
 
Member Since: Apr 2001
Location: Gig Harbor WA
Posts: 432
Thanked 0 Times in 0 Posts
Default

Tom .........

I'm told this is the same part number.

https://tinyurl.com/y8g3ealr

Rich
Cap'n Rich is offline   Reply With Quote
Old 05-08-2018, 09:06 PM   #11  
Tom400CFI
CF Senior Member
 
Tom400CFI's Avatar
 
Member Since: Aug 2004
Location: Park City Utah
Posts: 12,582
Thanked 462 Times in 410 Posts
Default

Huh. It looks the same. I'd probably buy it there too. I wonder why NAPA charges so much??
Tom400CFI is offline   Reply With Quote
Old 05-09-2018, 12:24 AM   #12  
JrRifleCoach
CF Senior Member
 
JrRifleCoach's Avatar
 
Member Since: Sep 2003
Location: Criminals obey guns laws like politicians follow their oath to office Republik of Kalifornico"
Posts: 18,070
Thanked 200 Times in 186 Posts
St. Jude '03-'04-'05-'06-'07-'08-'09-'10-'11-'12-'13-'14-'15-'16-'17

Default

Quote:
Originally Posted by Tom400CFI View Post
Huh. It looks the same. I'd probably buy it there too. I wonder why NAPA charges so much??
Seriously?
JrRifleCoach is offline   Reply With Quote
Old 05-15-2018, 06:56 PM   #13  
Cap'n Rich
CF Senior Member
Thread Starter
 
Cap'n Rich's Avatar
 
Member Since: Apr 2001
Location: Gig Harbor WA
Posts: 432
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Tom400CFI View Post
Huh. It looks the same. I'd probably buy it there too. I wonder why NAPA charges so much??
Tom ...........

It appears I was misinformed. The part arrived yesterday. I went to install it today and the new part is almost a mirror image of the old. It does not fit.

I then proceeded to try to swap out just the control modules, unscrewing them from the top mounting plate and the heat sinks. The old one was easy, just four little screws.

The new one is a little different design. The module is also attached to it's heat sink with a concealed screw. If you pull up on the module, you can see the screw under it. If you pull a little harder, you will bust off the leads to the transistor screwed to the board. Now the transistor is not the only thing that's screwed - you are, too!

I'm just full of bad ideas today, it seems.

If you go to eBay, you'll see used 'Vette BCM's go for around $50 delivered. New ones are $128. But, the new ones are a different design than the originals. They'll fit, but they seem to have a lot cheaper construction.

Is your part priced delivered, or should I buy the used one on eBay for $44 delivered? I may get bombed on rum and caffine-free diet coke this afternoon.
Cap'n Rich is offline   Reply With Quote
Old 05-15-2018, 08:47 PM   #14  
Cap'n Rich
CF Senior Member
Thread Starter
 
Cap'n Rich's Avatar
 
Member Since: Apr 2001
Location: Gig Harbor WA
Posts: 432
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by billschroeder5842 View Post
Hey, Cap'n , swap out the blower control module. Simple and easy. This is super common. I bought a spare as it is only a matter of time.

BTW... scrap your chiltons for a legit FSM. It has a great trouble shooting guide.
Bill ............ The more I think about it, I seem to remember I already have a legit FSM. I just can't find it. It's here, someplace. I'm looking.
Cap'n Rich is offline   Reply With Quote
Old 05-16-2018, 06:28 PM   #15  
Tom400CFI
CF Senior Member
 
Tom400CFI's Avatar
 
Member Since: Aug 2004
Location: Park City Utah
Posts: 12,582
Thanked 462 Times in 410 Posts
Default

Quote:
Originally Posted by Cap'n Rich View Post
Tom ...........

It appears I was misinformed. The part arrived yesterday. I went to install it today and the new part is almost a mirror image of the old. It does not fit.

I then proceeded to try to swap out just the control modules, unscrewing them from the top mounting plate and the heat sinks. The old one was easy, just four little screws.

The new one is a little different design. The module is also attached to it's heat sink with a concealed screw. If you pull up on the module, you can see the screw under it. If you pull a little harder, you will bust off the leads to the transistor screwed to the board. Now the transistor is not the only thing that's screwed - you are, too!

I'm just full of bad ideas today, it seems.

If you go to eBay, you'll see used 'Vette BCM's go for around $50 delivered. New ones are $128. But, the new ones are a different design than the originals. They'll fit, but they seem to have a lot cheaper construction.

Is your part priced delivered, or should I buy the used one on eBay for $44 delivered? I may get bombed on rum and caffine-free diet coke this afternoon.
Huh. That is all interesting too. Thanks for sharing!

I'd do that price, Shipped. Sorry I didn't reply sooner; I'm out of town until tomorrow, but if you want, I can get it out Friday. LMK!
Tom400CFI is offline   Reply With Quote
Old 05-16-2018, 06:39 PM   #16  
five-oh
CF Senior Member
 
five-oh's Avatar
 
Member Since: Mar 2007
Location: Morrilton Arkansas
Posts: 307
Thanked 7 Times in 4 Posts
Default

Quote:
Originally Posted by Cap'n Rich View Post
Tom ...........

It appears I was misinformed. The part arrived yesterday. I went to install it today and the new part is almost a mirror image of the old. It does not fit.

I then proceeded to try to swap out just the control modules, unscrewing them from the top mounting plate and the heat sinks. The old one was easy, just four little screws.

The new one is a little different design. The module is also attached to it's heat sink with a concealed screw. If you pull up on the module, you can see the screw under it. If you pull a little harder, you will bust off the leads to the transistor screwed to the board. Now the transistor is not the only thing that's screwed - you are, too!

I'm just full of bad ideas today, it seems.

If you go to eBay, you'll see used 'Vette BCM's go for around $50 delivered. New ones are $128. But, the new ones are a different design than the originals. They'll fit, but they seem to have a lot cheaper construction.

Is your part priced delivered, or should I buy the used one on eBay for $44 delivered? I may get bombed on rum and caffine-free diet coke this afternoon.
Man, I hate it didn't work for you. The Jeep part I listed on that thread was the exact part I ordered and it was identical to the original part I had on my '96. I didn't make that thread until I received the part, installed, and tested it.. I wonder if they changed the design from 89 to 96?
five-oh is offline   Reply With Quote
Old 05-20-2018, 04:27 PM   #17  
Cap'n Rich
CF Senior Member
Thread Starter
 
Cap'n Rich's Avatar
 
Member Since: Apr 2001
Location: Gig Harbor WA
Posts: 432
Thanked 0 Times in 0 Posts
Default

Aw, crap on a cracker, Tom. I should have waited. I bought one from eBay, it arrived yesterday, installed it today . . . and It Doesn't Work!

This one won't run the fan at all. I have voltage, both to the power wire (Red) and to the control wire (Tan). The control head is set to Manual fan, speed 10 (tried them all) and the fan doesn't run. If I plug the old one in, the fan starts right up and runs continuously.

I have a query in to the seller. I'll give him a chance to get his $0.02 worth in before I return it.

More rum!!!
Cap'n Rich is offline   Reply With Quote
Old 05-20-2018, 04:41 PM   #18  
Cap'n Rich
CF Senior Member
Thread Starter
 
Cap'n Rich's Avatar
 
Member Since: Apr 2001
Location: Gig Harbor WA
Posts: 432
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by five-oh View Post
Man, I hate it didn't work for you. The Jeep part I listed on that thread was the exact part I ordered and it was identical to the original part I had on my '96. I didn't make that thread until I received the part, installed, and tested it.. I wonder if they changed the design from 89 to 96?
Five-Oh . . .
There's definite, obvious differences both in the top plate and the insides.
I'll attach a picture of the two top plates. You can see readily the plugs are reversed and (not so easily) one of the mounting holes is in a different place.

Cap'n Rich is offline   Reply With Quote
Old 05-20-2018, 05:03 PM   #19  
Tom400CFI
CF Senior Member
 
Tom400CFI's Avatar
 
Member Since: Aug 2004
Location: Park City Utah
Posts: 12,582
Thanked 462 Times in 410 Posts
Default

Man...that's frustrating sounding! Mine is just sitting here, so if you end up wanting it, LMK.

-Tom
Tom400CFI is offline   Reply With Quote
Old 05-20-2018, 05:57 PM   #20  
Cap'n Rich
CF Senior Member
Thread Starter
 
Cap'n Rich's Avatar
 
Member Since: Apr 2001
Location: Gig Harbor WA
Posts: 432
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Tom400CFI View Post
Man...that's frustrating sounding! Mine is just sitting here, so if you end up wanting it, LMK.

-Tom
Cap'n Rich is offline   Reply With Quote
Go Back   CorvetteForum - Chevrolet Corvette Forum Discussion >
Reload this Page
  • Suddenly my HVAC blower is on high - even with the key off.
  •  
     
    Reply

    Related Topics
    Thread Thread Starter Forum Replies Last Post
    [C2] My Hot Rod Is DEAD! Maybe the little red wire is to blame. rinkydink64 C1 & C2 Corvettes 23 10-18-2017 06:01 PM
    Engine Bogging James84vette C4 Tech/Performance 8 04-05-2017 05:42 AM
    Steering Column Fire Stephenms C4 General Discussion 9 08-03-2016 10:13 AM
    1994 Automatic Climate Control Issues TorchTarga94 C4 Tech/Performance 20 05-31-2016 10:00 PM
    Alternator/Charge System Faults - Bill Curle? RiceBurnerZ07 C5 General 7 03-22-2016 08:48 PM


    Thread Tools Search this Thread
    Search this Thread:

    Click for Advanced Search

    Posting Rules
    You may not post new threads
    You may not post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are Off
    Pingbacks are Off
    Refbacks are Off

    Forum Jump

    Sponsored Ads
    Vendor Directory

    All times are GMT -4. The time now is 07:19 PM.


    We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
     
    • Ask a Question
      Get answers from community experts
    Question Title:
    Description:
    Your question will be posted in: