engine help! - Page 2 - CorvetteForum - Chevrolet Corvette Forum Discussion


C4 Tech/Performance L98 Corvette and LT1 Corvette Technical Info, Internal Engine, External Engine

engine help!

Reply
 
 
 
Thread Tools Search this Thread
Old 01-13-2018, 08:07 PM   #21  
Brenden Schaeffer
Junior Member
Thread Starter
 
Member Since: Jan 2018
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by mtwoolford View Post
I may not be following exactly what's happening, but:

"something weird happened. I turned the car on after all this and let it warm up then all of a sudden it just shut off it wouldn't fire but would crank....so I tried starting it again and it ran fine"

switch is normally "open" when engine not running.

When ignition key is in "start" switch is bypassed and power is fed to fuel pump relay.

This explains (at least one possible explanation) why your engine starts and runs with 0 psi

when ignition switch is turned back from "start" to "on", the ignition circuit no longer feeds power to the fuel pump relay.

switch is normally "closed" when engine running. when engine starts and oil pressure builds, switch closes and provides power to fuel pump relay.

If that switch is failing to close intermittently, or visa versa, goes open ...as in bad contacts or a bad diaphragm...it could go a long way in explaining your symptoms. In my experience, switches, especially pressure operated switches, fail intermittently over time, not catastrophically, all at once.
I did a test and when I can get it running if I tap ontop of the ECM sometimes the fans will shut on and off and if itís key on power and if I tap on it I can hear the switches turning off and on. And when itís running if I tap on it sometimes it will shut off sooooo new ECM
Brenden Schaeffer is offline   Reply With Quote
Old 01-13-2018, 08:10 PM   #22  
aklim
CF Senior Member
 
aklim's Avatar
 
Member Since: Jul 2004
Location: Hartford WI
Posts: 13,707
Thanked 619 Times in 608 Posts
Default

Quote:
Originally Posted by Brenden Schaeffer View Post
I did a test and when I can get it running if I tap ontop of the ECM sometimes the fans will shut on and off and if itís key on power and if I tap on it I can hear the switches turning off and on. And when itís running if I tap on it sometimes it will shut off sooooo new ECM
If the connections are tight, sure that is an issue. Does someone have a known good one for you to test before buying?
aklim is offline   Reply With Quote
Old 01-13-2018, 09:24 PM   #23  
Brenden Schaeffer
Junior Member
Thread Starter
 
Member Since: Jan 2018
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by aklim View Post
If the connections are tight, sure that is an issue. Does someone have a known good one for you to test before buying?
Iv gone through every ground and what not . I donít but the company iv been looking at told me if it doesnít work I can return it. Should I look at a repair place or just go for a new one? Itís half the price for a repair
Brenden Schaeffer is offline   Reply With Quote
Old 01-13-2018, 10:13 PM   #24  
aklim
CF Senior Member
 
aklim's Avatar
 
Member Since: Jul 2004
Location: Hartford WI
Posts: 13,707
Thanked 619 Times in 608 Posts
Default

Quote:
Originally Posted by Brenden Schaeffer View Post
Iv gone through every ground and what not . I donít but the company iv been looking at told me if it doesnít work I can return it. Should I look at a repair place or just go for a new one? Itís half the price for a repair
If they have gone through it, it might not be a bad idea to try.
aklim is offline   Reply With Quote
Go Back   CorvetteForum - Chevrolet Corvette Forum Discussion >
Reload this Page
  • engine help!
  •  
     
    Reply

    Related Topics
    Thread Thread Starter Forum Replies Last Post
    A8 rev match TATPAD C7 Z06 Discussion 48 01-19-2018 10:43 AM
    Rev match paddles placement Basil2000 C7 Z06 Discussion 7 10-24-2017 07:19 PM
    Tour mode shift lights '17 GS 2lt cor66vette C7 Tech/Performance 2 12-24-2016 09:10 AM
    Rev match glitched and freaked the car out Speednet C7 Z06 Discussion 13 10-19-2016 09:08 PM
    Rev'nRods GEM '62 C1 & C2 Corvettes 3 07-06-2016 10:14 PM


    Thread Tools Search this Thread
    Search this Thread:

    Click for Advanced Search

    Posting Rules
    You may not post new threads
    You may not post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are Off
    Pingbacks are Off
    Refbacks are Off

    Forum Jump

    Sponsored Ads
    Vendor Directory

    All times are GMT -4. The time now is 06:07 AM.


    We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
     
    • Ask a Question
      Get answers from community experts
    Question Title:
    Description:
    Your question will be posted in: