87 C4: low torque and vibrations at highway speeds - CorvetteForum - Chevrolet Corvette Forum Discussion

Go Back  CorvetteForum - Chevrolet Corvette Forum Discussion > C4 Corvettes, 1984 - 1996 > C4 Tech/Performance
Reload this Page >

87 C4: low torque and vibrations at highway speeds

Notices
C4 Tech/Performance L98 Corvette and LT1 Corvette Technical Info, Internal Engine, External Engine

87 C4: low torque and vibrations at highway speeds

Reply

 
 
 
Old 03-20-2018, 08:13 PM
  #1  
joshjoshvette
Junior Member
Thread Starter
 
Member Since: Mar 2017
Location: Los Angeles, CA
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default 87 C4: low torque and vibrations at highway speeds

Hello all!

Wanted to see if anyone had this problem or could help me diagnose it.

I've got a 87 4+3 C4 that I've been having some issues with. It seems to be working fine at low to moderate speeds, up to around 45-50mph in 2nd gear OD and 3rd gear. The main issue is when I'm accelerating up to highway speeds. Once I get into 3rd gear and around 50mph, there is almost no torque, i feel like I'm driving a geo prism or something... And as I'm trying to get up to speed in 3rd and 4th gear, the car starts vibrating pretty heavily, engine starts getting loud and feels bogged down. The past 2 days, it was also accompanied by a burning rubber smell. Talked to my mechanic briefly about it and he suspected it could be the clutch due to the burnt rubber smell. The clutch was just replaced about a year ago. (maybe a shitty part?)

Any ideas would be much appreciated. thanks!
joshjoshvette is offline  
Reply With Quote
Old 03-22-2018, 02:47 PM
  #2  
Kevova
CF Senior Member
 
Kevova's Avatar
 
Member Since: Sep 2013
Location: near the thumb in the mitten
Posts: 2,960
Thanked 278 Times in 265 Posts
Default

Clutch normally will slip on hard acceleration. Are you running cat converters? Has OD unit been serviced?
Kevova is offline  
Reply With Quote
Old 07-11-2018, 02:55 PM
  #3  
joshjoshvette
Junior Member
Thread Starter
 
Member Since: Mar 2017
Location: Los Angeles, CA
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Originally Posted by Kevova View Post
Clutch normally will slip on hard acceleration. Are you running cat converters? Has OD unit been serviced?
Turned out it was the brake calipers getting locked up. Replaced them and its been good to go.
joshjoshvette is offline  
Reply With Quote
 
 
 


Thread Tools
Search this Thread
Quick Reply: 87 C4: low torque and vibrations at highway speeds


Sponsored Ads
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: