Go Back  CorvetteForum - Chevrolet Corvette Forum Discussion > C4 Corvettes, 1984 - 1996 > C4 Tech/Performance
Reload this Page >

Intermittant no crank, no fuel pump prime, no injector signal?

Notices
C4 Tech/Performance L98 Corvette and LT1 Corvette Technical Info, Internal Engine, External Engine

Intermittant no crank, no fuel pump prime, no injector signal?

 
Old 06-11-2019, 11:31 AM
  #1  
Mikeceli
CF Senior Member
Thread Starter
 
Member Since: Sep 2002
Location: Petaluma CA
Posts: 11,655
Likes: 0
Received 6 Likes on 6 Posts
Default Intermittant no crank, no fuel pump prime, no injector signal?

Hi. RE 1989 IROC Z Camaro 305 TPI AT.

Intermittent NO Crank with SES and VATS lights functioning in THE normal fashion. When I remotely energize the starter it cranks fine, (NO START) sometimes NO Fuel Pump Prime (0 PSI @ Rail) , sometimes pump runs w/ 35 PSI @ Rail), YET does not run unless I spray Carb Spray in PCV hose to manifold.

In other words, what would SHUT DOWN a GOOD cranking system, SOMETIMES / SOMETIMES NOT prevent fuel pump receiving current, and apparently prevent injectors from firing?

My Actron CP-9190 scanner reads "Communication Error" .

I recently bought this car as a "Fixer" and have no history. THANK YOU!
Mikeceli is offline  
Old 06-12-2019, 08:09 AM
  #2  
Kevova
CF Senior Member
 
Kevova's Avatar
 
Member Since: Sep 2013
Location: near the thumb in the mitten
Posts: 4,010
Received 375 Likes on 359 Posts
Default

A Camaro is not a Corvette. I would suspect VATS
Kevova is offline  
Old 06-12-2019, 03:22 PM
  #3  
aklim
CF Senior Member
 
aklim's Avatar
 
Member Since: Jul 2004
Location: Hartford WI
Posts: 16,113
Received 822 Likes on 803 Posts
Default

Originally Posted by Mikeceli View Post
Hi. RE 1989 IROC Z Camaro 305 TPI AT.

Intermittent NO Crank with SES and VATS lights functioning in THE normal fashion. When I remotely energize the starter it cranks fine, (NO START) sometimes NO Fuel Pump Prime (0 PSI @ Rail) , sometimes pump runs w/ 35 PSI @ Rail), YET does not run unless I spray Carb Spray in PCV hose to manifold.

In other words, what would SHUT DOWN a GOOD cranking system, SOMETIMES / SOMETIMES NOT prevent fuel pump receiving current, and apparently prevent injectors from firing?

My Actron CP-9190 scanner reads "Communication Error" .

I recently bought this car as a "Fixer" and have no history. THANK YOU!
Apparently prevent injectors from firing? How about testing it to see that it DOES prevent injectors from firing? Get a noid light and see if it does have pulse when it doesn't want to run. If it is VATS, you should not be able to crank it. If it is the neutral safety switch, probably same thing.
aklim is online now  
Old 06-12-2019, 04:17 PM
  #4  
Mikeceli
CF Senior Member
Thread Starter
 
Member Since: Sep 2002
Location: Petaluma CA
Posts: 11,655
Likes: 0
Received 6 Likes on 6 Posts
Default

I will get a set of NOID lights, been meaning to for years! I am set up to start the GM FSM troubleshoot tree. It is a PITA and was hoping someone FAMILIAR w/ 80's GM VATS, ESCM (ECM), Ign. Control Modules, etc. might have some shortcut tips. FWIW I also posted in tgo.org (F Body forum) with no responses, so far. Thanks
Mikeceli is offline  
Old 06-12-2019, 04:25 PM
  #5  
jsinga
CF Senior Member
 
Member Since: Oct 2003
Location: Savannah GA
Posts: 472
Likes: 0
Received 6 Likes on 6 Posts
Default

no distributor reference pulses
jsinga is offline  
Old 06-12-2019, 06:22 PM
  #6  
aklim
CF Senior Member
 
aklim's Avatar
 
Member Since: Jul 2004
Location: Hartford WI
Posts: 16,113
Received 822 Likes on 803 Posts
Default

Originally Posted by Mikeceli View Post
I will get a set of NOID lights, been meaning to for years! I am set up to start the GM FSM troubleshoot tree. It is a PITA and was hoping someone FAMILIAR w/ 80's GM VATS, ESCM (ECM), Ign. Control Modules, etc. might have some shortcut tips. FWIW I also posted in tgo.org (F Body forum) with no responses, so far. Thanks
https://www.autozone.com/tools-and-e..._0_0?location=
aklim is online now  

Thread Tools
Search this Thread
Quick Reply: Intermittant no crank, no fuel pump prime, no injector signal?


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: