Left front Daytime Running Light /Turn signal - CorvetteForum - Chevrolet Corvette Forum Discussion


C5 Tech
Corvette Tech/Performance: LS1 Corvette Technical Info, Internal Engine, External Engine, Tech Topics, Basic Tech, Maintenance, How to Remove & Replace
Sponsored by:
Sponsored by:

Left front Daytime Running Light /Turn signal

Reply
 
 
 
Thread Tools Search this Thread
Old 08-05-2017, 10:17 PM   #1
Clayton59
CF Member
Thread Starter
 
Member Since: Jun 2015
Location: Ohatchee Alabama
Posts: 64
Thanked 0 Times in 0 Posts
Default Left front Daytime Running Light /Turn signal

OK my Corvette Forum friends, again I come to you with a situation and request your assistance.


I have C5 2001 coupe. The left front running light and turn signal don't work. The left side parking light does work. The rear turn signal and brake lights work as they should. The right side lights all work as they should. I have already replaced the bulb with a new one (twice, two different blubs). I already replaced the #40 relay, even though I swapped the #38 and #40 and there was no difference in either one.


I have read other posts where the running lights, 4 way Flashers and turn signals were inoperative... I think my situation is a little different than that. My situation only pertains to the left front Daytime running light/Turn signal


Any and all suggestions will be greatly appreciated...
Clayton59 is offline   Reply With Quote
Old 08-06-2017, 03:15 AM   #2
8VETTE7
CF Senior Member
 
8VETTE7's Avatar
 
Member Since: Jul 2007
Posts: 20,202
Thanked 1,347 Times in 1,199 Posts
Default

Quote:
Originally Posted by Clayton59 View Post
OK my Corvette Forum friends, again I come to you with a situation and request your assistance.


I have C5 2001 coupe. The left front running light and turn signal don't work. The left side parking light does work. The rear turn signal and brake lights work as they should. The right side lights all work as they should. I have already replaced the bulb with a new one (twice, two different blubs). I already replaced the #40 relay, even though I swapped the #38 and #40 and there was no difference in either one.


I have read other posts where the running lights, 4 way Flashers and turn signals were inoperative... I think my situation is a little different than that. My situation only pertains to the left front Daytime running light/Turn signal


Any and all suggestions will be greatly appreciated...


Cannot be the fuse if the RF light works since the same fuse services both sides and if the relay #40 and the LF bulb are known good, there are only a few things that it could be.

Wiring between the relay and the bulb, the bulb socket itself, the ground (Splice pack 100 and G102 which are on the left side frame near the headlight) or a BCM problem since the BCM provides the ground for the coil side of relay 40. Is or has the carpet in the passenger foot well been wet??

If none of the above are found to be a problem it could be the portion of the multi function switch that operates the LF turn signal. Separate electrical power path in the MFS for LF, RF LR and RR signal lights.
8VETTE7 is offline   Reply With Quote
Old 08-06-2017, 10:20 AM   #3
Clayton59
CF Member
Thread Starter
 
Member Since: Jun 2015
Location: Ohatchee Alabama
Posts: 64
Thanked 0 Times in 0 Posts
Default

when I turn on the 4way flashers, 3 of the four work. the left front does not. Where does this wire harness plug in the to main harness? I want to run back up the harness and check the connections.
Clayton59 is offline   Reply With Quote
Old 08-06-2017, 11:45 AM   #4
LoneStarFRC
CF Senior Member
St. Jude Donor '08-'09-'10-'11-'12-'13-'14-'15-'16
 
LoneStarFRC's Avatar
 
Member Since: May 2001
Location: Don't judge anyone until you've walked a mile in their stupid, ugly shoes ~
Posts: 36,830
Thanked 178 Times in 170 Posts
Default

A fried L/F bulb socket can be a problem too. They get cooked over time from all the heat from the OE incandescent bulb, which is the source of the C5 parking light/DRL issues in the first place.

HTH
LoneStarFRC is offline   Reply With Quote
Old 08-06-2017, 12:54 PM   #5
Clayton59
CF Member
Thread Starter
 
Member Since: Jun 2015
Location: Ohatchee Alabama
Posts: 64
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by 8VETTE7 View Post
Cannot be the fuse if the RF light works since the same fuse services both sides and if the relay #40 and the LF bulb are known good, there are only a few things that it could be.

Wiring between the relay and the bulb, the bulb socket itself, the ground (Splice pack 100 and G102 which are on the left side frame near the headlight) or a BCM problem since the BCM provides the ground for the coil side of relay 40. Is or has the carpet in the passenger foot well been wet?? No, never been wet

If none of the above are found to be a problem it could be the portion of the multi function switch that operates the LF turn signal. Separate electrical power path in the MFS for LF, RF LR and RR signal lights.

So, I found the plug under the Right Front headlight. I unplugged the harness and used my volt meter. I touched the black wire prong with the negative side of the meter. with the red probe I touched the Dark Blue wire prong (right side light) and got a 14 volt reading. When I touched the Light blue wire prong (left side light) there was no power... Therefore I'm leaning toward the Multifunction switch... What are your thoughts? Where can I get the correct GM part number for this? I looked on GM Parts.com but they only show the switch for NON Telescopic steering column. Mine is telescopic.
Clayton59 is offline   Reply With Quote
Old 08-06-2017, 01:52 PM   #6
LoneStarFRC
CF Senior Member
St. Jude Donor '08-'09-'10-'11-'12-'13-'14-'15-'16
 
LoneStarFRC's Avatar
 
Member Since: May 2001
Location: Don't judge anyone until you've walked a mile in their stupid, ugly shoes ~
Posts: 36,830
Thanked 178 Times in 170 Posts
Default

Quote:
Originally Posted by Clayton59 View Post
So, I found the plug under the Right Front headlight. I unplugged the harness and used my volt meter. I touched the black wire prong with the negative side of the meter. with the red probe I touched the Dark Blue wire prong (right side light) and got a 14 volt reading. When I touched the Light blue wire prong (left side light) there was no power... Therefore I'm leaning toward the Multifunction switch... What are your thoughts? Where can I get the correct GM part number for this? I looked on GM Parts.com but they only show the switch for NON Telescopic steering column. Mine is telescopic.
GM 26075870 or,
AC Delco D1512G
Same part number for all C5s.

HTH
LoneStarFRC is offline   Reply With Quote
The Following User Says Thank You to LoneStarFRC For This Useful Post:
Clayton59 (08-06-2017)
Old 08-06-2017, 02:16 PM   #7
8VETTE7
CF Senior Member
 
8VETTE7's Avatar
 
Member Since: Jul 2007
Posts: 20,202
Thanked 1,347 Times in 1,199 Posts
Default

Quote:
Originally Posted by Clayton59 View Post
So, I found the plug under the Right Front headlight. I unplugged the harness and used my volt meter. I touched the black wire prong with the negative side of the meter. with the red probe I touched the Dark Blue wire prong (right side light) and got a 14 volt reading. When I touched the Light blue wire prong (left side light) there was no power... Therefore I'm leaning toward the Multifunction switch... What are your thoughts? Where can I get the correct GM part number for this? I looked on GM Parts.com but they only show the switch for NON Telescopic steering column. Mine is telescopic.
I agree that if there is no voltage at the light blue wire at the connector then the most likely failure cause is in the multi function switch. I can post the wiring diagrams if you would like to review them yourself. There are a couple pages and are NOT the easiest diagrams to follow that I have ever looked at. Let me know if you need the diagrams.

Unfortunately I cannot help you with sourcing the MFS as I have NOT had to do that yet. I did just do a quick look on a couple of parts places (Rock Auto, O'reilly) and they do NOT seem to make note of the telescopic column. That is not conclusive in my mind so I might call a local dealer and ask if there are two different parts or not.


After reviewing the PN's that LoneStarFRC posted it appears that Amazon has the part a bit less expensive than most other places I quickly searched with the AC Delco PN.

Last edited by 8VETTE7; 08-06-2017 at 02:22 PM.
8VETTE7 is offline   Reply With Quote
The Following User Says Thank You to 8VETTE7 For This Useful Post:
Clayton59 (08-06-2017)
Old 08-06-2017, 03:23 PM   #8
LoneStarFRC
CF Senior Member
St. Jude Donor '08-'09-'10-'11-'12-'13-'14-'15-'16
 
LoneStarFRC's Avatar
 
Member Since: May 2001
Location: Don't judge anyone until you've walked a mile in their stupid, ugly shoes ~
Posts: 36,830
Thanked 178 Times in 170 Posts
Default

Quote:
Originally Posted by 8VETTE7 View Post
......

Unfortunately I cannot help you with sourcing the MFS as I have NOT had to do that yet. I did just do a quick look on a couple of parts places (Rock Auto, O'reilly) and they do NOT seem to make note of the telescopic column. That is not conclusive in my mind so I might call a local dealer and ask if there are two different parts or not......
ACD makes no distinction as well.....

http://parts-catalog.acdelco.com/cat...log_search.php

Click on "wipers/lamps/fuses" > then "Lighting Modules and Switches"

I've changed one out before and not nearly as difficult as I expected.
LoneStarFRC is offline   Reply With Quote
Old 08-07-2017, 08:50 PM   #9
mike venth
CF Senior Member
Support Corvetteforum!
 
Member Since: Feb 2013
Location: Riner Va
Posts: 351
Thanked 32 Times in 26 Posts
Default

Just went through this.....no head lights-was twisty thing on stalk switch..
Gene @cultrag parts 484-334-8833
Vettenuts (someone here will have number or goggle) new/used
John Llewellyn 865.604.0498 used
I went with a used one ($$$$) and it was like new.
mike v
mike venth is offline   Reply With Quote
Go Back   CorvetteForum - Chevrolet Corvette Forum Discussion >
Reload this Page
  • Left front Daytime Running Light /Turn signal
  •  
     
    Reply

    Related Topics
    Thread Thread Starter Forum Replies Last Post
    63 Front Parking Light / Turn signal Wfvtr17 C1 & C2 Corvettes 11 09-28-2017 02:42 PM
    Turn Signal/DRL Replacement mathia C5 Tech 20 09-09-2017 06:17 PM
    Turn signal help Rogers 07 C6 Corvette General Discussion 2 03-06-2017 02:04 PM
    65 Corvette turn signal/brake light left side problem urthegman C1 & C2 Corvettes 18 06-26-2016 07:26 AM
    HELP - Turn Sgnal / Daytime Running Light Dead rapido1 C6 Corvette General Discussion 9 12-18-2015 11:04 PM


    Thread Tools Search this Thread
    Search this Thread:

    Click for Advanced Search

    Posting Rules
    You may not post new threads
    You may not post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are Off
    Pingbacks are Off
    Refbacks are Off

    Forum Jump

    Sponsored Ads
    Vendor Directory

    All times are GMT -4. The time now is 07:16 AM.


    We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
     
    • Ask a Question
      Get answers from community experts
    Question Title:
    Description:
    Your question will be posted in: