C6 Corvette General Discussion General C6 Corvette Discussion not covered in Tech
Sponsored by:
Sponsored by:

replacing the stock nav/stereo unit

 
Old 06-23-2018, 10:21 AM
  #41  
Northshore3lt
Junior Member
 
Northshore3lt's Avatar
 
Member Since: Feb 2014
Location: Peoples Republic of Massachusetts
Posts: 36
Recieved 2 Likes on 1 Post
Default

Originally Posted by TorchRedFred View Post
For the C6 you can not re-use the factory mic. Also, not sure how he wired the steering wheel controls but my guess is he screwed something up. This is a very simple install with the correct wiring interface (Pac Audio RP5-GM11). If you use OnStar, it is suppose to mute the radio, not turn it off.
Thanks,I'll get them to fix it on Monday
Northshore3lt is offline  
Old 06-23-2018, 10:51 AM
  #42  
humvet
CF Senior Member
Support Corvetteforum!
 
humvet's Avatar
 
Member Since: Oct 2005
Location: Santa Clara, CA
Posts: 3,764
Recieved 7 Likes on 7 Posts
Default

Can we assume that HUD displays for XM, turn directions, etc. go away once the HU is replaced?
humvet is offline  
Old 06-23-2018, 11:05 AM
  #43  
EVRose
CF Senior Member
 
EVRose's Avatar
 
Member Since: Oct 2010
Location: Las Vegas NV
Posts: 14,367
Recieved 680 Likes on 552 Posts
Default

Originally Posted by humvet View Post
Can we assume that HUD displays for XM, turn directions, etc. go away once the HU is replaced?
Yes. No aftermarket hu is compatible with HUD.
EVRose is offline  
The following users liked this post:
humvet (06-23-2018)
Old 06-23-2018, 11:42 AM
  #44  
Matthewstorm
CF Senior Member
 
Matthewstorm's Avatar
 
Member Since: Oct 2017
Location: North Carolina
Posts: 1,120
Recieved 104 Likes on 93 Posts
Default

How is it you have Google Maps? Do you have CarPlay? I can only get Apple Maps on my new head unit.
Matthewstorm is offline  
Old 06-23-2018, 01:21 PM
  #45  
TorchRedFred
CF Senior Member
 
TorchRedFred's Avatar
 
Member Since: Jan 2017
Location: Morris County New Jersey
Posts: 2,208
Recieved 418 Likes on 359 Posts
Default

Originally Posted by Matthewstorm View Post
How is it you have Google Maps? Do you have CarPlay? I can only get Apple Maps on my new head unit.
If you have an Android phone, you would use Android Auto instead of Apple CarPlay. In that case, you get google maps.
TorchRedFred is offline  
Old 06-24-2018, 03:30 AM
  #46  
Vette_Fan
CF Senior Member
 
Vette_Fan's Avatar
 
Member Since: Jan 2005
Location: Hayward (Bay Area) CA
Posts: 3,588
Recieved 44 Likes on 38 Posts
Default

Originally Posted by dr_gallup View Post
Crutchfield says that does not fit, too deep. ???
Originally Posted by Matthewstorm View Post
Check out the new Pioneer AVIC W8400 NEX. It's a beast and looks like it's factory installed.
Why not get the 8200 NEX? What's 8400 got on it?


Originally Posted by Ken's 05 in Troy View Post
Also looking to upgrade radio/nav unit in my '05 . Really don't need nav -Google works fine from phone.Went on Crutchfield & Newegg sites to compare & Newegg $ are cheaper . Kenwood DDX9704S or DDX9903S same $. if anyone has those units how do you like them ? I'm just looking for better sound quality
Exactly my point. I didn't need a Nav either. But I was getting the 4200NEX from (Azmn, Crutchfield, Eby) for the same price as the 8200 from Newegg. And 8200 is miles ahead of 4200.

...Just saying...
Vette_Fan is offline  
Old 06-24-2018, 01:55 PM
  #47  
808_Vette
CF Senior Member
Support Corvetteforum!
 
808_Vette's Avatar
 
Member Since: Jun 2018
Location: HI&TX
Posts: 147
Recieved 11 Likes on 11 Posts
Default

Got a Sony XAV-V631BT (didn't need NAV) from Crutchfield and couldn't be happier. Sound is good and it connects to my iPhone very quickly. Its also a touchscreen and a digital media player with an input for a rear view camera if so desired. I don't recommend you have Crutchfield do the wiring harness for you because last I checked they were using butt connectors instead of soldering the connections. The install went perfect but I wish I watched the MGW C6 shifter and console removal video on youtube first because its way better than the instructions that Crutchfield provides. Good luck in your search.

808_Vette is offline  
Old 06-24-2018, 03:24 PM
  #48  
Jeff T.
CF Senior Member
 
Jeff T.'s Avatar
 
Member Since: Jul 2007
Location: Arlington Park Racecourse IL
Posts: 8,788
Recieved 570 Likes on 500 Posts
St. Jude Donor '13-'14-'15-'16-'17-'18-'19
Default

Apple CarPlay or Android Auto, I assume using either of them uses you cell data for the Nav??
Jeff T. is offline  
Old 06-24-2018, 06:51 PM
  #49  
TorchRedFred
CF Senior Member
 
TorchRedFred's Avatar
 
Member Since: Jan 2017
Location: Morris County New Jersey
Posts: 2,208
Recieved 418 Likes on 359 Posts
Default

Originally Posted by Jeff T. View Post
Apple CarPlay or Android Auto, I assume using either of them uses you cell data for the Nav??
Yes. Either your head unit has built in navigation or you use your phone nav through the head unit via Apple CarPlay and/or Android Auto.
TorchRedFred is offline  
The following users liked this post:
Jeff T. (06-25-2018)
Old 06-24-2018, 09:01 PM
  #50  
Oh Boy
CF Senior Member
 
Oh Boy's Avatar
 
Member Since: Sep 2017
Location: New York
Posts: 1,111
Recieved 169 Likes on 144 Posts
Default

Originally Posted by TorchRedFred View Post
For the C6 you can not re-use the factory mic.
Yes you can. I had it done on my '13 GS with a Kenwood. Double D mods figured out how to do this a couple of years ago and my installer called him and he told him how to do it. Unfortunately I don't know what he did and I since took out the Kenwood and went back to the Bose/Nav head unit.

Oh Boy is offline  
Old 06-24-2018, 09:06 PM
  #51  
RobLo
CF Senior Member
Support Corvetteforum!
 
RobLo's Avatar
 
Member Since: May 2010
Location: Long Island New York
Posts: 1,543
Recieved 90 Likes on 71 Posts
Default

Originally Posted by Oh Boy View Post
since took out the Kenwood and went back to the Bose/Nav head unit.
Just curious, why?
RobLo is offline  
Old 06-24-2018, 09:30 PM
  #52  
TorchRedFred
CF Senior Member
 
TorchRedFred's Avatar
 
Member Since: Jan 2017
Location: Morris County New Jersey
Posts: 2,208
Recieved 418 Likes on 359 Posts
Default

Originally Posted by Oh Boy View Post
Yes you can. I had it done on my '13 GS with a Kenwood. Double D mods figured out how to do this a couple of years ago and my installer called him and he told him how to do it. Unfortunately I don't know what he did and I since took out the Kenwood and went back to the Bose/Nav head unit.
Well I'm not going to say you are wrong, but without more info your post is not real helpful. And speaking of Double D mods, I just did a search and found about a dozen posts of his where he states that you need to use the mic supplied with the new head unit. If he found a way to re-use the mic, he wasn't sharing it with all of us.

Post #16 in this thread for example,
https://www.corvetteforum.com/forums...le-d-mods.html
TorchRedFred is offline  
Old 06-24-2018, 09:42 PM
  #53  
Oh Boy
CF Senior Member
 
Oh Boy's Avatar
 
Member Since: Sep 2017
Location: New York
Posts: 1,111
Recieved 169 Likes on 144 Posts
Default

Originally Posted by RobLo View Post
Just curious, why?
In my opinion the Bose amp and speakers definitely clash with Kenwood. The Bose uses difference staging specs to achieve their sound and I did not like the sound the Bose/Kenwood combo produced. Too overdriven and even with the 13 band EQ the Kenwood comes with I could never get a good clean tight sound. Either too tinny or too muddy. After one week I went back to the original Bose/Nav head unit and never regretted it.

Last edited by Oh Boy; 06-24-2018 at 09:52 PM.
Oh Boy is offline  
Old 06-24-2018, 09:50 PM
  #54  
Oh Boy
CF Senior Member
 
Oh Boy's Avatar
 
Member Since: Sep 2017
Location: New York
Posts: 1,111
Recieved 169 Likes on 144 Posts
Default

Originally Posted by TorchRedFred View Post
Well I'm not going to say you are wrong, but without more info your post is not real helpful. And speaking of Double D mods, I just did a search and found about a dozen posts of his where he states that you need to use the mic supplied with the new head unit. If he found a way to re-use the mic, he wasn't sharing it with all of us.

Post #16 in this thread for example,
https://www.corvetteforum.com/forums...le-d-mods.html
Yea unfortunately I don't have info and for all I know my installer could have duped me and hid the mic somewhere and told me the factory one was still working. I only had the Kenwood in for a week and don't remember much.
But he was on the phone with DD and they were talking about the mic. I do know for a fact thou other people have had it done in their Pontiac G-8's with Onstar.

Last edited by Oh Boy; 06-24-2018 at 09:53 PM.
Oh Boy is offline  
Old 06-24-2018, 10:03 PM
  #55  
TorchRedFred
CF Senior Member
 
TorchRedFred's Avatar
 
Member Since: Jan 2017
Location: Morris County New Jersey
Posts: 2,208
Recieved 418 Likes on 359 Posts
Default

Originally Posted by Oh Boy View Post
In my opinion the Bose amp and speakers definitely clash with Kenwood. The Bose uses difference staging specs to achieve their sound and I did not like the sound the Bose/Kenwood combo produced. Too overdriven and even with the 13 band EQ the Kenwood comes with I could never get a good clean tight sound. Either too tinny or too muddy. After one week I went back to the original Bose/Nav head unit and never regretted it.
Are you sure your installer installed your head unit properly? The only time I ever hear someone say their aftermarket head unit sounded worse than the factory head unit, is when there was an issue with the install or the wrong wiring interface was used. Just my 2 cents.
TorchRedFred is offline  
Old 06-24-2018, 11:00 PM
  #56  
Oh Boy
CF Senior Member
 
Oh Boy's Avatar
 
Member Since: Sep 2017
Location: New York
Posts: 1,111
Recieved 169 Likes on 144 Posts
Default

Originally Posted by TorchRedFred View Post
Are you sure your installer installed your head unit properly? The only time I ever hear someone say their aftermarket head unit sounded worse than the factory head unit, is when there was an issue with the install or the wrong wiring interface was used. Just my 2 cents.
Yup it was done correctly. RP5-GM-11 plugged in the amplified port. Bose uses specific specs and frequencies to match their head units to their amps and speakers to achieve the sound staging they get. I believe the Kenwood amp and the Bose amp causes a imbalance in the pairing. I can't speak for other aftermarket head units as the Kenwoods are the only units I have ever used or listened to. Believe me I really wanted to like it, it just didn't do it for me personally. I do know sound as I have played a instrument for most of my life. BTW I just put a new Kenwood in my DD 2000 Deville and the sound difference was dramatic (post #11 in this thread) but I have no Bose or premium stereo in my Deville so the Kenwood was able to do it's thing on it's own merits.

Last edited by Oh Boy; 06-24-2018 at 11:10 PM.
Oh Boy is offline  
Old 06-24-2018, 11:14 PM
  #57  
Matthewstorm
CF Senior Member
 
Matthewstorm's Avatar
 
Member Since: Oct 2017
Location: North Carolina
Posts: 1,120
Recieved 104 Likes on 93 Posts
Default

Well today halfway thru a road trip I lost my satellite radio. It's not even an option anymore on the screen. Brand new Pioneer head. Also got an onscreen message saying parking garage brake sensor was disconnected, but I have no idea what that's for.
Matthewstorm is offline  
Old 06-25-2018, 07:39 AM
  #58  
Northshore3lt
Junior Member
 
Northshore3lt's Avatar
 
Member Since: Feb 2014
Location: Peoples Republic of Massachusetts
Posts: 36
Recieved 2 Likes on 1 Post
Default

Going back to Best Buy this morning to fix the Microphone issue,I'm assuming easy fix.
I am more concerned/annoyed with the issue of pressing phone icon on steering wheel,which causes new unit to lose power,and reboot(old menu voice plays over speakers",please press OnStarbutton",I do not use OnStar
PAC harness was used,other steering wheel controls work fine.
Any suggestions to discuss with tech?
Northshore3lt is offline  
Old 06-25-2018, 02:32 PM
  #59  
TorchRedFred
CF Senior Member
 
TorchRedFred's Avatar
 
Member Since: Jan 2017
Location: Morris County New Jersey
Posts: 2,208
Recieved 418 Likes on 359 Posts
Default

Originally Posted by Northshore3lt View Post
Going back to Best Buy this morning to fix the Microphone issue,I'm assuming easy fix.
I am more concerned/annoyed with the issue of pressing phone icon on steering wheel,which causes new unit to lose power,and reboot(old menu voice plays over speakers",please press OnStarbutton",I do not use OnStar
PAC harness was used,other steering wheel controls work fine.
Any suggestions to discuss with tech?
Any updates? I think it's just the way he wired it (OnStar issue). It should be an easy fix for both issues.
TorchRedFred is offline  
Old 06-25-2018, 02:49 PM
  #60  
EVRose
CF Senior Member
 
EVRose's Avatar
 
Member Since: Oct 2010
Location: Las Vegas NV
Posts: 14,367
Recieved 680 Likes on 552 Posts
Default

Originally Posted by TorchRedFred View Post
Well I'm not going to say you are wrong, but without more info your post is not real helpful. And speaking of Double D mods, I just did a search and found about a dozen posts of his where he states that you need to use the mic supplied with the new head unit. If he found a way to re-use the mic, he wasn't sharing it with all of us.

Post #16 in this thread for example,
https://www.corvetteforum.com/forums...le-d-mods.html
One way to do it is to cut the microphone off the end of the Kenwood mic and run the wire up to the factory microphone. Cut the factory connector off and solder the Kenwood wire to the factory mic. You would lose OnStar doing this but everything on the new HU that requires voice should work.
This is the factory microphone.


There was an upgrade to the microphone by GM later on but it still has the same connector on it.

Last edited by EVRose; 06-25-2018 at 02:52 PM.
EVRose is offline  

Thread Tools
Search this Thread
Quick Reply: replacing the stock nav/stereo unit


Sponsored Ads
Vendor Directory

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: