XM radio No signal - CorvetteForum - Chevrolet Corvette Forum Discussion

Notices
C6 Corvette General Discussion General C6 Corvette Discussion not covered in Tech
Sponsored by:
Sponsored by:

XM radio No signal

Old 10-12-2018, 11:37 AM
  #1  
mittens
CF Senior Member
Thread Starter
 
mittens's Avatar
 
Member Since: Nov 2005
Location: Huntsville Alabama
Posts: 2,032
Thanked 59 Times in 46 Posts
Default XM radio No signal

Picked up a C6 again, and it has Nav and XM... I am a XM person and tried to convert my service from my C7 to it. all kinds of signals sent to car and such.... radio on channel 1 says no signal.... and no sound...

So from my googling and searches here (all really old threads) only things I am coming up with is check connections in back to XM recever.. I did. uninstalled it and put it back with all connections..... and still n0thing.

also from my understanding the car has a XM antenna in each side mirror. not sure how they would go bad.....

anyone else have any hints, tips tricks? would be great p to get it working...
mittens is offline  
Old 10-12-2018, 01:08 PM
  #2  
RicK T
CF Senior Member
 
RicK T's Avatar
 
Member Since: Sep 2005
Location: Las Vegas, Nevada
Posts: 20,201
Thanked 470 Times in 388 Posts
Default

You may have seen this already, if not, look at the various ideas, might help, and check if the car has a PAL unit as that might be the problem:

https://www.corvetteforum.com/forums...howing-up.html
RicK T is offline  
The Following User Says Thank You to RicK T For This Useful Post:
corvettezman (11-06-2018)
Old 10-12-2018, 02:02 PM
  #3  
mittens
CF Senior Member
Thread Starter
 
mittens's Avatar
 
Member Since: Nov 2005
Location: Huntsville Alabama
Posts: 2,032
Thanked 59 Times in 46 Posts
Default

thanks but that thread seem to be more the head unit not seeing the Xm module

I can select the XM 1 and XM2, just no signal from that part/
mittens is offline  
Old 10-12-2018, 02:02 PM
  #4  
Richard F
CF Senior Member
 
Richard F's Avatar
 
Member Since: Aug 2014
Location: Palestine...East Texas Piney Woods Tx
Posts: 490
Thanked 85 Times in 59 Posts
Default

Make sure that they have the correct radio serial number information to turn it on. You might have given them a number out of place or letter wrong in the serial number.
Richard F is offline  
Old 10-15-2018, 04:52 PM
  #5  
Legalice
CF Member
Support Corvetteforum!
 
Legalice's Avatar
 
Member Since: Dec 2017
Location: Versailles Kentucky
Posts: 54
Thanked 6 Times in 5 Posts
Default

What year is your car?

I bought a 2005 in February with factory system. I had to upgrade the XM antenna to a new version to receive the signal and keep it. Otherwise, every time I turned off the car I had to have the signal re-sent. I ended up buying a new head unit anyway and had the antenna upgraded at the same time.

There were things about this posted on this forum but I don't have it at hand at the moment.

Doing a search on XM problems in C6 Corvette also brought up info as I recall.

Newer C6 had the newer antenna but I don't remember when it changed.

Last edited by Legalice; 10-15-2018 at 04:54 PM.
Legalice is offline  
Old 10-15-2018, 05:51 PM
  #6  
Dano523
CF Senior Member
 
Member Since: Dec 2013
Posts: 6,883
Thanks: 0
Thanked 978 Times in 795 Posts
Default

Yep, what year of car?

Up to/just before the 2010 models, since sirus bought out XM radio in 2008, the OEM XM module in the car has to be reprogrammed to receiver the sirus signal.
If you bought the used car from a GM dealer, they would pull the module and send it to Sirus to be upgraded, and the dealer would give you free 6 month of sirus to make sure it was working/get you hooked on sirus to begin with.

If the module was not updated, and you need it updated now, and it cheaper to just buy the sir-gm1 module to swap out with the other OEM module that may need to be reprogrammed instead. If you check around, can find them for around $50 new, while the last time I check, sirus wanted something like $80 to reprogram the old xm module to receive there signal.

The sir-gm1 module kit will come with the needed pigtails so you can pull the old module, install the new one right back in the same area, and use the pig tails that comes with it to plug right back in the factory wiring harness.


One the module is isnstalled, then switch to XM to get the serial number from the new module, and that is the one that you need use for the account.


If the module is upgraded/programmed correctly to start with, then time to start checking to make sure that everything is in place. Hence could be that someone disconnected the module, has a Pal in line or swapped for for the XM module, or something happened to the mirrors, and they where replaced with ones that don't have the XM antennas.
Dano523 is offline  
Old 10-16-2018, 12:20 AM
  #7  
mittens
CF Senior Member
Thread Starter
 
mittens's Avatar
 
Member Since: Nov 2005
Location: Huntsville Alabama
Posts: 2,032
Thanked 59 Times in 46 Posts
Default

Car is a 2007, I have checked all connections. So this reprogramming my be the problem. So how can I get that checked?
mittens is offline  
Old 10-16-2018, 04:11 AM
  #8  
Gator6977
CF Member
 
Gator6977's Avatar
 
Member Since: Apr 2018
Location: KS
Posts: 84
Thanked 16 Times in 14 Posts
2018 C6 of Year Finalist
Default

I'm assuming you've contacted SXM about the issue? They can and will send a refresh signal. If after you make the change, don't have the car to where it can receive the SXM signal, with the radio on, within half an hour, it will go stale and not work. I had to do this with my 11' Acadia when I activated it. My 08' Vette didn't have the same issue as I ran outside and backed it out of the garage as soon as I finished switching everything over online.
Gator6977 is offline  
Old 10-16-2018, 11:02 AM
  #9  
Reckedhim
CF Member
 
Member Since: Mar 2018
Location: Wisconsin
Posts: 74
Thanks: 0
Thanked 10 Times in 10 Posts
Default

Did you look up your radio number by Vin? If so, you may need to get the actual radio number from your radio and enter it as the radio id on the Sirius site since it may have been upgraded at some point.
Reckedhim is online now  
Old 10-16-2018, 11:37 AM
  #10  
mittens
CF Senior Member
Thread Starter
 
mittens's Avatar
 
Member Since: Nov 2005
Location: Huntsville Alabama
Posts: 2,032
Thanked 59 Times in 46 Posts
Default

The head unit shows the Radios number. I have double checked with the XM people and they have the right number.... also they say even with the wrong number I should hear the adds on chanel 1... I don't hear anything. they have resent many many many refresh signals to it as well, went through all the trouble shooting they can. Its a CAR problem.

So How can I get a factory tuner to swap out and see? what year was the change made? just buy a used one? and swap it and then register the new number and my factory antennas will work? or where is a place to send my tuner to have it upgraded?
mittens is offline  
Old 10-16-2018, 09:18 PM
  #11  
Dano523
CF Senior Member
 
Member Since: Dec 2013
Posts: 6,883
Thanks: 0
Thanked 978 Times in 795 Posts
Default

Originally Posted by mittens View Post

So How can I get a factory tuner to swap out and see? what year was the change made? just buy a used one? and swap it and then register the new number and my factory antennas will work? or where is a place to send my tuner to have it upgraded?

Would help to know if coupe or convertable, but here are the loctation that the modules are located/

On covertible, it will be behind the water fall cover between the seats.


On a coupe, it will over the driver rear tire wheel well behind the carpet.


To get it updated to receiver the sirus signal is still programmed for XM radio instead, the unit has to be back to sirius, and they will want money to reprogram it. So give them a call, go over the module number on the unit, and check to see if they have any record of it being upgraded (either by its vin number or the cars vin number). Again, if you buy the used car from GM, then will pull the unit, send it to siruis to be upgraded for free, then when they get it back, will install it back in the car, and dealer will set up a 6 month account for free, since they need such for testing to make sure it working. If you have not figure this out yet, XM first gave GM the modules for free to push the service, then when siruis bought out XM, siruis is the one that supplied the XM modules to GM for free next (including upgrading all the older XM modules as well).

IIRQ, sirus wants around $80 to upgrade the older XM radio modules if you send it in yourself, and then you still have shipping back and forth on your dime.

As for the Sirus SIR/GM1 kits, they are harder to find now. Hence it not just the module that you need, but the jumper pigtails that comes with the kits as well. Hence the only ones that I'm finding are the two on ebay, and they do not come with the needed jumper pigtails to being able to connect it to the factory wiring connectors.

Regarding the oem XM C6 modules for sale on the cheap (GM22729350) that may be sirus programmed , I'm not seeing any that show the Sirus update sticker/writing on the labels on them, so could be in the same boat since the ones that I seeing are out of pre-2010 cars, without the sirus update as well.
Dano523 is offline  
Old 10-17-2018, 09:58 AM
  #12  
mittens
CF Senior Member
Thread Starter
 
mittens's Avatar
 
Member Since: Nov 2005
Location: Huntsville Alabama
Posts: 2,032
Thanked 59 Times in 46 Posts
Default

Car is a Z06, Coupe, Not sure why my Sig on this forum never shows, and I have all the boxes checked... I am not a newb to forms... just this forum never shows sigs ha.

as I stated I have pull the unit, checked all connection sand reinstalled.... still nothing. I will have to give someone a call and see if anyone will take my 80 bucks... I would pay that to have it fixed but when I was on the phone with them many times it was always its a dealship/car issue not we can fix it for you.

Last edited by mittens; 10-17-2018 at 09:58 AM.
mittens is offline  
Old 10-17-2018, 07:31 PM
  #13  
Dano523
CF Senior Member
 
Member Since: Dec 2013
Posts: 6,883
Thanks: 0
Thanked 978 Times in 795 Posts
Default

Originally Posted by mittens View Post
Car is a Z06, Coupe, Not sure why my Sig on this forum never shows, and I have all the boxes checked... I am not a newb to forms... just this forum never shows sigs ha.

as I stated I have pull the unit, checked all connection sand reinstalled.... still nothing. I will have to give someone a call and see if anyone will take my 80 bucks... I would pay that to have it fixed but when I was on the phone with them many times it was always its a dealship/car issue not we can fix it for you.
Go talk to a GM dealer and work it out with them to send it back to Sirus to be reprogrammed (from XM radio, to Sirius). Something may have changed with GM now able to flash the module still in the car, but as of last year, they still have to pull them to send them to sirius to be reprogrammed, then would reinstall them back in the car once they got it back. If you sweet talk the dealer, may end up hooking you up with the free 6 months subscription as well.

Short of that, they you trying to find a Sir-gm1 kit with the needed jumper pigtails, so you can swap it out with the XM radio programed OEM module in the car or another XM module that does have the sirus update on it so you can install it instead. Again, the glitch here, of the $40 used XM modules (GM22729350 I do see up for sale, none of them are showing signs of the siruis updates, so would bank from 2009 cars or older, and the reason that they are going so cheap for the $40 isntead.
Dano523 is offline  
Old 10-17-2018, 08:38 PM
  #14  
mittens
CF Senior Member
Thread Starter
 
mittens's Avatar
 
Member Since: Nov 2005
Location: Huntsville Alabama
Posts: 2,032
Thanked 59 Times in 46 Posts
Default

So my moms 2007 has never had a update and her XM works fine?

have a friend with one same thing?
mittens is offline  
Old 10-18-2018, 11:25 PM
  #15  
Dano523
CF Senior Member
 
Member Since: Dec 2013
Posts: 6,883
Thanks: 0
Thanked 978 Times in 795 Posts
Default

Originally Posted by mittens View Post
So my moms 2007 has never had a update and her XM works fine?

have a friend with one same thing?
read,
https://en.wikipedia.org/wiki/Sirius_XM_Satellite_Radio

And when XM radio became sirus XM, the older OEM XM radio modules had to be programmed upgraded to receiver the Sirus signal.

If she has a 2007 Vet, then take a look at the XM module and you will see the sirus upgrade writing on the label. So by 2009, most of the module on the car where already firmware upgraded to receiver the sirus signal before the car left the factory, but there was still a few that needed the upgrade, and was caught/corrected before the cars where sold. On the older cars , the upgrade was done during any service if you lost the signal , to make sure it was still able to receiver the Sirus signal.

As by 2010, all the XM modules that GM received from sirius XM to install in the cars (for free I should add), where already programmed correctly.
Hence GM did not pay for the XM modules, but instead got a kick back to corparating the system in the car. This is the reason that GM can not only send the modules back to Siruis to be reprogrammed so they work in the GM cars, but will set up the car with a free 6 months subscription when you buy a used vet from a GM dealer as well.

So 2005 to around 2007 that someone let the 6 month free xm radio subscription run out, module was never reprogrammed. 2007 sold in say 2008 to up around late 2009 if the module was not already factor programmed for the different Sirius signal, the dealer would pull the unit, and swap in one that was programmed correctly (will not show up on a GM service history).

Now a days since the dealers are not sitting on extra programmed modules, if GM dealer sells one of the older cars that the module has not been upgraded (since they don't have spare upgraded modules), they just pull the XM module and send it to Siruis to be upgraded, then put it back in the car when they get it back. Even here, its a 50/50 chance if the gm service history will show up for XM module update, since the money for such comes from Sirius, and not GM instead.

So if your mom has a C6 2007 with working XM,, then pull her module and install it in your car for testing. If its your module that has be be upgraded, then her subscription/module will work in your car then it your module the problem. Hence each module has it own serial number that Sirius uses from the subscription, and with her module in your car, your head unit will display that serial number.

Also, since you know that her system works fine with her module, and you have a subscription on your module, then if she can not receiver the XM signal in her car with you module installed, its your XM module that needs to be updated.

Last edited by Dano523; 10-18-2018 at 11:31 PM.
Dano523 is offline  
Old 10-19-2018, 09:56 AM
  #16  
mittens
CF Senior Member
Thread Starter
 
mittens's Avatar
 
Member Since: Nov 2005
Location: Huntsville Alabama
Posts: 2,032
Thanked 59 Times in 46 Posts
Default

All that wou;ldl be great to test except the modules have to be modded to work with another car. as stated before in other threads you have to send them off to change the vin, or radio id, or open them up and clip the first top lef of a 8 leg chip to bypass this. so I can tjust pull hers and test.
mittens is offline  
Old 10-19-2018, 07:25 PM
  #17  
Dano523
CF Senior Member
 
Member Since: Dec 2013
Posts: 6,883
Thanks: 0
Thanked 978 Times in 795 Posts
Default

XM module is not vin number specific.
Each module will have its own serial number and when installed, it the one that will display on the radio that you use to activate the account. Hence siruis will over the air turn the module on with account, and when the account is closed, will send the kill comand for that serial number to shut the receive module back to no subscription state.
Note, when GM gives you the free 6 months account, they just connect to the OBDII port to communicate with the module and activate it for a 6 months period via the sps flashing. Hence GM ESC issues the Dealers a special file code # to use on the car to SPS flash the XM module for the free 6 months subscription that is not tied to any one to start with. I have yet to see the that SPS file # in the wild, but had seen the one for the BMW's to do the same instead.


The VCIM's are vin number specific instead. So if you swap a later one from other car to get blue tooth (which is part of the VCIM in the car) then pull the serial number off it, since you will need to give that to On star, instead of them just using your car's vin number instead.

Last edited by Dano523; 10-19-2018 at 07:28 PM.
Dano523 is offline  
Old 10-19-2018, 08:12 PM
  #18  
RobLo
CF Senior Member
Support Corvetteforum!
 
RobLo's Avatar
 
Member Since: May 2010
Location: Long Island New York
Posts: 1,498
Thanked 77 Times in 62 Posts
Default

Not sure if this will help but...bought my '05 back in 2010, it had the XM module and the "wart" on the roof. Original owner never subscribed to XM, I wanted it and contacted XM. The told me I had to upgrade the module to receive a digital signal, it had to be done by a dealer. I asked price, they said the had a special going on, $40 for the upgrade. I thought, "what a deal" and made an appointment with the dealer. What XM didn't tell me, $40 for the upgrade but I had to sign up for a 1 year subscription, total cost was $220, oh well! Still subscribe to XM and have installed the PAL module from Ray Kawal, everything plays nice together and works well. Good luck!
RobLo is offline  
Old 11-01-2018, 10:52 AM
  #19  
mittens
CF Senior Member
Thread Starter
 
mittens's Avatar
 
Member Since: Nov 2005
Location: Huntsville Alabama
Posts: 2,032
Thanked 59 Times in 46 Posts
Default

Ok guys, after some research its was either a bad module ot the anntennas.. was hoping bad module,

Scooped used one off ebay for 20 shipped. plugged it in on Accery mode, and it worked! I had the preview channel.

Turned car off removed, took it apart to Clipped the single pin and stop it form Theft locking once I powered up the whole car/BCM. this thread will show you how https://www.corvetteforum.com/forums...-yourself.html

Put it back together, plugged it in and BAM works on ACCecory mode, and with car running.. then I installed it in the tray tucked away like factory and put carpet back. Called XM they swapped my service to the new radio ID.

XM now working...

wanted to close out the thread for the next time someone else is searching.
mittens is offline  
The Following 3 Users Say Thank You to mittens For This Useful Post:
ErikR (11-01-2018), Landru (11-01-2018), Vet Interested (11-01-2018)
Old 11-02-2018, 12:44 PM
  #20  
mittens
CF Senior Member
Thread Starter
 
mittens's Avatar
 
Member Since: Nov 2005
Location: Huntsville Alabama
Posts: 2,032
Thanked 59 Times in 46 Posts
Default

Well spoke to soon. Everything works, but every time I **** car down and start it back up it forgets the channels I saved and starts at the preview channel... and when I click say the first channel saved (it still shows the correct favorite on the button, it changes to the factory default for that button and then the button label changes..
mittens is offline  

Thread Tools
Search this Thread
Sponsored Ads
Vendor Directory

Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: