Hatch not Popping up - CorvetteForum - Chevrolet Corvette Forum Discussion

Notices
C6 Corvette General Discussion General C6 Corvette Discussion not covered in Tech
Sponsored by:
Sponsored by:

Hatch not Popping up

Old 12-04-2018, 11:55 PM
  #1  
rolaszek1986
Junior Member
Thread Starter
 
Member Since: Oct 2016
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default Hatch not Popping up

2008 Z51 hatch not popping up. Solinoid clicks. Lock releases, just not opening enough to get fingers in to lift. Occurs when using both remote and console button.
Any ideas. Any help appreciated.
rolaszek1986 is offline  
Old 12-05-2018, 12:33 AM
  #2  
Cherokee Nation
CF Senior Member
 
Cherokee Nation's Avatar
 
Member Since: Jan 2008
Location: corpus christi Texas
Posts: 5,801
Thanked 184 Times in 177 Posts
Default

Replace your struts.
Cherokee Nation is online now  
Old 12-05-2018, 12:40 AM
  #3  
Vette_DD
CF Senior Member
Support Corvetteforum!
 
Vette_DD's Avatar
 
Member Since: May 2004
Posts: 70,963
Thanked 536 Times in 418 Posts
Default

Had the same problem on my 012, but didn't know how to fix it. Only was doing it about the last 2 or 3 months before I traded the car. Wish I had known the solution.
Vette_DD is offline  
Old 12-05-2018, 08:52 AM
  #4  
C6ToGo
CF Senior Member
 
C6ToGo's Avatar
 
Member Since: Dec 2006
Location: Pearland / Houston Tx
Posts: 2,072
Thanks: 0
Thanked 190 Times in 150 Posts
Default

Spraying some lube down in the lock has worked for me a couple times.
C6ToGo is offline  
Old 12-05-2018, 08:59 AM
  #5  
Mayor111
CF Senior Member
 
Mayor111's Avatar
 
Member Since: Oct 2016
Location: Easton PA
Posts: 1,264
Thanked 352 Times in 228 Posts
Default

Originally Posted by Cherokee Nation View Post
Replace your struts.


Originally Posted by C6ToGo View Post
Spraying some lube down in the lock has worked for me a couple times.


Both will fix the problem - do the lube spray in the lock area first - that usually does the trick - if not, then struts.
Mayor111 is offline  
Old 12-05-2018, 10:31 AM
  #6  
TomdaToolman
CF Senior Member
Support Corvetteforum!
 
TomdaToolman's Avatar
 
Member Since: May 2017
Location: Friday Harbor WA
Posts: 679
Thanked 55 Times in 50 Posts
Default

Originally Posted by rolaszek1986 View Post
2008 Z51 hatch not popping up. Solinoid clicks. Lock releases, just not opening enough to get fingers in to lift. Occurs when using both remote and console button.
Any ideas. Any help appreciated.
Lubing the hatch seal has helped with my 2012, but am going to replace the struts as well, as I think it's time!

Last edited by TomdaToolman; 12-05-2018 at 10:32 AM.
TomdaToolman is offline  


Thread Tools
Search this Thread
Sponsored Ads
Vendor Directory

Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: