clicking noise from behind the radio - CorvetteForum - Chevrolet Corvette Forum Discussion

Notices
C6 Corvette General Discussion General C6 Corvette Discussion not covered in Tech
Sponsored by:
Sponsored by:

clicking noise from behind the radio

Old 12-10-2018, 04:59 PM
  #1  
cgladish
CF Senior Member
Thread Starter
 
cgladish's Avatar
 
Member Since: Jan 2017
Location: CONCORD CA.
Posts: 594
Thanked 88 Times in 76 Posts
Default clicking noise from behind the radio

I've an issue off and on for a year or so. seems more 'on' lately though ( 2009 base, 3LT, 6 spd ).
I have a clicking noise coming behind the center stack / radio.
sounds like a relay that is cycling. it cycle for a second or so, then be quiet, then cycle again.
it'll happen whether car is on or off.
everything seems to be working fine. I will occasionally get the 'no fob detected' prompt, more so in the last few days.
I'm the second owner & as far as I know, it's all stock.
any thoughts?
cgladish is offline  
Old 12-12-2018, 12:52 AM
  #2  
vetteJPJ
CF Member
 
Member Since: Aug 2018
Posts: 92
Thanked 9 Times in 9 Posts
Default

I've heard the same noise but only when turning off car. It stops in a few seconds. I have an 06 base with Kenwood headunit. It was present with original factory unit too. That would eliminate the headunit as a source. It doesn't bother me, but it is noticiable.
vetteJPJ is offline  
Old 12-12-2018, 11:21 AM
  #3  
cgladish
CF Senior Member
Thread Starter
 
cgladish's Avatar
 
Member Since: Jan 2017
Location: CONCORD CA.
Posts: 594
Thanked 88 Times in 76 Posts
Default

since I was getting the 'no key fob" prompt, I changed the battery. that seemed to clear that issue.
I'm still getting the relay clicking noise. it doesn't appear to be affecting anything, but very noticeable.
cgladish is offline  
Old 12-12-2018, 11:26 AM
  #4  
z06clif
CF Senior Member
 
z06clif's Avatar
 
Member Since: Jun 2008
Location: Mt. Sinai NY
Posts: 4,244
Thanked 147 Times in 131 Posts
Default

Could this noise have something to do with the Nav unit reading the Nav CD?

Clif
z06clif is offline  
Old 12-12-2018, 11:34 AM
  #5  
marinablu67
CF Senior Member
 
marinablu67's Avatar
 
Member Since: Sep 2016
Location: Tampa Bay, Florida
Posts: 522
Thanked 60 Times in 52 Posts
Default

What you maybe hearing is a stuck stepper motor, that opens and closes the ventilation doors for the climate control system. I have an older Chevy Silverado PU with the same system, and one door is stuck, and the motor cycles itself off and on, which is the clicking noise.

Last edited by marinablu67; 12-12-2018 at 11:35 AM.
marinablu67 is offline  
Old 12-12-2018, 11:49 AM
  #6  
cgladish
CF Senior Member
Thread Starter
 
cgladish's Avatar
 
Member Since: Jan 2017
Location: CONCORD CA.
Posts: 594
Thanked 88 Times in 76 Posts
Default

car does not have a nav system. car is all stock. as mentioned previously, everything is working correctly
(radio, HVAC, all other electronics ). it has the same sound as when you press the start button, and it can't find the fob.
even after the car starts, while running, or even after the car is off, it'll be clicking.
I guess I'll have to wait it out until some more happens.
cgladish is offline  
Old 12-12-2018, 08:13 PM
  #7  
dbritey
CF Member
 
dbritey's Avatar
 
Member Since: Dec 2010
Location: MA
Posts: 57
Thanked 1 Time in 1 Post
Default

My 05 has done that since the day I brought her home from the dealer lot. Everything functions as it should. Never had an issue and have 54k miles now. I just think of it as one of her harmless quirks!
dbritey is offline  
Old 12-13-2018, 10:36 AM
  #8  
cgladish
CF Senior Member
Thread Starter
 
cgladish's Avatar
 
Member Since: Jan 2017
Location: CONCORD CA.
Posts: 594
Thanked 88 Times in 76 Posts
Default

i don't mind harmless quirks ( I.e. squeaky top, hot trans tunnel ), and this one I've lived with for several months now.
but if it's a relay, then at some point this constant cycling will shorten its life span. I guess that's when i'll find out what was causing the noise.
until then, motor on!
cgladish is offline  
Old 12-15-2018, 03:42 AM
  #9  
BackInBlack05
CF Senior Member
 
Member Since: Jul 2012
Location: San Jose CA
Posts: 323
Thanks: 0
Thanked 10 Times in 9 Posts
Default

I had my fob sensor thing replaced. The new one clicks when it challenges the fob. I never noticed it prior.
BackInBlack05 is online now  
Old 12-15-2018, 09:57 AM
  #10  
449er
CF Senior Member
 
449er's Avatar
 
Member Since: Apr 2016
Location: Pittsburgh
Posts: 2,043
Thanked 252 Times in 214 Posts
Default

With an automatic car, you will hear the relays clicking when you put your foot on the brake to start the car, but beyond that, I don't know
449er is offline  
Old 12-15-2018, 10:07 AM
  #11  
bonnell
CF Senior Member
 
bonnell's Avatar
 
Member Since: Feb 2004
Location: Loudon/Lake Mary Tennessee/Florida
Posts: 2,762
Thanked 32 Times in 29 Posts
Default

I travel from Tennessee to Florida a few times per year. After Iíve been on the road for a while I hear this noise - like a relay cycling - when I let off of the gas on the highway.
bonnell is offline  
Old 12-17-2018, 11:01 AM
  #12  
cgladish
CF Senior Member
Thread Starter
 
cgladish's Avatar
 
Member Since: Jan 2017
Location: CONCORD CA.
Posts: 594
Thanked 88 Times in 76 Posts
Default

further up date, the relay has started to cycle in time with the wipers. if I hit the brakes, the cycling stops. let off of the brakes and it starts cycling again.
prior to recent activity, you could heard the brake relay click once when apply the brakes, then again when you let off.
(I've heard this relay and feel that is the one coming from passenger foot well.)
this current issue still seems to be coming from behind the center stack.
sometimes now, the relay will cycle even if the car is off.
still, nothing seems to be effected and everything is running fine.
cgladish is offline  
Old 12-17-2018, 11:13 AM
  #13  
PCMusicGuy
CF Senior Member
 
Member Since: Apr 2007
Location: Houston TX
Posts: 3,193
Thanked 92 Times in 71 Posts
Default

I've heard something coming from behind/under the dash for a long time but it suddenly stopped one day. It sounded kinda like a relay where it would go tik-a-tik-a-tik-a-tik-a and then stop. This was only heard a few minutes after starting up the car. I haven't heard it in a while but everything is still working @ 140k+ miles.
PCMusicGuy is online now  
Old 12-17-2018, 11:27 AM
  #14  
LMB-Z
CF Senior Member
 
LMB-Z's Avatar
 
Member Since: Jan 2006
Location: Texarkana Texas
Posts: 6,495
Thanked 405 Times in 366 Posts
Default

Remove the console and track down the "cliking" noise. Unplug the stereo if needed. Martians may be tracking your every move. I would want to know rather than wait for something to happen. Takes about 10 minutes or less to remove the console.
LMB-Z is offline  
Old 12-17-2018, 11:33 AM
  #15  
cgladish
CF Senior Member
Thread Starter
 
cgladish's Avatar
 
Member Since: Jan 2017
Location: CONCORD CA.
Posts: 594
Thanked 88 Times in 76 Posts
Default

thx! I've been thinking about doing just that ( center stack removal ).just don't want to get to far down the rabbit hole.
I live in condo & don't have freedom previously afforded from my last residence.
cgladish is offline  


Thread Tools
Search this Thread
Quick Reply: clicking noise from behind the radio


Sponsored Ads
Vendor Directory

Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: